Atheros ar9285wb-eg problem on MINT 14

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help

Atheros ar9285wb-eg problem on MINT 14

Postby eyal on Fri Feb 08, 2013 12:48 pm

Hi

I got Mint 14 installed on my Asus S400CA laptop.
When I am connecting to wireless network, it is only working if I'm really close to the source. If I get a few meters away, the signal drops and I can no longer connect.
When I boot the same machine with the Windows 8 installation the wireless is just fine.
The wireless modem is Atheros ar9285wb-eg.
When I tried to install the .inf driver with "windows wireless driver" program, It said that the driver is ok, but then when I rebooted the system didn't recognize any modem in the hardware.

Anyone knows the reason? and how do I fix it? (maybe the n-speed?)
Thanks

$ uname -a
Linux bamboo 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

$ iwconfig
lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"kusiot only"
Mode:Managed Frequency:2.462 GHz Access Point: 00:0E:2E:8F:67:84
Bit Rate=54 Mb/s Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=39/70 Signal level=-71 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:298 Invalid misc:3157 Missed beacon:0
eyal
Level 1
Level 1
 
Posts: 5
Joined: Thu Feb 07, 2013 2:55 am

Linux Mint is funded by ads and donations.
 

Re: Atheros ar9285wb-eg problem on MINT 14

Postby AlbertP on Fri Feb 08, 2013 2:26 pm

Please uninstall the driver from Windows Wireless Drivers. After rebooting when wifi is working again, please run:
Code: Select all
gksudo gedit /etc/modprobe.d/ath9k.conf

In that text editor please put:
Code: Select all
options ath9k nohwcrypt
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Atheros ar9285wb-eg problem on MINT 14

Postby eyal on Sat Feb 09, 2013 5:33 am

Thanks Albert for the fast response,
I did what you said (but I had no need to uninstall the windows driver- it is not installed) and then rebooted the system, but it didn't work:

Code: Select all
$ iwconfig
lo        no wireless extensions.


I erased the file and rebooted and I got it back to the previous state.

Any other suggestions?
Thanks!
eyal
Level 1
Level 1
 
Posts: 5
Joined: Thu Feb 07, 2013 2:55 am

Re: Atheros ar9285wb-eg problem on MINT 14

Postby AlbertP on Sat Feb 09, 2013 9:01 am

In your first post you said you had tried Windows Wireless Drivers to load the .inf file, so it may be that ath9k got blacklisted that way. Could you please run:
Code: Select all
sudo rm /etc/modprobe.d/ndiswrapper.conf
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Atheros ar9285wb-eg problem on MINT 14

Postby eyal on Sat Feb 09, 2013 11:41 am

Sorry, no such file:
the files in the modprobe.d:
Code: Select all
alsa-base.conf               blacklist-oss.conf
ath9k.conf                   blacklist-rare-network.conf
blacklist-ath_pci.conf       blacklist-watchdog.conf
blacklist.conf               dkms.conf
blacklist-firewire.conf      iwlwifi.conf
blacklist-framebuffer.conf   vmwgfx-fbdev.conf
blacklist-modem.conf         
eyal
Level 1
Level 1
 
Posts: 5
Joined: Thu Feb 07, 2013 2:55 am

Re: Atheros ar9285wb-eg problem on MINT 14

Postby AlbertP on Sun Feb 10, 2013 11:08 am

Ok, so setting options ath9k nohwcrypt did not work. Make sure you didn't mistype it. A typo there would indeed cause the wireless to disappear completely. Apart from that I don't know why setting this in ath9k.conf would make wlan0 disappear from the iwconfig output.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Atheros ar9285wb-eg problem on MINT 14

Postby eyal on Sun Feb 10, 2013 2:54 pm

Hi,
did you forget =1 ?:
Code: Select all
options ath9k nohwcrypt=1

I just tested it, it doesn't improve the signal strength...
Thanks
eyal
Level 1
Level 1
 
Posts: 5
Joined: Thu Feb 07, 2013 2:55 am

Re: Atheros ar9285wb-eg problem on MINT 14

Postby AlbertP on Mon Feb 11, 2013 6:38 am

The ath9k_htc needs =1 indeed when setting nohwcrypt (else it does not load), but all other Atheros drivers including ath9k should do the same thing when there is no =1.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Atheros ar9285wb-eg problem on MINT 14

Postby eyal on Mon Feb 11, 2013 6:45 am

Thanks Albert.
Anyway, it didn't help for the signal strength...
Any other ideas?
Thanks
eyal
Level 1
Level 1
 
Posts: 5
Joined: Thu Feb 07, 2013 2:55 am

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: No registered users and 8 guests