Problems with quote keys on UK MacBook 1,1 with Mint 14 MATE

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

Problems with quote keys on UK MacBook 1,1 with Mint 14 MATE

Postby jam on Mon Feb 11, 2013 8:39 am

I've just installed Mint 14 MATE on a UK model MacBook 1,1 (2006) which is in good condition. (Completely wiping the old install of OS X.) Almost everything seems great - wireless, trackpad (though I've not tested the iSight camera) - but there is an apparent software or configuration problem with the keyboard. It takes two presses of the ' (quote) or " (shift-quote, i.e double quote) or ` (backquote) or ~ (shift-backquote, i.e. tilde) to get each one of those characters displayed in any application, but they are then not recognised as that character e.g. bash doesn't recognise the quotes. I've not found any other odd keys. This is an 'out of the box' installation - I've not subsequently tweaked anything other than what I mention below.

I've searched the forums for any other report of this problem, no luck. I used the Package Manager to ensure that my installation was up to date, immediately after installation.

Under 'Control Centre' -> 'Keyboard' -> 'Layouts' I initially tried the keyboard layout 'English (UK) (UK, Macintosh international)', but 'English (UK) English (UK, Macintosh)' does the same. I don't understand the difference between that setting and the separate one for 'Keyboard model' lower down the 'Layouts' panel, which I have set to 'MacBook/MacBook Pro (Intl)' and sometimes 'MacBook/MacBook Pro' - the problem occurs with both of those.

There were no error messages during installation, but when I alter the keyboard model under 'Control Centre' -> 'Keyboard Preferences' -> 'Layouts' with 'Move up' (to get the layout I want at the top of the list) I see a popup error box which contains the text:

Code: Select all
Error activating XKB configuration.

It can happen under various circumstances:
* a bug in the libxklavier library
* a bug in X server (xkbcomp, xmodmap utilities)
* X server with incompatible libxkbfile implementation

X server version data:
The X.org Foundation
11300000

If you report this situation as a bug, please include:
* The result of xprop -root | grep XKB
* The result of mateconftool-2 -R /desktop/mate/peripherals/keyboard/kbd


The results of those shell commands are:

Code: Select all
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "pc105", "gb", "mac_intl", ""
_XKB_RULES(STRING) = "evdev", "pc105", "gb", "mac_intl", "terminate:ctrl_alt_bksp"


and:

Code: Select all
model = macbook79
layouts = [gb     mac_intl,gb      mac]
options = [grp grp:shift_caps_toggle]


Any ideas?
jam
Level 1
Level 1
 
Posts: 2
Joined: Mon Feb 11, 2013 7:47 am

Linux Mint is funded by ads and donations.
 

Re: Problems with quote keys on UK MacBook 1,1 with Mint 14

Postby xenopeek on Mon Feb 11, 2013 8:48 am

This sounds like you have picked a keyboard layout out with dead keys. which exhibits this Windows-like behavior of making your keyboard act like a drunken moron (my opinion). To type a ', " or ~ on such keyboard layouts, you would press that key and afterwards press the spacebar key. That will generate the correct character. Dead keys are a way to easily add diacritics, you can type ' followed by e to get é, " and e for ë, ~ and n for ñ, and so on. Try to find a keyboard layout without dead keys that works for your MacBook.

I'm using "English (US)" on my normal keyboard, and this doesn't have dead keys. On the layouts tab of the keyboard layout program you would click the options button and set a key for "compose key position" to be able to use diacritics. I have it set to right ctrl, so when I press right-ctrl with ' and then press e, I get é. But pressing ' without the compose key gives me ' immediately.

Get rid of the layout using dead keys :wink:
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15284
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Problems with quote keys on UK MacBook 1,1 with Mint 14

Postby jam on Mon Feb 11, 2013 9:37 am

I'd no idea what a 'dead key' was before you explained it just now - I quite agree that it seems an awkward way to get accented and other special characters! I'm a Brit, and don't want accented characters. Alas, my keyboard is one with a British layout. I see now that I could have chosen the layout "English (UK) English (UK, international with dead keys)" but didn't - I've never selected it. Neither of the two layouts I tried mention 'dead keys' in their names.

So, although I'll follow your advice and tinker with layouts until I find one which matches my key tops and which doesn't have the problem, I still think that there's a bug or two here.

Many thanks for your reply.
jam
Level 1
Level 1
 
Posts: 2
Joined: Mon Feb 11, 2013 7:47 am

Re: Problems with quote keys on UK MacBook 1,1 with Mint 14

Postby buja on Wed Dec 25, 2013 11:56 am

Thanks for this post!

I had the same problem on my desktop with Maya, diacritics were easy, but single and double quotes took an extra spacebar press. This was especially annoying after I realised my laptop (with LMDE) did not need the extra space. But now both machines handle single and double quotes and diacritics the same way, which makes life a lot easier. :)
buja
Level 1
Level 1
 
Posts: 2
Joined: Mon Dec 17, 2012 6:48 pm
Location: The Netherlands


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 10 guests