Dual Boot Problem

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Dual Boot Problem

Postby mrogovin on Sun Feb 10, 2013 9:46 pm

I have a HD partitioned for WIndows XP and Mint 14 (/, /home, swap). After following the installation instructions (or so I thought), my system only boots to Mint and I cannot get to Windows (some might see this as a plus, but since my current printer only works with Windows and the rest of the famly is skeptical of changing over, I need WIndows access for a while). I am looking for a way to reconfigure the system so that I get an option on restart/power on to boot to either WIndows XP or Mint, and to do this with a minimum of manual coding/config file editing, if at all possible. I did search for how to create a dual boot system, but admit that the techie stuff was going over this poor newbie's head just a bit. I read about EasyBCD, but since it runs in Windows and I can't get there, that does not appear to be a viable option at the moment. If that is the best way, perhaps guide me to how I can boot to WIndows? Other ideas welcome too of course. Would appreciate any kind soul helping out.
mrogovin
Level 1
Level 1
 
Posts: 15
Joined: Fri Feb 08, 2013 5:14 pm

Linux Mint is funded by ads and donations.
 

Re: Dual Boot Problem

Postby wayne128 on Sun Feb 10, 2013 9:57 pm

To dual boot Mint and WinXP, you have a few ways

1. Using WinXP to controm MBR.

refer to this thread on how to change WinXP boot.ini to add Mint
viewtopic.php?f=46&t=118207&p=653281&hilit=windows+boot.ini+#p653348


2. Using Default Mint boot loader to control MBR,
Mint14 uses grub2.00
and it should have already work during the installation.
Since yours is not working, one possibility is corrupted grub2 during installation.
In that case, you can do these

a. use simplest method, just reinstall grub2 to MBR

b. use a more sure method, download a repair disk and use it to repair your grub
https://help.ubuntu.com/community/Boot-Repair

3. use other boot loader... not necessary unless above two method still do not work

By the way, I do not think EasyBCD can work on WinXP, at least that was what I learned sometime ago and they said it on their website, however, I am not too current on latest version, just go check their FAQ.
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: Dual Boot Problem

Postby mrogovin on Mon Feb 11, 2013 10:57 am

Thanks. Used Boot Repair but it did not work. Reinstalled Grub, no change, boots to Linux.

Tried again, this time choosing Restore MBR. This changed the boot to Windows, but not dual boot.

The log files from each session are

http://paste2.org/p/2848858
http://paste2.org/p/2848869

Any suggestions would be welcome.
mrogovin
Level 1
Level 1
 
Posts: 15
Joined: Fri Feb 08, 2013 5:14 pm

Re: Dual Boot Problem

Postby FireSoul on Mon Feb 11, 2013 2:21 pm

mrogovin wrote:I have a HD partitioned for WIndows XP and Mint 14 (/, /home, swap). After following the installation instructions (or so I thought), my system only boots to Mint and I cannot get to Windows (some might see this as a plus, but since my current printer only works with Windows and the rest of the famly is skeptical of changing over, I need WIndows access for a while). I am looking for a way to reconfigure the system so that I get an option on restart/power on to boot to either WIndows XP or Mint, and to do this with a minimum of manual coding/config file editing, if at all possible. I did search for how to create a dual boot system, but admit that the techie stuff was going over this poor newbie's head just a bit. I read about EasyBCD, but since it runs in Windows and I can't get there, that does not appear to be a viable option at the moment. If that is the best way, perhaps guide me to how I can boot to WIndows? Other ideas welcome too of course. Would appreciate any kind soul helping out.


Hello.
Perhaps you have right dual boot,but you wait too long and Mint run,more than 10 sec.

Look when you open computer and you see at screen writed Linux Mint, some line other start for Mint and Windows XP.Then you must use arrow buttoms and choice Windows XP /enter.
If you don't take windows xp it run mint.
User avatar
FireSoul
Level 3
Level 3
 
Posts: 126
Joined: Mon Jan 28, 2013 5:15 am

Re: Dual Boot Problem

Postby mrogovin on Mon Feb 11, 2013 3:24 pm

I got it working. Not perfect, but I do have a menu. Linux opened with "serious errors" in the home folder, but worked fine when I ignored the error. Probably something went wrong when I ran boot repair again and it crashed forcing a hard restart. But then ran it again and then it worked. Hopefully the error will not reappear, but I can always recreate /home since it only has a few settings and no files so far.
mrogovin
Level 1
Level 1
 
Posts: 15
Joined: Fri Feb 08, 2013 5:14 pm

Re: Dual Boot Problem

Postby lmarmisa on Mon Feb 11, 2013 5:43 pm

I have several dual boot systems and I like to use the GRUB_SAVEDEFAULT option of GRUB 2. If you activate this option, GRUB will remember the last OS selected (XP or Mint) until a new OS is manually selected from the GRUB 2 menu. I think this is a very useful feature.

You can also deactivate the hidden menu option of GRUB. If so, you have to comment the GRUB_HIDDEN_TIMEOUT parameter.

If you want to reduce the GRUB timeout, you can do it too. I will change timeout to 5 secs in this example.

This is the procedure to follow if you wish to change some GRUB2 parms. Open a terminal and become root with this command:

Code: Select all
sudo su


Then edit the file /etc/default/grub using your prefered editor (gedit, pluma, nano, vi, etc):

Code: Select all
pluma /etc/default/grub


I recommend to change the first lines to these contents:

Code: Select all
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

....



Save and exit.

Finally, you have to update GRUB typing this command:

Code: Select all
update-grub


Reboot the system and check the new features of GRUB.

Best regards,

Luis
User avatar
lmarmisa
Level 2
Level 2
 
Posts: 91
Joined: Wed Feb 15, 2012 5:22 am
Location: Madrid - Spain

Re: Dual Boot Problem

Postby mrogovin on Wed Feb 13, 2013 10:37 am

Thanks Luis I may try that. The system works ok now, but each time I boot linux, I get a serious error message. Linux appears to run fine despite this, but I suspect I may have to reinstall.
mrogovin
Level 1
Level 1
 
Posts: 15
Joined: Fri Feb 08, 2013 5:14 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: avtovaz, Barry87, Bing [Bot], Pastcal, rossi46 and 22 guests