Wireless drops or slows Ralink RT2561/RT61 Mint 14

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Wireless drops or slows Ralink RT2561/RT61 Mint 14

Postby lvikng56 on Mon Feb 11, 2013 7:07 pm

Hi I'm running 32-bit Mint 14 with cinnamon. My wireless will sometimes take a long time to connect, but sometimes will work fine. After connecting it will sometimes work for a long period of time, but then drop in speed to an unusable level without disconnecting, eventually it will disconnect sometimes.

I have read a lot about various similar posts related to not connecting or dropping out and it seems to often be related to a different driver and the resolution is update, it seems I have the latest operating system and a different driver where that is not the case so I'm writing a new post. Years ago I would have just shotgunned the problem and eventually have solved it, but would have tried so much in the process I would be unsure what the problem or solution was in the first place, so I would like to avoid that this time and actually get at the heart of the matter. I have been using linux for a while, but have rarely encountered problems in the past so may not be the best with this sort of thing, clarity and simplicity would be greatly appreciated in helping identify what the problem is, how to fix it, and why exactly this is fixing the problem at hand.

From the hardware side, the Ralink PCI card does not seem to work very well on Windows 7 , so I'm not sure it is a fault of the operating system, but I read Ralink cards don't work well on Windows 7 so that is not a very good control either.

I used to have Mint 12 on this machine and I don't remember many problems but I barely used it and since the problem is intermittent I may not have picked up on any pattern.

I have also noticed it fails less frequently when closer to the router. So I am running into that age old issue of a problem that's hard to replicate as when I carry it over to the router to use Ethernet to diagnose and attempt to fix the problem, via update or whatever, it appears solved until I carry it back to where it was and the problem resurfaces again days later.

That being said, no other computer I have experiences problems related to signal strength from that distance, but here is a sketchy complication, I have an alfa usb wifi adapter that I use for testing and such which has, thus far, been very reliable in that regard, but it too will have a similar problem of a crazy drop in speed to completely unusable levels and drop out on an occasion. This has me very confused. It has a signal strength of about 90% in that location so signal strength seems to not be the problem.

I want to focus on the Ralink PCI card for the time being even though the problem could be entirely unrelated given what I know about the rest of the situation.

Forums, I channel you for guidance here.

Code: Select all
inxi -Fc 0
System:    Host: GX620 Kernel: 3.5.0-17-generic i686 (32 bit) Desktop: Gnome Distro: Linux Mint 14 Nadia
Machine:   System: Dell product: OptiPlex GX620
           Mobo: Dell model: 0HH807 Bios: Dell version: A06 date: 02/20/2006
CPU:       Single core Intel Pentium 4 CPU (-HT-) cache: 2048 KB flags: (lm nx sse sse2 sse3)
           Clock Speeds: 1: 2800.00 MHz 2: 2800.00 MHz
Graphics:  Card: NVIDIA G84 [GeForce 8400 GS] X.Org: 1.13.0 driver: nvidia Resolution: 1920x1080@60.0hz
           GLX Renderer: GeForce 8400 GS/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 304.43
Audio:     Card-1: Intel 82801G (ICH7 Family) AC'97 Audio Controller driver: snd_intel8x0 Sound: ALSA ver: 1.0.25
           Card-2: VIA VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller driver: snd_ice1724
Network:   Card-1: Ralink RT2561/RT61 802.11g PCI driver: rt61pci
           IF: wlan0 state: up mac: 78:44:76:98:f1:10
           Card-2: Broadcom NetXtreme BCM5751 Gigabit Ethernet PCI Express driver: tg3
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:13:72:72:89:99
Drives:    HDD Total Size: 2080.4GB (52.7% used) 1: USB id: /dev/sda model: My_Book_1130 size: 2000.4GB
           2: id: /dev/sdb model: WDC_WD800JD size: 80.0GB
Partition: ID: / size: 14G used: 12G (92%) fs: ext4 ID: swap-1 size: 2.14GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 145 Uptime: 3:33 Memory: 674.9/2015.4MB Client: Shell inxi: 1.8.4
lvikng56
Level 1
Level 1
 
Posts: 1
Joined: Mon Feb 11, 2013 3:43 pm

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: csakcsek, JeremyB, norry, PatH57 and 6 guests