nvidia-detector "none"

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

nvidia-detector "none"

Postby Ema0404 on Mon Feb 11, 2013 12:20 pm

Hi all,
I installed linux mint 14. I have an Acer Aspire 5755G with a nVidia GeForce GT 540M. I tried to install manually the linux drivers but the console said that the video card wasn't detected, infact typing
Code: Select all
nvidia-detector

the output is
Code: Select all
none

What does this mean?
Ema0404
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 06, 2013 11:16 am

Linux Mint is funded by ads and donations.
 

Re: nvidia-detector "none"

Postby zerozero on Tue Feb 12, 2013 6:08 am

before going any further with any driver installation, open a terminal and share with us the output of
Code: Select all
inxi -SGx
that is an optimus enabled technology card and driver installation can't be done the usual way
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: nvidia-detector "none"

Postby debbie on Tue Feb 12, 2013 6:10 am

Adding ubuntu-x-swat and an update/upgrade/reboot may help solve your problem
debbie
Level 1
Level 1
 
Posts: 29
Joined: Tue Jan 15, 2013 6:37 am
Location: Cornwall UK

Re: nvidia-detector "none"

Postby Ema0404 on Tue Feb 12, 2013 8:17 am

output
Code: Select all
user@host ~ $ inxi -SGx
System:    Host: Dra216Sto8542 Kernel: 3.5.0-17-generic x86_64 (64 bit, gcc: 4.7.2)
           Desktop: Gnome Distro: Linux Mint 14 Nadia
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GF108 [GeForce GT 540M] bus-ID: 01:00.0
           X.Org: 1.13.0 driver: intel Resolution: 1366x768@60.0hz
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A


what is ubuntu-x-swat? and what should I do for add it?

However I installed nvidia drivers (downloaded from the nvidia's official site), even if it said that drivers don't work. Not a good idea: my resolution was 640x480. I correct it editing xorg-conf like this:
Code: Select all
user@host ~ $ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.51  (buildmeister@swio-display-x86-rhel47-08.nvidia.com)  Tue Sep 18 18:26:36 PDT 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
    HorizSync       30 - 107
    VertRefresh     48 - 120
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "intel"                                      #<---- This is what I changed
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

and it seems to work.
Ema0404
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 06, 2013 11:16 am

Re: nvidia-detector "none"

Postby zerozero on Tue Feb 12, 2013 8:28 am

Ema0404 wrote:what is ubuntu-x-swat? and what should I do for add it?
it is useless in the gpu configuration you have.

Ema0404 wrote: I correct it editing xorg-conf like this:
this was a smart trick but i believe that it didn't addressed the main issue
Ema0404 wrote:GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A
< this one: according to this output you have no direct rendering (no 3d acceleration) furthermore you can't use the nvidia card in a per-app basis like you could with bumblebee https://wiki.ubuntu.com/Bumblebee
(now a warning note: bumblebee doesn't like to be installed when it detects traces of other nvidia drivers installations; it will fail)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: nvidia-detector "none"

Postby Ema0404 on Tue Feb 12, 2013 9:34 am

I have already installed bumblebee but it doesn't work. Infact when I tried to configure nvidia settings with "optirun" the program didn't see nvidia card. Now, it doesn't like nvidia drivers (maybe). This is the output
Code: Select all
user@host ~ $ optirun nvidia-settings
[ 1241.820738] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the

[ 1241.820817] [ERROR]Aborting because fallback start is disabled.
Ema0404
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 06, 2013 11:16 am

Re: nvidia-detector "none"

Postby Perceptor on Thu Jun 13, 2013 3:44 pm

Did anyone manage to find a solution to this problem? I have the same issue...

Code: Select all
user@Orion ~ $ nvidia-detector
none


Code: Select all
user@Orion ~ $ nvidia-smi
NVIDIA: could not open the device file /dev/nvidiactl (No such file or directory).
NVIDIA-SMI has failed because it couldn't communicate with NVIDIA driver. Make sure that latest NVIDIA driver is installed and running.


Code: Select all
user@Orion ~ $ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module  304.88  Wed Mar 27 14:26:46 PDT 2013
GCC version:  gcc version 4.7.2 (Ubuntu/Linaro 4.7.2-2ubuntu1)


Code: Select all
user@Orion ~ $ inxi -SGx
System:    Host: Orion Kernel: 3.5.0-17-generic x86_64 (64 bit, gcc: 4.7.2) Desktop: N/A Distro: Linux Mint 14 Nadia
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GF106 [GeForce GT 555M] bus-ID: 01:00.0
           X.Org: 1.13.0 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A


I am trying to use CUDA and I'm guessing that the fact that my nvidia driver isn't being used my system might be my problem...
Perceptor
Level 1
Level 1
 
Posts: 1
Joined: Thu Jun 13, 2013 3:36 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: jekern77 and 13 guests