(CLOSED) Newly installed DVD/CDROM drive not found

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

(CLOSED) Newly installed DVD/CDROM drive not found

Postby debbie on Tue Feb 12, 2013 11:41 am

New CD/DVD Drive not showing/working

by debbie on Tue Feb 12, 2013 9:21 am

Last night my old IDE DVD drive was taken out and a new SATA drive put in place of it complete with an 'IOMAH' Bi-Directional IDE/SATA Converter kit. The problem now though is that it fails to work when I put a music CD in. The light on the front of the drive on my pc tower appears briefly when I put a CD in then it goes out and nothing else happens.


I have tried to find out more about this and some people mention /etc/fstab folder. Mine is actually /etc/fstab.d and there is nothing at all inside this folder.

I tried this in the Terminal;

debbie@debbie-GT5042B ~ $ mount
/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/debbie/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=debbie)
debbie@debbie-GT5042B ~ $

Should I have unmounted the previous DVD/CD drive before removing it? This is the second time I have had to install a new drive, and the first time I installed one, which was temporary, it was detected straight away. That time I was using an IDE type with the wide cable.

Last edited by debbie on Tue Feb 12, 2013 3:16 pm, edited 2 times in total.
debbieLevel 1
Posts: 19Joined: Tue Jan 15, 2013 11:37 amLocation: Cornwall UK
Last edited by debbie on Tue Feb 12, 2013 3:27 pm, edited 1 time in total.
debbie
Level 1
Level 1
 
Posts: 29
Joined: Tue Jan 15, 2013 6:37 am
Location: Cornwall UK

Linux Mint is funded by ads and donations.
 

Re: Newly installed DVD/CDROM drive not found

Postby viking777 on Tue Feb 12, 2013 12:31 pm

Can you post the output of the command:

Code: Select all
inxi -d


It should tell us if your optical device is discovered or not.

BTW (and this is probably not relevant to your present question) fstab is a file, not a folder, so if you look a little bit further down the /etc folder you will see it. Linux will not work without it, so it is there.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Newly installed DVD/CDROM drive not found

Postby debbie on Tue Feb 12, 2013 12:52 pm

okay so here is the output, Viking;

debbie@debbie-GT5042B ~ $ inxi -d
Drives: HDD Total Size: 200.0GB (3.9% used) 1: /dev/sda WDC_WD2000JS 200.0GB
Optical: No optical drives detected.
debbie@debbie-GT5042B ~ $

and thanks for that comment about the fstab file. Yes you've guessed it, I'm still Windows-brainwashed lol.
debbie
Level 1
Level 1
 
Posts: 29
Joined: Tue Jan 15, 2013 6:37 am
Location: Cornwall UK

Re: Newly installed DVD/CDROM drive not found

Postby cecar on Tue Feb 12, 2013 1:04 pm

Your drives jumper setting needs to be set to Master i think. Check your drives jumpersetting.
cecar
Level 4
Level 4
 
Posts: 365
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden

Re: Newly installed DVD/CDROM drive not found

Postby debbie on Tue Feb 12, 2013 1:10 pm

Can you tell me what commands I must use?
debbie
Level 1
Level 1
 
Posts: 29
Joined: Tue Jan 15, 2013 6:37 am
Location: Cornwall UK

Re: Newly installed DVD/CDROM drive not found

Postby cecar on Tue Feb 12, 2013 1:16 pm

It is a set of pins on your drive. Looks something like this.

Image
cecar
Level 4
Level 4
 
Posts: 365
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden

Re: Newly installed DVD/CDROM drive not found

Postby debbie on Tue Feb 12, 2013 1:24 pm

Before I take the computer off the shelf, I want to ask if as it's a SATA DVD/CDROM would it have a master/slave connection?
debbie
Level 1
Level 1
 
Posts: 29
Joined: Tue Jan 15, 2013 6:37 am
Location: Cornwall UK

Re: Newly installed DVD/CDROM drive not found

Postby cecar on Tue Feb 12, 2013 1:28 pm

debbie wrote:Before I take the computer off the shelf, I want to ask if as it's a SATA DVD/CDROM would it have a master/slave connection?


Oh... I misunderstood. I thought it was a IDE drive. I really dont know if SATA CDROM's has jumpers.
cecar
Level 4
Level 4
 
Posts: 365
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden

Re: Newly installed DVD/CDROM drive not found

Postby debbie on Tue Feb 12, 2013 1:30 pm

Yes it had just one connection lead to it's own motherboard and another to the power supply. Nice and easy, except it doesn't work :D
debbie
Level 1
Level 1
 
Posts: 29
Joined: Tue Jan 15, 2013 6:37 am
Location: Cornwall UK

Re: Newly installed DVD/CDROM drive not found

Postby cecar on Tue Feb 12, 2013 1:33 pm

Then i dont have a clue at the moment. Sorry.... :roll:
cecar
Level 4
Level 4
 
Posts: 365
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden

Re: Newly installed DVD/CDROM drive not found

Postby viking777 on Tue Feb 12, 2013 1:55 pm

The fact that inxi says you have no optical drive suggests to me that it is wrongly connected even though you said it was easy. I can only suggest you check the connections again, can't think of anything else right now. One thing that is very easy to check - does the drive tray open when you press the button - if it does then at least you know the drive has a power supply, in which case it could be the connection to the motherboard drive controller that is either loose or maybe in the wrong place.

OTOH it could be something to do with this 'IOMAH' Bi-Directional IDE/SATA Converter kit' which I have never even heard of, so if it was I couldn't help you with it.

A review on Amazon said:

It is important to check which of two identical connectors takes the SATA lead.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Newly installed DVD/CDROM drive not found

Postby debbie on Tue Feb 12, 2013 2:09 pm

Okay I have read and understood your reply, and yes the tray does indeed open and shut with a press of the button so the power supply is getting through. Mr. Fixit is coming now to open the casing and check the connections are aligned correctly and then I will get back to you straight away.

Regards, Debbie
debbie
Level 1
Level 1
 
Posts: 29
Joined: Tue Jan 15, 2013 6:37 am
Location: Cornwall UK

Re: Newly installed DVD/CDROM drive not found

Postby debbie on Tue Feb 12, 2013 3:24 pm

You were spot on, Viking! The connections were incorrect but have now been fixed and it's working a treat. I'm listening to my cd now as I type this and I apologise for what must seem a waste of time to you both. You have been very helpful and now I can close this post, thankfully :lol:
debbie
Level 1
Level 1
 
Posts: 29
Joined: Tue Jan 15, 2013 6:37 am
Location: Cornwall UK

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], dontNull, Google Adsense [Bot] and 23 guests