Rhythmbox problem after upgrade.

Questions about applications and software
Forum rules
Before you post please read how to get help

Rhythmbox problem after upgrade.

Postby orys on Sat Feb 09, 2013 9:37 pm

I had some minor problems with rhytmbox - getting stuck, not playing full files and skipping to next ones...

So I decided to upgrade it, and it turned out to be a mistake.

First I had that problem with canberra-something, which I solved as per another thread at this forum.

But it still do not starts. When I run it from terminal I got this:

Code: Select all
orys@orysiownia ~ $ rhythmbox
 
(rhythmbox:2335): Rhythmbox-WARNING **: couldn't load fallback icon rhythmbox-missing-artwork: Brak ikony "rhythmbox-missing-artwork" w motywie
Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/gi/types.py", line 235, in mro
return mro(cls)
File "/usr/lib/python2.7/dist-packages/gi/types.py", line 249, in mro
bases_of_subclasses += list(map(mro, C.__bases__)) + [list(C.__bases__)]
File "/usr/lib/python2.7/dist-packages/gi/types.py", line 249, in mro
bases_of_subclasses += list(map(mro, C.__bases__)) + [list(C.__bases__)]
File "/usr/lib/python2.7/dist-packages/gi/types.py", line 249, in mro
bases_of_subclasses += list(map(mro, C.__bases__)) + [list(C.__bases__)]
File "/usr/lib/python2.7/dist-packages/gi/types.py", line 249, in mro
bases_of_subclasses += list(map(mro, C.__bases__)) + [list(C.__bases__)]
File "/usr/lib/python2.7/dist-packages/gi/types.py", line 254, in mro
not_head = [s for s in bases_of_subclasses if candidate in s[1:]]
File "/usr/lib/python2.7/dist-packages/gi/module.py", line 243, in __getattr__
return getattr(self._introspection_module, name)
File "/usr/lib/python2.7/dist-packages/gi/module.py", line 154, in __getattr__
interfaces = tuple(interface for interface in get_interfaces_for_object(info)
File "/usr/lib/python2.7/dist-packages/gi/module.py", line 83, in get_interfaces_for_object
interfaces.append(getattr(module, name))
File "/usr/lib/python2.7/dist-packages/gi/module.py", line 243, in __getattr__
return getattr(self._introspection_module, name)
File "/usr/lib/python2.7/dist-packages/gi/module.py", line 105, in __getattr__
self.__name__, name))
AttributeError: 'gi.repository.Gio' object has no attribute 'ActionMap'
**
ERROR:/build/buildd-pygobject_3.1.0-2-i386-S1vdYv/pygobject-3.1.0/gi/_gobject/pygobject.c:929:pygobject_new_full: assertion failed: (tp != NULL)
Przerwane
orys@orysiownia ~ $


I never seen anything smilar before, so I have no idea what to do with it. Anyone can help me?
orys
Level 1
Level 1
 
Posts: 12
Joined: Wed May 23, 2012 1:15 pm

Linux Mint is funded by ads and donations.
 

Re: Rhythmbox problem after upgrade.

Postby jungle_boy on Mon Feb 11, 2013 12:13 pm

Rhythmbox has always been problematic...
LM17.1 Mate (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1225
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: Rhythmbox problem after upgrade.

Postby orys on Mon Feb 11, 2013 12:36 pm

It wasn't for me... But thank you for your helpful insight :)

Btw: I just installed brand new Mint Debian on my netbook, there is the same problem. Banshee is working (unlike as on my desktop, where I have to listen to music from Clementine, which is very annoying, especially that multimedia keys at the keyboard does not work. I want my Rhythmbox back :P).

Apart from that I did not managed to find anything that could help me solve my problem, so if anyone have ideas, I would be grateful for your advice.
orys
Level 1
Level 1
 
Posts: 12
Joined: Wed May 23, 2012 1:15 pm

Re: Rhythmbox problem after upgrade.

Postby orys on Thu Feb 14, 2013 7:56 pm

Searched through the net and I have no idea where to even start, so I decided to install the previous version, but in synaptic that option (Force version) is unavailable. Does it mean that I can't do it, or it is still possible through apt-get?
orys
Level 1
Level 1
 
Posts: 12
Joined: Wed May 23, 2012 1:15 pm

Re: Rhythmbox problem after upgrade.

Postby zerozero on Thu Feb 14, 2013 8:22 pm

are you (re)using a HOME from previous installs?
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6493
Joined: Tue Jul 07, 2009 2:29 pm

Re: Rhythmbox problem after upgrade.

Postby orys on Thu Feb 14, 2013 8:36 pm

zerozero wrote:are you (re)using a HOME from previous installs?


I guess not, as I installed brand new system on my netbook from scratch and there is the same problem.

I am not really sure what do you mean. On my dekstop It worked very well for years before, I upgraded it, it stopped to work. I removed it completely and then installed again, still not working.

I don't have any file or folder "rhythmbox" in my /home.
orys
Level 1
Level 1
 
Posts: 12
Joined: Wed May 23, 2012 1:15 pm

Re: Rhythmbox problem after upgrade.

Postby orys on Fri Feb 15, 2013 11:15 pm

I am giving up, I downloaded previous version's .deb package, installed it and all works fine again :)
orys
Level 1
Level 1
 
Posts: 12
Joined: Wed May 23, 2012 1:15 pm

Re: Rhythmbox problem after upgrade.

Postby jungle_boy on Sat Feb 16, 2013 8:43 am

OK!

Please, what version of linux mint are you using (11, 12, 13, 14, mate, cinnamon, kde, xfce, lxde, fluxbox), and what Rhythmbox you downloaded?
LM17.1 Mate (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1225
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: Rhythmbox problem after upgrade.

Postby orys on Sat Feb 16, 2013 11:31 am

I hope that's all you need:

Code: Select all
orys@orysiownia ~ $ cat /etc/*-release
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=1
DISTRIB_CODENAME=debian
DISTRIB_DESCRIPTION="Linux Mint Xfce Edition"

orys@orysiownia ~ $ uname -or
2.6.39-2-486 GNU/Linux

orys@orysiownia ~ $ cat /etc/debian_version
wheezy/sid



And I installed rhythmbox and rhythmbox-plugins in version 0.12.8-3
orys
Level 1
Level 1
 
Posts: 12
Joined: Wed May 23, 2012 1:15 pm

Re: Rhythmbox problem after upgrade.

Postby jungle_boy on Sat Feb 16, 2013 12:09 pm

Ok.

Thanks!
LM17.1 Mate (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1225
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 19 guests