Display Issues Vesa/Radeon fail, refresh rate is 0.0 hz

Forum rules
Before you post please read this

Display Issues Vesa/Radeon fail, refresh rate is 0.0 hz

Postby ramk on Sat Feb 16, 2013 2:22 pm

Hi

My machine is a Thinkpad t60 - with an ATI x1300 graphics card. Its triple booted with the original windows xp along with linux mint 11 and linux mint 14 - xfce.

My core OS is the LM 14 xfce (rather should be). I recently upgraded from lm13 xfce to lm 14 xfce . And since then have been in all sorts of display issues- Namely

1. LM 14 fails to load any appropriate driver for my x1300 graphics card. AMD stopped support for this type of card sometime back and lm is supposed to use open source drivers (i think radeon) but this fails as seen in data below

Because of this my display i stuck at 1280x960 or lower instead of 1400 x 1050

Another problem is my screen suddenly goes haywire and becomes a runny portrait in oil and psychedelic colors which is solved only by a reboot.

Code: Select all
 $ inxi -Gx
Graphics:  Card: Advanced Micro Devices [AMD] nee ATI M52 [Mobility Radeon X1300] bus-ID: 01:00.0
           X.Org: 1.13.0 drivers: ati,radeon (unloaded: fbdev) FAILED: vesa Resolution: 1400x1050@0.0hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.2, 128 bits) GLX Version: 2.1 Mesa 9.2-devel Direct Rendering: Yes


2. The refresh rate is stuck at 0.0 hz -
am not sure what it will do - but am sure it can't be anything good,

3. When i use alt f1 to shift / open another terminal session my screen gets horizontol colored lines and the home session then becomes a nasty paint job requiring a reboot

4. Cannot attach another monitor - my os does not pick it up - even on a restart

5. Boot up needs nomodeset as a parameter in grub - (not a huge headache but incase this is relevant)


**
Have tried to follow many guides and solutions from the net and none of them have remotely come close to addressing the issues

some places i have seen and followed are
Unblacklisting radeon - http://ubuntuforums.org/showthread.php?t=1955100&page=2


Removing fglrx etc
Ubuntu_Oneiric_Installation_Guide#Can.27t_remove_fglrx_with_dpkg_.28diversion_issue.29

xrandr resolution problem with vesa driver
http://forums.opensuse.org/english/get- ... river.html

current xrandr is given below


Code: Select all
$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1400 x 1050, current 1400 x 1050, maximum 1400 x 1050
default connected 1400x1050+0+0 0mm x 0mm
   1400x1050       0.0*


Code: Select all
$ glxinfo |grep "OpenGL"
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.2, 128 bits)
OpenGL version string: 2.1 Mesa 9.2-devel
OpenGL shading language version string: 1.20
OpenGL extensions:


**
Need your advice on this issue

**
I don't want to use legacy drivers or resort to an older package - with updates and all it will be a pain, worst case scenario is to shift back to lm13 which worked well .

So would be very happy to get advice and somehow get my system working
**
l
ramk
Level 1
Level 1
 
Posts: 6
Joined: Thu Jul 07, 2011 8:47 am

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 4 guests