COuld not update ICEauthority file

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

COuld not update ICEauthority file

Postby popoff on Fri Oct 19, 2012 9:49 am

after the login window pops up:
COuld not update ICEauthority file /home/spas/.ICEauthority

after this:

Your session lasted less than 10 seconds.
If you did not make yourself a session, it may mean that there is a problem in the installation or there is not enough disk space. Try to enter one of the failsafe sessions to determine how to fix the problem.

View details (file ~ /. Xsession-errors)

/ etc / mdm / Xsession: Beginning session setup
localuser: spas being added to access control list

upd. I use LMDE with Gnome3.
popoff
Level 1
Level 1
 
Posts: 3
Joined: Fri Oct 19, 2012 7:36 am

Linux Mint is funded by ads and donations.
 

Re: COuld not update ICEauthority file

Postby xenopeek on Fri Oct 19, 2012 11:21 am

Boot from rescue mode (in the GRUB boot menu you can select that; hold shift during boot to get the GRUB boot menu to show if not shown by default). Drop to the root console. Run the following two commands (one at a time) should hopefully fix this:
chown username:groupname /home/username/.ICEauthority
chmod 0600 /home/username/.ICEauthority

Replace username and groupname with your own username and groupname (by default your username is the same as your groupname). Username is the one you log in with.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15285
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: COuld not update ICEauthority file

Postby popoff on Mon Oct 22, 2012 8:55 am

it's didn't work. May I entered wrong personal information, example groupname? how i can find it?
popoff
Level 1
Level 1
 
Posts: 3
Joined: Fri Oct 19, 2012 7:36 am

<Solved> Could not update ICEauthority file

Postby timber on Tue Nov 13, 2012 1:19 am

I realize this is an older post but I just experienced a similar problem with not being able to logon and the message "could not update .ICEauthority file".
Of course, my immediate response was panic ... :shock:

Background:
Using LMDE latest updates (UP5).
/ and /home are on separate partitions.
Problem arose when I installed a version of Puppy Linux on a different partition.

I'm not sure why or how it happened but immediately following the Puppy install I got the dreaded "could not update .ICEauthority file" message.
I wasn't able to fix the problem from the LiveDVD but was able to fix it from the LMDE logon by going to the console there (as another user here suggests).
In this case the problem was not with the .ICEauthority permissions (even though it appeared that way from the message) but (as noted below) with the "/home" folder permissions.

I got to the console (from logon screen) via Ctrl + Alt +F1 ... (Ctrl +Alt = F7 to return to logon after the fix)
I noticed that I could not change to the /home/username folder or even to the /home folder so assumed that permissions were some how corrupted there.

The Fix:
Code: Select all
sudo chown username:groupname /home

(In my case the username and groupname are the same).

Worked like a charm ... hope this offers others with another possible solution for this problem, should it ever arise. :D
Dave:

Samsung R580 laptop
Geforce 310M w/ nvidia-glx driver
8 gig RAM
LMDE Cinnamon - Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
User avatar
timber
Level 3
Level 3
 
Posts: 104
Joined: Sat Jan 02, 2010 11:24 pm
Location: Pacific Northwest

Re: <Solved> Could not update ICEauthority file

Postby jhehe on Sat Feb 16, 2013 7:16 pm

timber wrote:I realize this is an older post but I just experienced a similar problem with not being able to logon and the message "could not update .ICEauthority file".
Of course, my immediate response was panic ... :shock:

Background:
Using LMDE latest updates (UP5).
/ and /home are on separate partitions.
Problem arose when I installed a version of Puppy Linux on a different partition.

I'm not sure why or how it happened but immediately following the Puppy install I got the dreaded "could not update .ICEauthority file" message.
I wasn't able to fix the problem from the LiveDVD but was able to fix it from the LMDE logon by going to the console there (as another user here suggests).
In this case the problem was not with the .ICEauthority permissions (even though it appeared that way from the message) but (as noted below) with the "/home" folder permissions.

I got to the console (from logon screen) via Ctrl + Alt +F1 ... (Ctrl +Alt = F7 to return to logon after the fix)
I noticed that I could not change to the /home/username folder or even to the /home folder so assumed that permissions were some how corrupted there.

The Fix:
Code: Select all
sudo chown username:groupname /home

(In my case the username and groupname are the same).

Worked like a charm ... hope this offers others with another possible solution for this problem, should it ever arise. :D


Hi,

any chance you can tel me how i can find out my groupname? this is my first time installing so don't know much about linux and i am running into the same problem.
jhehe
Level 1
Level 1
 
Posts: 13
Joined: Sat Feb 16, 2013 6:45 pm

Re: COuld not update ICEauthority file

Postby xenopeek on Sun Feb 17, 2013 4:23 am

Usually your groupname is the same as your username. Following command will display your groupname:
Code: Select all
id -gn
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15285
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: COuld not update ICEauthority file

Postby jhehe on Sun Feb 17, 2013 6:51 pm

thanks, turned out it is the same and no modified. had me worried for a second that it was the generated computer ID during setup.
jhehe
Level 1
Level 1
 
Posts: 13
Joined: Sat Feb 16, 2013 6:45 pm

Re: COuld not update ICEauthority file

Postby galaxies on Sat Jun 08, 2013 1:33 am

had the same exact issue & read this thread. all i needed to do was disable automatic login through 'sudo mdmsetup' , there was a checkbox which just needed to be unchecked. iceauthority error went away , thanks!!
galaxies
Level 1
Level 1
 
Posts: 6
Joined: Fri May 31, 2013 9:18 am

error Could not update ICEauthority file

Postby lawrencemaria on Tue Jul 09, 2013 5:28 am

galaxies wrote:had the same exact issue & read this thread. all i needed to do was disable automatic login through 'sudo mdmsetup' , there was a checkbox which just needed to be unchecked. iceauthority error went away , thanks!!


Same here! It seems to be Linux Mint 15 bug to do with "enable Automatic Login" option.
When I disenable auto-login there isn't "ICEauthority file" error!! Enable auto-login and immediately the error "Could not update ICEauthority fiel" banner comes up on boot up. Click okay, click manually the username and enter the password -the login then is normal.
But then, having to wait each time to enter the password and then wait for the system to load up is a real pain!
Hope there is some cure -real soon! Till then let us disenable auto-login or revert to linuxmint 14!
------------------------------------------------------------------
Maria Lawrence
lawrencemaria
Level 1
Level 1
 
Posts: 39
Joined: Tue Nov 15, 2011 4:43 am
Location: Rome, Italy

Re: COuld not update ICEauthority file

Postby eraserheah34 on Thu Jul 11, 2013 2:30 pm

xenopeek wrote:Boot from rescue mode (in the GRUB boot menu you can select that; hold shift during boot to get the GRUB boot menu to show if not shown by default). Drop to the root console. Run the following two commands (one at a time) should hopefully fix this:
chown username:groupname /home/username/.ICEauthority
chmod 0600 /home/username/.ICEauthority

Replace username and groupname with your own username and groupname (by default your username is the same as your groupname). Username is the one you log in with.


when I try to use the code in my root shell it claims the file directory does not exist??? Any way to get around that or am I doing something incorrectly?
eraserheah34
Level 1
Level 1
 
Posts: 5
Joined: Wed Mar 27, 2013 12:10 pm

Re: COuld not update ICEauthority file

Postby xenopeek on Thu Jul 11, 2013 3:22 pm

IDK, have you looked? The list of directories in /home you can check with the command:
Code: Select all
ls /home
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15285
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: COuld not update ICEauthority file

Postby eraserheah34 on Sat Jul 13, 2013 2:19 pm

Yeah, the response is "eric" which is the username but thats the only thing listed
eraserheah34
Level 1
Level 1
 
Posts: 5
Joined: Wed Mar 27, 2013 12:10 pm

Re: COuld not update ICEauthority file

Postby xenopeek on Sun Jul 14, 2013 4:05 am

Right, so then running the commands as below with your username inserted should not complain about the directory not existing:
Code: Select all
chown eric:eric /home/eric/.ICEauthority
chmod 0600 /home/eric/.ICEauthority
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15285
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: COuld not update ICEauthority file

Postby fat_cat on Mon Oct 14, 2013 5:06 am

The only thing I've done is I also enabled autologin. Now I cant get system working, after "ICEauthority" message there is one more, "The path for the directory containing caja settings need read and write permissions: /home/USER/.config/caja". After that, it gets stuck with linuxmint wallpaper and only keys that work are Ctrl-Alt-Del and Ctrl-Alt-Backspace. So I simply cannot undo this setting, because I cannot login into system. How to disable autologin from the command line?

chown command results in "does not exist" as well.
fat_cat
Level 1
Level 1
 
Posts: 1
Joined: Mon Oct 14, 2013 2:22 am

Re: COuld not update ICEauthority file

Postby mba on Sun Nov 09, 2014 11:01 am

I was able to solve this by doing the following:

type ctrl alt F1
login with user password
enter: "ecryptfs-mount-private"
enter: passphrase (this is the passphrase I use for encryption)
type ctrl alt F7
login with user password
mba
Level 1
Level 1
 
Posts: 1
Joined: Sun Nov 09, 2014 10:43 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 6 guests