LinuxMint switches off wireless even in Windows.

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help

LinuxMint switches off wireless even in Windows.

Postby yugeshshrestha on Mon Feb 18, 2013 9:42 am

I have a Sony VAIO laptop where I have windows 8 installed. Recently I installed Linux mint Cinnamon edition in my laptop side by side with Windows 8. The wireless was working fine until when I connected my laptop to ethernet cable and switched off the wireless using Wireless OFF button in the bottom right side of taskbar. Since then the Wireless doesnot become ON again, the manual switch in my laptop turns on/off bluetooth but not the WiFi. I booted up windows 8 and the wireless still shows off in it.
I tried installing all updates for LinuxMint but wireless doesnot still work.. I tried sudo ifconfig wlan0 on.. doesnot work.. Rest I dont know what to do.
I found a temporary solution though.. wireless works in windows 8 when I take out the battery and put it in again, but as soon as I boot with Linuxmint same problem occurs.

I really need to work on Linux right now, so I need this error to fix.. HELP

[NOTE: My Wireless adapter is Qualcomm Atheros AR9285 Wireless Network Adapter.]
Thank you if you can find me a fix!
yugeshshrestha
Level 1
Level 1
 
Posts: 3
Joined: Mon Feb 18, 2013 9:31 am

Linux Mint is funded by ads and donations.
 

Re: LinuxMint switches off wireless even in Windows.

Postby wswack on Mon Feb 18, 2013 10:49 am

I am not an expert, but I had a similar problem with a VAIO. In Linux, turning off the WIFI, then turning it back on results in a soft block. It may also be a bios setting. Apparently, almost all bios settings have to be set through the Sony Control Center (or whatever it is called) in Windows. Try to find if it is turned off there. I had to turn the touch pad on in Windows VAIO Control Center before it would work in Linux.

1. In Windows try turning the wifi on with the control center. You might also try restoring the default setting in the bios settings.
2. In Linux try running the command:
sudo rfkill unblock all

You may have to do both. Good luck and I hope this helps.
wswack
Level 1
Level 1
 
Posts: 21
Joined: Mon Jun 11, 2012 10:56 am

Re: LinuxMint switches off wireless even in Windows.

Postby AlbertP on Mon Feb 18, 2013 11:28 am

Could you run this command in terminal on Linux and post the output:
Code: Select all
rfkill list
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: LinuxMint switches off wireless even in Windows.

Postby yugeshshrestha on Tue Feb 19, 2013 4:26 am

Thank you.. yes the Wifi was soft blocked by the linux kernel it seems..
Code: Select all
sudo rfkill unblock all

worked like a charm!! :D

Thanks :D
yugeshshrestha
Level 1
Level 1
 
Posts: 3
Joined: Mon Feb 18, 2013 9:31 am


Return to Wireless

Who is online

Users browsing this forum: JeremyB and 4 guests