LMDE BREAKAGES - (Tracking SID!) -{CLOSED}

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby zerozero on Fri Feb 08, 2013 10:06 pm

slowly getting around the steam installation (yeahh, i know it's very slowly :lol: )
solved the libnspr4:i386 issue: was installed from mozilla.debian and a higher v. than available in testing
Code: Select all
Start-Date: 2013-02-09  02:00:17
Commandline: synaptic
Downgrade: libnspr4:amd64 (4.9.3~beta1-1, 4.9.2-1)
Remove: libnspr4-0d:amd64 (4.9.3~beta1-1)
End-Date: 2013-02-09  02:00:30

in the next days to tackle the rest 8)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6479
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby mockturtl on Sat Feb 09, 2013 4:09 pm

zerozero wrote:slowly getting around the steam installation (yeahh, i know it's very slowly :lol: )
Try the latest... they've really cleaned up the dependencies.

Code: Select all
Package: steam
Version: 1.0.0.25
Architecture: i386
Maintainer: Valve Corporation <linux@steampowered.com>
Installed-Size: 6492
Depends: libc6, libgl1-mesa-dri, libgl1-mesa-glx, xterm | gnome-terminal, zenity
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 437
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby mockturtl on Sat Feb 09, 2013 5:11 pm

In fact, the latest Steam (v25) installs in UP6:

Code: Select all
$ install xterm:i386  # gnome-terminal:i386 conflicts with gnome-terminal:amd64
...
The following actions will resolve these dependencies:

     Install the following packages:                 
1)     libutempter0:i386 [1.1.5-4 (testing, unstable)]
2)     libxaw7:i386 [2:1.0.10-2 (testing, unstable)] 
3)     libxft2:i386 [2.3.1-1 (testing, unstable)]     
4)     libxmu6:i386 [2:1.1.1-1 (testing, unstable)]   
5)     libxpm4:i386 [1:3.5.10-1 (testing, unstable)] 
6)     xbitmaps [1.1.1-2 (unstable)]                 

Accept this solution? [Y/n/q/?] y
The following NEW packages will be installed:
  libutempter0:i386{a} libxaw7:i386{a} libxft2:i386{a} libxmu6:i386{a} libxpm4:i386{a} xbitmaps{a} xterm:i386
The following partially installed packages will be configured:
  steam:i386
0 packages upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,039 kB of archives. After unpacking 2,652 kB will be used.
Do you want to continue? [Y/n/?] y
Let's see whether it runs...
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 437
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby cwwgateway on Sat Feb 09, 2013 5:13 pm

Is the libc6 dependency still at version 2.15? AFAIK all debian branches except experimental are on 2.13.
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby mockturtl on Sat Feb 09, 2013 5:22 pm

mockturtl wrote:Let's see whether it runs...

Nope.

cwwgateway wrote:Is the libc6 dependency still at version 2.15? AFAIK all debian branches except experimental are on 2.13.
Yep.

Code: Select all
 $ steam
Running Steam on linuxmint 1 64-bit
STEAM_RUNTIME is enabled automatically
 /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libX11.so.6)

$ policy libc6:i386
libc6:i386:
  Installed: 2.13-37
  Candidate: 2.13-37
  Version table:
     2.17-0experimental2 0
          1 http://http.debian.net/debian/ experimental/main i386 Packages
     2.13-38 0
         50 http://http.debian.net/debian/ unstable/main i386 Packages
 *** 2.13-37 0
        700 http://mirror.metrocast.net/linuxmint-debian/incoming/ testing/main i386 Packages
         99 http://http.debian.net/debian/ testing/main i386 Packages
        100 /var/lib/dpkg/status
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 437
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby mockturtl on Fri Feb 15, 2013 3:57 pm

I notice I can't build the latest cinnamon on my sid/Steam box... checking whether that libc6 from experimental is the culprit.

Code: Select all
dh_shlibdeps -pcinnamon  -l :/usr/lib/gnome-bluetooth 
dpkg-shlibdeps: error: no dependency information found for /usr/lib/libGL.so.1 (used by debian/cinnamon/usr/lib/cinnamon/libcinnamon.so)
dh_shlibdeps: dpkg-shlibdeps -Tdebian/cinnamon.substvars debian/cinnamon/usr/bin/cinnamon debian/cinnamon/usr/lib/cinnamon/cinnamon/cinnamon-hotplug-sniffer debian/cinnamon/usr/lib/cinnamon/cinnamon/cinnamon-perf-helper debian/cinnamon/usr/lib/cinnamon/libcinnamon.so debian/cinnamon/usr/lib/mozilla/plugins/libcinnamon-browser-plugin.so returned exit code 2
make: *** [binary-predeb-IMPL/cinnamon] Error 2
dpkg-buildpackage: error: debian/rules binary gave error exit status 2
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 437
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby mockturtl on Fri Feb 15, 2013 6:34 pm

I can build cinnamon in a clean sid, so I think something from experimental must be the problem. (Note: it needs cinnamon-control-center from github.)

ZZ, I think there will be some pain after the thaw, when cinnamon migrates to jessie and everyone's pinning is different... for now `dpkg --force-overwrite` will override sid's cinnamon with a local or linuxmint.com version.
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 437
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby zerozero on Sun Feb 17, 2013 9:07 pm

mock,
after much delay i got steam :D (thanks for the hand-holding)
Code: Select all
zerozero@deb-kde ~ $ apt policy steam
steam:i386:
  Installed: 1.0.0.28
  Candidate: 1.0.0.28
  Version table:
 *** 1.0.0.28 0
        500 http://repo.steampowered.com/steam/ precise/steam i386 Packages
        100 /var/lib/dpkg/status

this version has only the libc6 dep to solve
Code: Select all
deb-kde zerozero # aptitude install -t experimental libc6:i386
The following packages will be upgraded:
  libc6 libc6:i386 locales locales-all
4 packages upgraded, 0 newly installed, 0 to remove and 511 not upgraded.
#second option gives the solution
The following actions will resolve these dependencies:                                                                                             
     Upgrade the following packages:                                                                                                                                             
1)     libc-dev-bin [2.13-37 (now, testing) -> 2.17-0experimental2 (experimental)]   
2)     libc6-dbg [2.13-37 (now, testing) -> 2.17-0experimental2 (experimental)]       
3)     libc6-dev [2.13-37 (now, testing) -> 2.17-0experimental2 (experimental)]   
4)     libc6-dev:i386 [2.13-37 (now, testing) -> 2.17-0experimental2 (experimental)]   
5)     libc6-i386 [2.13-37 (now, testing) -> 2.17-0experimental2 (experimental)]     
6)     libc6-i686:i386 [2.13-37 (now, testing) -> 2.17-0experimental2 (experimental)]     

Accept this solution? [Y/n/q/?] Y                                                               
The following packages will be upgraded:     
  libc-dev-bin libc6 libc6:i386 libc6-dbg libc6-dev libc6-dev:i386 libc6-i386 libc6-i686:i386 locales locales-all

the only thing i noticed is that at startup steam has a "call" for jockey-gtk but once we dismiss xterm it starts fine.

in which way pulling these packages from experimental will impact stability we'll see :shock:
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6479
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby cwwgateway on Mon Feb 18, 2013 3:48 pm

I also just got steam installed on my Sid install. Has anybody tried to install any games yet? AFAIK installing certain games installs extra dependencies, and I'd be curious to see if the versions and names are correct for Debian.
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby mockturtl on Mon Feb 18, 2013 4:59 pm

cwwgateway wrote:I also just got steam installed on my Sid install. Has anybody tried to install any games yet? AFAIK installing certain games installs extra dependencies, and I'd be curious to see if the versions and names are correct for Debian.

The Book of Unwritten Tales has a free demo. Decent puzzle / adventure in the style of Lucasfilm.

Team Fortress 2 needed pulseaudio (search google, I think I saw an alsa workaround in the Steam forum). I had the "black screen" nvidia problem, but it's been fixed since v25.

There's a big sale for the next few days: http://store.steampowered.com/sale/linux_release/. Lots of games for $3.
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 437
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby fiver22 on Mon Feb 18, 2013 9:29 pm

Did I do this?
Code: Select all
{13-02-18 21:30}m0nster2:~ fiver22% sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  accountsservice apache2.2-bin banshee bind9-host cheese-common cpp-4.7 cups cups-client
  cups-filters cups-ppdc dconf-gsettings-backend dconf-service default-jre default-jre-headless
  digikam digikam-data dnsutils enblend enfuse evince evince-common evolution-data-server
  evolution-data-server-common file-roller frei0r-plugins g++-4.7 gcc-4.7 gcc-4.7-base
  gcc-4.7-base:i386 gedit gedit-common gir1.2-accountsservice-1.0 gir1.2-clutter-1.0
  gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-evince-3.0 gir1.2-freedesktop gir1.2-glib-2.0
  gir1.2-gnomebluetooth-1.0 gir1.2-gtk-3.0 gir1.2-mutter-3.0 gir1.2-soup-2.4
  gir1.2-telepathylogger-0.2 gir1.2-totem-1.0 gjs glib-networking glib-networking-common
  glib-networking-services gnome-accessibility-themes gnome-bluetooth gnome-contacts
  gnome-control-center gnome-control-center-data gnome-desktop3-data gnome-online-accounts
  gnome-session gnome-session-bin gnome-session-common gnome-session-fallback
  gnome-settings-daemon gnome-shell gnome-shell-common gnome-themes-standard
  gnome-themes-standard-data gvfs gvfs-backends gvfs-bin gvfs-common gvfs-daemons gvfs-libs
  kipi-plugins kipi-plugins-common libaccountsservice0 libclutter-1.0-0 libcogl-pango0 libcups2
  libcups2:i386 libcupscgi1 libcupsimage2 libcupsmime1 libcupsppdc1 libevdocument3-4
  libevview3-3 libexttextcat-data libfftw3-3 libfftw3-bin libfftw3-dev libfolks-eds25
  libfolks-telepathy25 libfolks25 libgail-3-0 libgcc1 libgcc1:i386 libgfortran3
  libgirepository-1.0-1 libgjs0b libglib2.0-0 libglib2.0-bin libgoa-1.0-0 libgoa-1.0-common
  libgomp1 libgtk-3-0 libgtk-3-bin libgtk-3-common libhsqldb-java libitm1
  libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0 libnautilus-extension1a libpoppler-glib8
  libppl-c4 libpulse0 libpulse0:i386 libpython2.7 libquadmath0 libreoffice-base
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-gnome libreoffice-gtk libreoffice-impress libreoffice-math libreoffice-style-tango
  libreoffice-writer libselinux1 libselinux1:i386 libsemanage-common libsemanage1
  libsoup-gnome2.4-1 libsoup2.4-1 libstdc++6 libstdc++6:i386 libstdc++6-4.7-dev
  libtotem-plparser17 libtotem0 libuuid-perl libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 mutter-common
  packagekit packagekit-backend-aptcc packagekit-tools perl perl-base perl-modules poppler-utils
  printer-driver-escpr pulseaudio-utils python python-all python-all-dev python-dev
  python-imaging python-minimal python-packagekit python-uno python2.7 python2.7-dev
  python2.7-minimal python3 python3-minimal rsyslog tcl totem totem-common totem-mozilla
  totem-plugins usbmuxd vino xserver-xorg-video-nouveau zsh
The following packages will be upgraded:
  apt-listchanges aptitude aptitude-common aptitude-doc-en beets beets-doc binutils bluetooth
  bluez bluez-alsa bluez-cups bluez-gstreamer cpp cups-common curl discover e2fslibs e2fsprogs
  eglibc-source filezilla filezilla-common findutils folks-common fonts-droid
  fonts-lohit-beng-assamese fonts-lohit-beng-bengali fonts-lohit-gujr fonts-lohit-telu
  fonts-opensymbol foomatic-db freeglut3 freeglut3:i386 g++ gcc gcr gdebi gdebi-core
  gir1.2-atk-1.0 gir1.2-clutter-gst-1.0 gir1.2-folks-0.6 gir1.2-gck-1 gir1.2-gcr-3
  gir1.2-gdesktopenums-3.0 gir1.2-gdkpixbuf-2.0 gir1.2-gmenu-3.0 gir1.2-gtkclutter-1.0
  gir1.2-networkmanager-1.0 gir1.2-pango-1.0 gir1.2-peas-1.0 gir1.2-polkit-1.0
  gir1.2-telepathyglib-0.12 gir1.2-totem-plparser-1.0 gir1.2-upowerglib-1.0 git git-man
  gnome-icon-theme gnome-icon-theme-symbolic gnome-keyring gnome-menus gnome-power-manager
  gnuplot gnuplot-nox grub-common grub-pc grub-pc-bin grub2-common gsettings-desktop-schemas
  gstreamer0.10-nice gtk2-engines-pixbuf hpijs hplip hplip-data htop hugin hugin-data
  hugin-tools imagemagick imagemagick-common info install-info iproute java-common libaacs0
  libass4 libatk1.0-0 libatk1.0-data libaudiofile1 libaudiofile1:i386 libbluetooth3 libbluray1
  libc-bin libcairo-gobject2 libcairo-perl libcairo2 libclutter-gst-1.0-0 libclutter-gtk-1.0-0
  libcogl-common libcogl9 libcomerr2 libcomerr2:i386 libcroco3 libcupsdriver1 libcupsfilters1
  libcurl3 libcurl3:i386 libcurl3-gnutls libcurl3-nss libdatrie1 libdecoration0 libdiscid0
  libdiscover2 libdrm-intel1 libdrm-intel1:i386 libdrm-radeon1 libdrm-radeon1:i386 libdrm2
  libdrm2:i386 libexpat1 libexpat1:i386 libexpat1-dev libfribidi0 libgadu3 libgail-common
  libgail18 libgck-1-0 libgcr-3-1 libgcr-3-common libgdata-common libgdata13 libgdk-pixbuf2.0-0
  libgdk-pixbuf2.0-common libgeoclue0 libgeoip1 libgexiv2-1 libglib-perl libglib2.0-data
  libgmp10 libgmpxx4ldbl libgnome-keyring-common libgnome-keyring0 libgnome-menu-3-0 libgnutls26
  libgnutls26:i386 libgssdp-1.0-3 libgtk2-perl libgtk2.0-0 libgtk2.0-bin libgtk2.0-common
  libgupnp-1.0-4 libgweather-common libhpmud0 libjack-jackd2-0 libjack-jackd2-0:i386
  libjs-jquery-ui libjs-sphinxdoc libkeybinder0 libkpathsea6 liblapack3 liblapack3gf
  liblouis-data libmagickcore5 libmagickcore5-extra libmagickwand5 libmediainfo0
  libmission-control-plugins0 libmtdev1 libmtp-common libmtp-runtime libmtp9 libncurses5
  libncursesw5 libncursesw5:i386 libnettle4 libnice10 libnm-glib-vpn1 libnm-glib4
  libnm-gtk-common libnm-gtk0 libnm-util2 libopts25 libopus0 libp11-kit0 libp11-kit0:i386
  libpam-gnome-keyring libpango-perl libpango1.0-0 libpeas-1.0-0 libpeas-common libplist1
  libpolkit-agent-1-0 libpolkit-gobject-1-0 libpq5 libpulse-mainloop-glib0 libqjson0
  libquvi-scripts libraw5 libreoffice-emailmerge libreoffice-filter-mobiledev
  libreoffice-java-common libreoffice-report-builder-bin librsvg2-2 librsvg2-common
  libsane-hpaio libsdl-image1.2 libsepol1 libshout3 libsigsegv2 libsmbclient libsoundtouch0
  libss2 libstartup-notification0 libsvga1 libsvga1:i386 libtasn1-3 libtasn1-3:i386
  libtasn1-3-bin libtdb1 libtdb1:i386 libtelepathy-glib0 libtelepathy-logger2 libthai-data
  libthai0 libtinfo5 libtinfo5:i386 libtracker-sparql-0.14-0 libupower-glib1 libv4l-0
  libv4l-0:i386 libv4lconvert0 libv4lconvert0:i386 libva-x11-1 libva1 libvdpau1 libvisio-0.0-0
  libwbclient0 libwebkitgtk-1.0-common libwebkitgtk-3.0-common libwpd-0.9-9 libxml2 libxml2:i386
  libxml2-utils libxrandr2 libxrandr2:i386 libxslt1.1 libxslt1.1:i386 libyelp0 libzen0
  linux-libc-dev make mediainfo mime-support mscompress multiarch-support nautilus-data
  ncurses-base ncurses-bin ncurses-term network-manager network-manager-gnome
  network-manager-pptp network-manager-pptp-gnome obexd-client openssh-client openssh-server
  patch phonon-backend-vlc policykit-1 printer-driver-c2esp printer-driver-foo2zjs
  printer-driver-hpcups printer-driver-hpijs printer-driver-m2300w printer-driver-postscript-hp
  printer-driver-ptouch pulseaudio pulseaudio-esound-compat pulseaudio-module-gconf
  pulseaudio-module-x11 pulseaudio-module-zeroconf pyqt4-dev-tools python-cups python-decorator
  python-gdata python-gi python-gi-cairo python-gobject python-httplib2 python-libxml2
  python-mako python-musicbrainzngs python-numpy python-openssl python-pkg-resources
  python-pycurl python-pygame python-qt4 python-renderpm python-reportlab python-reportlab-accel
  python-setuptools python-sip python-twisted-bin python-twisted-core python-twisted-web
  python-xdg samba samba-common samba-common-bin shotwell shotwell-common simple-scan smplayer
  smplayer-translations synaptic tcl8.5 telepathy-gabble telepathy-mission-control-5 tomboy
  transmission-common transmission-gtk uno-libs3 upower ure usb-modeswitch usb-modeswitch-data
  xfce4-notifyd xserver-xorg-input-evdev xserver-xorg-video-fbdev xserver-xorg-video-intel
  xsltproc xterm yelp yelp-xsl
333 upgraded, 0 newly installed, 0 to remove and 174 not upgraded.
Need to get 227 MB of archives.
After this operation, 17.3 MB of additional disk space will be used.
Do you want to continue [Y/n]?

I was installing a bit willy-nilly trying to get steam working...but the above seems a bit much. Can anyone tell me if the updates are new or if I've done something to cause them?
User avatar
fiver22
Level 1
Level 1
 
Posts: 46
Joined: Wed Feb 01, 2012 8:08 am

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby zerozero on Mon Feb 18, 2013 9:35 pm

nahh :shock: there's no such an influx atm in sid or in testing
post the actual sources.list you're working with at the moment
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6479
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby fiver22 on Mon Feb 18, 2013 9:46 pm

zerozero wrote:nahh :shock: there's no such an influx atm in sid or in testing
post the actual sources.list you're working with at the moment

Oh Maaan,
I don't wanna admit this... I un-commented Experimental trying to get steam running and forgot to re-comment.

(Let's pretend this didn't happen)
Thanks for the quick reply! o/
User avatar
fiver22
Level 1
Level 1
 
Posts: 46
Joined: Wed Feb 01, 2012 8:08 am

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby zerozero on Mon Feb 18, 2013 9:48 pm

fiver22 wrote:(Let's pretend this didn't happen)
to be honest i have no idea what you are talking about :lol: :mrgreen:
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6479
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby mockturtl on Tue Feb 19, 2013 3:12 am

fiver22 wrote:Oh Maaan,
I don't wanna admit this... I un-commented Experimental trying to get steam running and forgot to re-comment.
If you're using the LMDE default /etc/apt/preferences, qualify the "origin = Debian" line by specifying an archive:

Code: Select all
Package: *
Pin: release o=Debian,a=unstable
Pin-Priority: 500

Then experimental will have priority 1 (other repos, say testing, default to 500), and you can upgrade without commenting it in sources.list.

(Values < 100 need to be requested explicitly: `install -t archive package` (get deps from archive), or `install package/archive` (get deps from your usual repo).
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 437
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby cwwgateway on Tue Feb 19, 2013 12:21 pm

The safest route is probably to remove the default Mint preferences file, since it can cause problems in the future as the current UP drifts farther away from testing/sid.

I just got netflix working following a guide on the #! forums (http://crunchbang.org/forums/viewtopic.php?id=23958), so I don't need any Ubuntu-based Mint installs anymore :D .
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby cwwgateway on Wed Feb 20, 2013 12:45 am

The Linux kernel version 3.8 was released yesterday, and this is the one that drops support for i386. I know liquorix hasn't updated yet (can't verify the others). I'm curious to see if this is dealt with smoothly. I'm also waiting for iceweasel 19.
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby fiver22 on Wed Feb 20, 2013 11:10 pm

seeing how everyone so kindly ignored my silly screwup ;)
I thought I'd post my sources and preferences for any suggestions:
Code: Select all
Package: *
Pin: release o=linuxmint
Pin-Priority: 500

Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 500

Package: *
Pin: release o=Debian
Pin-Priority: 500

####DEFAULT LMDE SOURCES CLEAN INSTALL 201204-XFCE###
# deb [arch=amd64,i386] http://packages.linuxmint.com/ debian main upstream imp$
# deb [arch=amd64,i386] http://debian.linuxmint.com/latest testing main contrib$
# deb [arch=amd64,i386] http://debian.linuxmint.com/latest/security testing/upd$
# deb [arch=amd64,i386] http://debian.linuxmint.com/latest/multimedia testing m$

####TRACK TESTING ADDED PAR MOI SET PINNING TO EQUAL###
deb [arch=amd64,i386] http://packages.linuxmint.com/ debian main upstream import
deb-src http://packages.linuxmint.com/ debian main upstream import
deb [arch=amd64,i386] http://ftp.ca.debian.org/debian/ testing main contrib non$
deb-src http://ftp.ca.debian.org/debian/ testing main contrib non-free
deb [arch=amd64,i386] http://security.debian.org/ testing/updates main contrib $
deb [arch=amd64,i386] http://www.deb-multimedia.org testing main non-free

####SIDUCTION FOR XFCE4####
deb http://packages.siduction.org/xfcenext unstable main
deb-src http://packages.siduction.org/xfcenext unstable main

####VirtualBox FOR WHEEZY####
deb http://download.virtualbox.org/virtualbox/debian wheezy contrib

##############DEBIAN EXPERIMENTAL##############33
#deb http://ftp.debian.org/debian experimental main


:)
User avatar
fiver22
Level 1
Level 1
 
Posts: 46
Joined: Wed Feb 01, 2012 8:08 am

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby cwwgateway on Wed Feb 20, 2013 11:30 pm

The sources.list seems fine. If you remove everything in your preferences file (including the entry for o=Debian), then you can uncomment experimental and have it be fine because it is set to not automatic as default. The o=Debian set to 500 gives all Debian repos, whether it be stable, testing, unstable, experimental, etc, a priority of 500, meaning packages from that repo will be installed if they are of a higher version. The other parts of your sources.list aren't necessary either. Here's how mine look for my sid install:
Code: Select all
sources.list:
deb http://ftp.us.debian.org/debian/ unstable main contrib non-free
deb-src http://ftp.us.debian.org/debian/ unstable main contrib non-free
bumblebee.list:
deb http://suwako.nomanga.net/debian sid main contrib
deb-src http://suwako.nomanga.net/debian sid main
experimental.list:
deb http://ftp.us.debian.org/debian/ experimental main contrib non-free
liquorix.list:
deb http://liquorix.net/debian/ sid main
multimedia.list:
deb http://www.deb-multimedia.org/ sid main non-free
steam.list:
deb http://repo.steampowered.com/steam/ precise steam
deb-src http://repo.steampowered.com/steam/ precise steam
xfcenext.list:
deb http://packages.siduction.org/xfcenext unstable main
deb-src http://packages.siduction.org/xfcenext unstable main
ehoover-compholio-wheezy.list:
deb http://ppa.launchpad.net/ehoover/compholio/ubuntu quantal main
deb-src http://ppa.launchpad.net/ehoover/compholio/ubuntu quantal main

preferences:
Package: *
Pin: origin liquorix.net
Pin-Priority: 1001

Package: *
Pin: release a=experimental
Pin-Priority: -1

Package: iceweasel icedove xulrunner* libmozjs*
Pin: release a=experimental
Pin-Priority: 900
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Postby mockturtl on Thu Feb 21, 2013 1:22 am

fiver22 wrote:seeing how everyone so kindly ignored my silly screwup ;)
I thought I'd post my sources and preferences for any suggestions:
Optionally, break out nonstandard repos (vbox, siduction-xfcenext) to separate .list files in /etc/apt/sources.list.d/ (chown root:root, chmod 644).

If linuxmint.com and debian.org both have the default pin-priority (500), you could see some conflicts with Mint-related projects that have official Debian packages (cinnamon, muffin... nemo? mdm?). For these, LM is upstream of Debian, so a higher priority makes sense -- the linuxmint.com repo will update sooner, and more often.
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 437
Joined: Sat Oct 09, 2010 8:51 pm

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 2 guests