T430U on LMDE UP 6

Questions about hardware and drivers
Forum rules
Before you post please read this

T430U on LMDE UP 6

Postby ledoktre on Tue Feb 19, 2013 12:17 am

Greetings all!

I've got one rather frustrating thing, and then a couple of "if you know how to do it" things to attach.

Specs : I've got LMDE UP 6 installed on my Thinkpad T430U. Its a system running an i5-3427U proc, 16GB DDR3 PC3-1600, Intel HD4000 graphics (Ivy Bridge GT2) and a UM77 chipset. Running a Samsung 840 Pro 250GB SATA3 SSD. Was running bios rev 2.02, just noticed 2.06 is out, so while I am still posting this, I will try it out.

1st and most prominent - I having trouble with the system randomly freezing. If there is sound playing, it just loops a second or so of audio. If there is no sound, it just freezes. Either way, mouse is gone, dead in the water. System does not appear to be even warm, so I don;'t think it is thermal? Where do I begin to try and figure out why its locking up? It happens a couple times a day.

Bonus # 1 - System has a Upek fingerprint reader. 147e:1002. Any idea how to install a driver? I've found some, but they seem to be on old abandoned projects.

Bonus # 2 - How do I tell if the system is detecting the battery properly? Under system profile it lists no battery present.

Bonus # 3 - System appears to recognize the trackpad (Syn PS2 Synaptics trackpad) just fine, as with the trackpoint (TPPS/2 IBM Trackpoint). I can't seem to use the scroll button on the trackpad (dedicated button between the L & R buttons) or any gestures (scroll up down on trackpad, etc). Any idea where to look for that?

Thats it I believe!

Thanks guys... a beautiful system!

Tim
ledoktre
Level 1
Level 1
 
Posts: 27
Joined: Wed Dec 05, 2012 11:34 am

Linux Mint is funded by ads and donations.
 

Re: T430U on LMDE UP 6

Postby ledoktre on Tue Feb 19, 2013 5:37 am

I may have answered part of my question. I found some other posts on this forum talking about their laptop hanging, and it was some sort of power management issue (rc6) with the graphics controller and going into deep sleep when idle . I've implemented their suggestion : i915.i915_enable_rc6=0 but its probably still a little early to tell if its fixed it or not.

I'm trying to install the liquorix kernel as well, thinking then I would not need the above fix, but thus far the laptop just hangs when trying to boot from it.

So y'all, feel free to chime in with thoughts and answers to any of my questions :-)

Thanks,
ledoktre
Level 1
Level 1
 
Posts: 27
Joined: Wed Dec 05, 2012 11:34 am

Re: T430U on LMDE UP 6

Postby zerozero on Tue Feb 19, 2013 7:44 am

probably you saw this topic viewtopic.php?f=199&t=110794#p689015
liquorix is indeed one of the options
these are the packages i have installed from there
Code: Select all
 $ dpkg -l | grep liquorix
ii  linux-headers-3.7.0-6.dmz.2-liquorix-686      3.7.0-12                          i386         Header files for Linux 3.7.0-6.dmz.2-liquorix-686
ii  linux-headers-liquorix-686                    3.7.0-12                          i386         Linux headers for liquorix on modern PCs
ii  linux-image-3.7.0-6.dmz.2-liquorix-686        3.7.0-12                          i386         Linux 3.7.0 for modern PCs
ii  linux-image-liquorix-686                      3.7.0-12                          i386         Linux image for liquorix on modern PCs
ii  liquorix-archive-keyring                      2009.05.25                        all          GnuPG archive keys of the liquorix archive
ii  liquorix-keyring                              2009.05.25                        all          GnuPG keys of liquorix Developers
ii  liquorix-keyrings                             2009.05.25                        all          Meta package to grab all useful GnuPG keys for liquorix

this is a 32bit system, adapt according but you need headers+image
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: T430U on LMDE UP 6

Postby ledoktre on Tue Feb 19, 2013 9:54 am

I think you are right. I think that was the link that I read. So far, no lockups with kernel option set. I did try installing liquorix earlier, but it would not boot- it would just hang with a blinking cursor.

Any ideas?
ledoktre
Level 1
Level 1
 
Posts: 27
Joined: Wed Dec 05, 2012 11:34 am

Re: T430U on LMDE UP 6

Postby ledoktre on Wed Mar 13, 2013 12:02 am

Greetings ;

Just a report back -- since modifying the boot command line as was suggested in a previous reply to this post, I have had zero lockups. That makes me very happy. The downside however, is that when on battery power, what used to be 5-6 hours is now like 3. It's definitely taken a hit. The article suggests that upgrading the kernel to a newer version should fix this.

I've tried upgrading to a liquorix kernel as well as (currently) siduction kernels. Worst of it is, no matter which one I use, it seems to hang during boot at ACPI. I'm hoping someone can turn me on to a solution. I'd really like to get this resolved!!

In addition :

Bonus # 1 - System has a Upek fingerprint reader. 147e:1002. Any idea how to install a driver? I've found some, but they seem to be on old abandoned projects.

Bonus # 2 - How do I tell if the system is detecting the battery properly? Under system profile it lists no battery present.

Bonus # 3 - System appears to recognize the trackpad (Syn PS2 Synaptics trackpad) just fine, as with the trackpoint (TPPS/2 IBM Trackpoint). I can't seem to use the scroll button on the trackpad (dedicated button between the L & R buttons). Any idea where to look for that?

Thanks all!
ledoktre
Level 1
Level 1
 
Posts: 27
Joined: Wed Dec 05, 2012 11:34 am

Re: T430U on LMDE UP 6

Postby SirSelim on Wed Mar 13, 2013 6:44 pm

ledoktre wrote:I've tried upgrading to a liquorix kernel as well as (currently) siduction kernels. Worst of it is, no matter which one I use, it seems to hang during boot at ACPI. I'm hoping someone can turn me on to a solution. I'd really like to get this resolved!!


Have you got a dedicated GFX card as well as your Intel HD4000? Reason I ask is because I have to manually install Nvidia drivers on my laptop each time I upgrade my liquorix kernel. If I don't it hangs (I had a massive issue with the DKMS Nvidia module, so for me the manual approach is just fine). I have also disabled my HD4000 by turning optimus off in the BIOS. Not sure if this helps at all...
User avatar
SirSelim
Level 1
Level 1
 
Posts: 22
Joined: Thu Nov 01, 2012 5:34 pm

Re: T430U on LMDE UP 6

Postby ledoktre on Thu Mar 14, 2013 1:54 am

Greetings,

Actually this laptop had an option to purchase it with just HD4000 or HD4000 and Nvidia together. As I was after better battery life, and I knew Optimus technology on Linux is not exactly spectacular, I opted for HD4000 only. I'd been running an older 2nd gen i5 for a year or so now with HD3000 graphics and it was plenty fast for what I needed anyway.

So no, this is just HD4000 graphics... it just gets to the ACPI part of the bootup and stops. In its tracks.

Any other ideas guys?

Thanks,
ledoktre
Level 1
Level 1
 
Posts: 27
Joined: Wed Dec 05, 2012 11:34 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron