Alsamixer automute mutes even when headphones unplugged

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Alsamixer automute mutes even when headphones unplugged

Postby ibozzie on Wed Feb 20, 2013 11:10 pm

I'm running Linux Mint 14 MATE on a Dell XPS 15 L502X. My issue is that alsamixer's automute feature will mute even when headphones are not plugged in. The quick solution has been to disable it and enable it whenever I plug in headphones, but that's irritating and I'd like to get it working. This wasn't an issue on this machine in Linux Mint 13 MATE, it only appeared after I upgraded.

Some examples: with auto-mute enabled, I reboot the computer. Sound is playing out of speakers, then I suspend and wake up the computer, and sound only comes out of the headphone jack (which I have not plugged anything into). Also, if I shut it down with headphones plugged in it will generally be automuted when I turn it back on, regardless of whether or not the headphones are still plugged in.

I've looked around and I haven't found anything related to this issue - does anyone have any ideas for how to fix this? I'm wondering if Pulseaudio has something to do with it.

I've uploaded my ALSA information here: http://www.alsa-project.org/db/?f=c3aac2aeda5178d2c0e759e8180d1c55806067d7

I've tried inserting the following line in alsa-base.conf:
Code: Select all
options snd-hda-intel model=auto

And commenting out the following in /etc/pulse/default.pa:
Code: Select all
load-module module-device-restore


Any help would be greatly appreciated!
ibozzie
Level 1
Level 1
 
Posts: 8
Joined: Wed Jun 13, 2012 6:21 pm
Location: State College, PA

Linux Mint is funded by ads and donations.
 

Re: Alsamixer automute mutes even when headphones unplugged

Postby ibozzie on Wed Feb 20, 2013 11:25 pm

Aaand looks like I got lucky right after I posted this and finally found the answer. For future reference, it looks like it had to do with my Intel HDA Audio drivers. There's actually a bug logged for this issue: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1064621/+activity

Turns out I just needed to install this: https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

All seems to be working fine now!
ibozzie
Level 1
Level 1
 
Posts: 8
Joined: Wed Jun 13, 2012 6:21 pm
Location: State College, PA


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 10 guests