HELP! Lowering volume completely mutes speakers

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

HELP! Lowering volume completely mutes speakers

Postby digitman on Tue Jan 29, 2013 7:54 pm

My linux mate is working great, except for just one problem. If I lower my volume (from taskbar), then if it goes down below around 16-20%, the volume is completely muted. So my only options are to keep the volume between 20% and 100%. For loud songs this is very problematic.

Any ideas?
digitman
Level 1
Level 1
 
Posts: 11
Joined: Sun Jan 20, 2013 3:39 am

Linux Mint is funded by ads and donations.
 

Re: HELP! Lowering volume completely mutes speakers

Postby digitman on Wed Jan 30, 2013 2:36 pm

bump
digitman
Level 1
Level 1
 
Posts: 11
Joined: Sun Jan 20, 2013 3:39 am

Re: HELP! Lowering volume completely mutes speakers

Postby Tit on Thu Feb 21, 2013 1:05 am

There is a similar topic here:
viewtopic.php?f=48&t=122583

There is an explanation here:
http://www.freedesktop.org/wiki/Softwar ... eMyVolumes

But, how do I "pass the 'control=' parameter to module-alsa-sink (and friends) and pass the name of a single mixer control that PulseAudio should control"??? :shock:

There is another possible solution here:
http://tombuntu.com/index.php/2010/05/0 ... ulseaudio/
Here's the text:

You’ll need to edit a PulseAudio configuration file to make the fix. Run the following command in a terminal to open it in the text editor (you will be prompted for your password):
gksu gedit /etc/pulse/default.pa
Find the following line in the file:
load-module module-udev-detect
And change it to this:
load-module module-udev-detect ignore_dB=1
Save and close the editor. Run the following command in a terminal to restart PulseAudio (it restarts when killed):
killall pulseaudio

Try this out and please post results :mrgreen: Thank you
Tit
Level 1
Level 1
 
Posts: 12
Joined: Mon Jan 28, 2013 6:25 am

Re: HELP! Lowering volume completely mutes speakers

Postby Tit on Thu Feb 21, 2013 2:54 am

Hmm, well the above two solutions worked very poorly for me, but I have a workaround: install pulseaudio-equalizer

Code: Select all
sudo add-apt-repository ppa:nilarimogard/webupd8 && sudo apt-get update && sudo apt-get install pulseaudio-equalizer


Run it and check "EQ enabled".

When you enable the equalizer, a "LADSPA Plugin Multiband EQ" appears in the volume controls of the sound preferences. Setting your default output to 100% and then using the volume buttons gives the following result:
volume buttons control the equalizer, default sink stays at 100% - woohoo :mrgreen: Have sound 'till 0% AND an equalizer.

Hope this was helpful...
Tit
Level 1
Level 1
 
Posts: 12
Joined: Mon Jan 28, 2013 6:25 am

Re: HELP! Lowering volume completely mutes speakers

Postby catweazel on Thu Feb 21, 2013 3:02 am

Tit wrote:install pulseaudio-equalizer

Thanks for the lead. I'm as deaf as a wooden post and use bone-conducting headphones, which I can hear perfectly with when I have them on. This tool has allowed me to tune the sound to my tastes.

Cheers, it's appreciated.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: HELP! Lowering volume completely mutes speakers

Postby digitman on Fri Feb 22, 2013 9:13 am

This needs to be fixed by the linux mint team, its a major bug and inexcusable that the taskbar volume control mutes the speakers at 15-16%
digitman
Level 1
Level 1
 
Posts: 11
Joined: Sun Jan 20, 2013 3:39 am


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: MSNbot Media, prohc and 9 guests