Hey Quick question<SOLVED>

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Hey Quick question<SOLVED>

Postby Pigeek on Wed Feb 20, 2013 3:32 am

On the Mate desktop environment If I press ctrl-alt-del I get the shutdown dialog.

Now the main question, Is there any way to restore that behavior to the Cinnamon desktop environment.

Any suggestions are appreciated.
Last edited by Pigeek on Sun Feb 24, 2013 1:38 am, edited 1 time in total.
Specs:
Pentium 2.2Ghz dual core E2200
2Gb Ram
Intel G33 graphics
Linux Mint 14 64-bit cinnamon
Pigeek
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 19, 2012 11:57 pm

Linux Mint is funded by ads and donations.
 

Re: Hey Quick question

Postby catweazel on Wed Feb 20, 2013 3:39 am

Pigeek wrote:On the Mate desktop environment If I press ctrl-alt-del I get the shutdown dialog.

Now the main question, Is there any way to restore that behavior to the Cinnamon desktop environment.

Any suggestions are appreciated.

The keyboard app lets you specify custom shortcuts so you could try that. There is no default for shutdown so you'll have to disable or change the logout shortcut, which is what ctrl+alt-del is mapped to.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: Hey Quick question

Postby Pigeek on Wed Feb 20, 2013 4:28 am

OK, but what do I link the new shortcut to?
Specs:
Pentium 2.2Ghz dual core E2200
2Gb Ram
Intel G33 graphics
Linux Mint 14 64-bit cinnamon
Pigeek
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 19, 2012 11:57 pm

Re: Hey Quick question

Postby catweazel on Wed Feb 20, 2013 4:45 am

Pigeek wrote:OK, but what do I link the new shortcut to?

I may have given you dodgy information. I tried it on my system but it doesn't work. I would have suggested mapping 'sudo shutdown now' but it's not working.

My apologies for the bum steer.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: Hey Quick question

Postby Pigeek on Wed Feb 20, 2013 4:58 am

It's totally fine, but there has to be a way to manually invoke that box, I just don't know how.
Specs:
Pentium 2.2Ghz dual core E2200
2Gb Ram
Intel G33 graphics
Linux Mint 14 64-bit cinnamon
Pigeek
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 19, 2012 11:57 pm

Re: Hey Quick question

Postby Pigeek on Thu Feb 21, 2013 5:22 am

Well I found that if I run this in a terminal
Code: Select all
'/usr/bin/gnome-session-quit' --power-off

It pops up the box I want, yet if I clear the logout shortcut and set this to any keyboard combination, It will not run when I use said combination.

Any other suggestions would be appreciated.
Specs:
Pentium 2.2Ghz dual core E2200
2Gb Ram
Intel G33 graphics
Linux Mint 14 64-bit cinnamon
Pigeek
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 19, 2012 11:57 pm

Re: Hey Quick question

Postby catweazel on Thu Feb 21, 2013 5:25 am

Pigeek wrote:It will not run when I use said combination.

That's what happened when I tried it :?
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: Hey Quick question

Postby Pigeek on Thu Feb 21, 2013 5:34 am

I know it runs in alt-f2, so how does the keyboard shortcut run it so that it won't work?
Specs:
Pentium 2.2Ghz dual core E2200
2Gb Ram
Intel G33 graphics
Linux Mint 14 64-bit cinnamon
Pigeek
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 19, 2012 11:57 pm

Re: Hey Quick question

Postby AlbertP on Thu Feb 21, 2013 5:35 am

You can also press the power button of your computer to get this dialog on Cinnamon.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6519
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Hey Quick question

Postby Pigeek on Thu Feb 21, 2013 5:38 am

AlbertP wrote:You can also press the power button of your computer to get this dialog on Cinnamon.

True, maybe I am being too picky, but I like being able to crtl-alt-del enter and shut down my pc in a smoother fashion, yet if it is mate and that or cinnamon I still will use cinnamon
Specs:
Pentium 2.2Ghz dual core E2200
2Gb Ram
Intel G33 graphics
Linux Mint 14 64-bit cinnamon
Pigeek
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 19, 2012 11:57 pm

Re: Hey Quick question

Postby AlbertP on Thu Feb 21, 2013 5:40 am

Are using Mint 14's default Cinnamon version, or are you on Mint 13 perhaps?
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6519
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Hey Quick question

Postby Pigeek on Thu Feb 21, 2013 5:42 am

Mint 14 cinnamon, up to date via the update manager
Specs:
Pentium 2.2Ghz dual core E2200
2Gb Ram
Intel G33 graphics
Linux Mint 14 64-bit cinnamon
Pigeek
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 19, 2012 11:57 pm

Re: Hey Quick question

Postby AlbertP on Thu Feb 21, 2013 6:14 am

The Ctrl-Alt-Del shortcut is already in use for logout: Cinnamon Settings > Keyboard > Shortcuts tab > System (at the left). You'll probably need to unset that if you want to use a custom shortcut to gnome-session-quit --power-off with the same key combination.

You can unset it by selecting the Ctrl-Alt-Delete text and then pressing Backspace.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6519
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Hey Quick question

Postby catweazel on Thu Feb 21, 2013 6:20 am

AlbertP wrote:You can unset it by selecting the Ctrl-Alt-Delete text and then pressing Backspace.

Even when that was done it didn't work for me.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: Hey Quick question

Postby AlbertP on Thu Feb 21, 2013 6:22 am

Have you already tried logging out and back in after adding the shortcut for gnome-session-quit --power-off?
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6519
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Hey Quick question

Postby Pigeek on Thu Feb 21, 2013 10:57 am

AlbertP wrote:Have you already tried logging out and back in after adding the shortcut for gnome-session-quit --power-off?

I did a full reboot and yes I did clear the logout shortcut.
Specs:
Pentium 2.2Ghz dual core E2200
2Gb Ram
Intel G33 graphics
Linux Mint 14 64-bit cinnamon
Pigeek
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 19, 2012 11:57 pm

Re: Hey Quick question

Postby Pigeek on Sun Feb 24, 2013 1:34 am

Ok, never mind it appears to be a known bug
https://bugs.launchpad.net/linuxmint/+bug/1077930
with a known workaround
http://forums.linuxmint.com/viewtopic.php?f=208&t=117585&start=20#p655476

Thanks for all the suggestions.
Specs:
Pentium 2.2Ghz dual core E2200
2Gb Ram
Intel G33 graphics
Linux Mint 14 64-bit cinnamon
Pigeek
Level 1
Level 1
 
Posts: 11
Joined: Fri Oct 19, 2012 11:57 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: bmike1, Google Adsense [Bot], Hecubus, I2k4 and 36 guests