Error - Update Manager does not work

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Error - Update Manager does not work

Postby DarioTW on Fri Feb 22, 2013 8:45 am

Hello,
I have dual boot on my Imac (27" display, late 2009, ATI Radeon etc), my system is Linux Mint 11. I installed graphic programs etc following David Revoy's guide (David's site is great source for us digital artists) http://www.davidrevoy.com/?article95/li ... tall-notes and for a while it all worked fine.
Then around December '12 I started having problems with the updates, but I did not pay attention to it.

Recently I tried to update to the newer MyPaint and after getting the ppa etc I got this message:
E: Type 'ain' is not known on line 3 in source list /etc/apt/sources.list.d/achadwick-mypaint-testing-natty.list

E: The list of sources could not be read
I tried to uncheck the source list and do update all all my system
now my Synaptic Package does not open and my Update Manger gives this message:
The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct.
E: Type 'ain' is not known on line 3 in source list /etc/apt/sources.list.d/achadwick-mypaint-testing-natty.list
E: Unable to lock the list directory
E: Type 'ain' is not known on line 3 in source list /etc/apt/sources.list.d/achadwick-mypaint-testing-natty.list
E: The list of sources could not be read.
Go to the repository dialog to correct the problem.
E: _cache->open() failed, please report.
ERROR###ERROR###ERROR###ERROR###ERROR###ERROR###ERROR
E:Type 'ain' is not known on line 3 in source list /etc/apt/sources.list.d/achadwick-mypaint-testing-natty.list

My source list:
(gedit:2541): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.3X7SSW': No such file or directory

(gedit:2541): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

deb http://packages.linuxmint.com/ katya main upstream import backport
deb-src http://packages.linuxmint.com/ katya main upstream import backport #Added by software-properties
deb http://archive.ubuntu.com/ubuntu/ natty main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ natty-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ natty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ natty partner
deb http://extras.ubuntu.com/ubuntu natty main
# deb http://packages.medibuntu.org/ natty free non-free

# deb http://archive.getdeb.net/ubuntu natty-getdeb apps
# deb http://archive.getdeb.net/ubuntu natty-getdeb games

I am at loss here
thanks
ps
I have been trying to install newer Linux Mint but having problems with my display, i.e., I get black screen after what appears to be a successful install of Linux MInt 14 KDE or Cinnamon (using a second monitor during the install) , thus failing my installs
DarioTW
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 22, 2013 8:22 am

Linux Mint is funded by ads and donations.
 

Re: Error - Update Manager does not work

Postby Akiviri on Fri Feb 22, 2013 1:47 pm

I'm not a guru on this - so take this for what it's worth

My advice - based on what I would do - would be to download your preferred upgrade, burn it to disk and do a fresh install with ONE monitor working. Get your second up and running afterwords to minimize the amount of problems you could have - I would follow the one monitor practice after this for every upgrade, for that reason. For me those generally go very smooth, but then I only use one monitor. Sounds like you have a mish-mash of things going on with a failed, and possibly not entirely regressed afterwords, upgrade. But as I said - I'm no expert on this.

At any rate - GL with your problem.
Akiviri
Level 1
Level 1
 
Posts: 6
Joined: Mon Feb 18, 2013 3:19 am
Location: Wisconsin, USA.

Re: Error - Update Manager does not work

Postby DarioTW on Sun Feb 24, 2013 4:45 pm

Hi,
thanks for the reply - my intention is to keep Linux Mint 11 and install newer one along - I am not sure whether Mint 13 or Mint 14 KDE.
For now, would like to solve the issue at hand though..
Perhaps someone with some interest in repairing such problems and Linux knowledge could offer a hand, pretty please
DarioTW
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 22, 2013 8:22 am

Re: Error - Update Manager does not work

Postby cwsnyder on Sun Feb 24, 2013 7:29 pm

Linux Mint 11 Katya has been obsolete with no update repositories for about 4 months, and Ubuntu 11.04 Natty no longer supported for the same time period. You will be able to continue using Katya, but will be unable to update or add applications. See http://www.linuxmint.com/oldreleases.php and http://releases.ubuntu.com/

You will have to update, probably to Linux Mint 13 Maya unless you wish to reach the same point with Lisa in 2 months. Maya is a Long Term Support version, supported until 2017 and is equivalent to Ubuntu 12.04 Precise Pangolin.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Error - Update Manager does not work

Postby Iurydice on Sun Feb 24, 2013 7:54 pm

DarioTW wrote:Recently I tried to update to the newer MyPaint and after getting the ppa etc I got this message:
E: Type 'ain' is not known on line 3 in source list /etc/apt/sources.list.d/achadwick-mypaint-testing-natty.list


You've encountered a bug - https://bugs.launchpad.net/ubuntu/+sour ... bug/789859

However, you can solve it if you still want to :)
Just edit the problematic file and remove the line 3 which contains "ain". Then save the file and run sudo apt-get update. If everything went well, you shouldn't get those errors anymore.

So, in your terminal type:
sudo gedit /etc/apt/sources.list.d/achadwick-mypaint-testing-natty.list

The file should open (if you don't use gedit, just replace it with the name of your text editor). Remove the line 3 and save the file. Then run sudo apt-get update.

Alternatively, you can delete that file altogether; type sudo rm /etc/apt/sources.list.d/achadwick-mypaint-testing-natty.list and update apt-get.

Good luck and let us know if it works ;)
If you think you're the only one, think again.
User avatar
Iurydice
Level 2
Level 2
 
Posts: 68
Joined: Mon Apr 07, 2008 4:18 pm

Re: Error - Update Manager does not work

Postby DarioTW on Wed Feb 27, 2013 10:47 am

Hello,
Thank you so much - I removed ain and saved, and it worked, namely my Synaptic Package Manager works now, and the Update Manager is showing nice green mark of being 'all right'

Just when typing - sudo apt-get update - into terminal I get at the end the following:
'' W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/n ... 4/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead. ''

Thus all seems fine for Linux Mint 11; now I have to upgrade to Mint 13 or Linux 12.04 Studio etc

Again, thanks to all :)
DarioTW
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 22, 2013 8:22 am

Re: Error - Update Manager does not work

Postby DarioTW on Wed Feb 27, 2013 10:47 am

Hello,
Thank you so much - I removed ain and saved, and it worked, namely my Synaptic Package Manager works now, and the Update Manager is showing nice green mark of being 'all right'

Just when typing - sudo apt-get update - into terminal I get at the end the following:
'' W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/n ... 4/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead. ''

Thus all seems fine for Linux Mint 11; now I have to upgrade to Mint 13 or Linux 12.04 Studio etc

Again, thanks to all :)
DarioTW
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 22, 2013 8:22 am

Re: Error - Update Manager does not work

Postby Iurydice on Wed Feb 27, 2013 12:45 pm

DarioTW wrote:Just when typing - sudo apt-get update - into terminal I get at the end the following:
'' W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/n ... 4/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead. ''


This happens because there is no "natty" folder among the extras. Check here: http://extras.ubuntu.com/ubuntu/dists/

If you don't want to see this error anymore, you should probably remove that repository, either via Synaptic or by manually editing your /etc/apt/sources.list file.
If you think you're the only one, think again.
User avatar
Iurydice
Level 2
Level 2
 
Posts: 68
Joined: Mon Apr 07, 2008 4:18 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: engelx, Google [Bot], jonesypeter, Mangar and 27 guests