Control + F not working

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Control + F not working

Postby Mr.Hart on Fri Feb 22, 2013 8:49 am

Linux Mint 14 with cinnamon, apparently updated

Hi, since some days ago the 'Control + F' shortcut doesn't work in any aplication.
Even in 'keyboard layout' when I see the keyboard map all the keys work except Control + F, that doesn't appear to respond (they DO work on their own), BUT when I try to bind it in the keyboard shortcut options It does respond, but I don't want to bind it, I want it to use the default purpose (aka search in opera or gedit).

The only thing I may messed up is:

Code: Select all
For Linux Mint 14 ("Workaround")

The setting for a custom keyboard shortcut didn't work well when tested in Linux Mint 14, but there's a workaround to create a "Keyboard Alternate", using back the old and yet functional keyboard setting:
 Press Alt-F2 and enter gksu gedit /usr/share/applications/keyboard-settings.desktop to create a new desktop file.
 Paste the following code inside the new file and save it.
 [Desktop Entry]
 Name=Keyboard
 Comment=Change keyboard settings
 Exec=gnome-control-center keyboard
 Icon=preferences-desktop-keyboard
 Terminal=false
 Type=Application
 StartupNotify=true
 Categories=GNOME;GTK;Settings;HardwareSettings;X-GNOME-Settings-Panel;
 OnlyShowIn=GNOME;Unity;
 X-GNOME-Bugzilla-Bugzilla=GNOME
 X-GNOME-Bugzilla-Product=gnome-control-center
 X-GNOME-Bugzilla-Component=keyboard
 X-GNOME-Bugzilla-Version=3.4.2
 X-GNOME-Settings-Panel=keyboard[Desktop Entry]
 Name=Keyboard Alternate
 Comment=Change keyboard settings
 Exec=gnome-control-center keyboard
 Icon=preferences-desktop-keyboard
 Terminal=false
 Type=Application
 StartupNotify=true
 Categories=GNOME;GTK;Settings;HardwareSettings;X-GNOME-Settings-Panel;
 OnlyShowIn=GNOME;Unity;
 X-GNOME-Bugzilla-Bugzilla=GNOME
 X-GNOME-Bugzilla-Product=gnome-control-center
 X-GNOME-Bugzilla-Component=keyboard
 X-GNOME-Bugzilla-Version=3.4.2
 X-GNOME-Settings-Panel=keyboard
 Keywords=Shortcut;Repeat;Blink;
 X-Ubuntu-Gettext-Domain=gnome-control-center-2.0

After this workaround, the setting for "Keyboard Alternate" is then available.

Go to Menu > System Tools > System Settings > Keyboard Alternate, and continue to add a new shortcut from Step 2 onwards as used for Linux Mint 13 above.


I did that and I set some shortcuts, now, as far as I remember I didn't mess up with the Control + F, but who knows, so I was wondering, is there any way to set ALL the keyboard functionalities back to its default state? Is there any specific file that is in charge of all shortcuts? What is the 'command' for search in applications, can I bind it myself?


Thanks for the attention, and yeah I did some search but... nothing worked
Mr.Hart
Level 1
Level 1
 
Posts: 3
Joined: Fri Feb 22, 2013 8:37 am

Linux Mint is funded by ads and donations.
 

Re: Control + F not working

Postby bigj231 on Fri Feb 22, 2013 11:51 am

Open the Menu, search for keyboard, adjust shortcuts from there.
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Re: Control + F not working

Postby Mr.Hart on Fri Feb 22, 2013 12:54 pm

bigj231 wrote:Open the Menu, search for keyboard, adjust shortcuts from there.

How does that get me back the control + F function in programs like browser or editor?
I mean there is a 'search' t bind, and I tried binding it there successfully, but it just doesn't work when I want to use it.
Mr.Hart
Level 1
Level 1
 
Posts: 3
Joined: Fri Feb 22, 2013 8:37 am

Re: Control + F not working

Postby FireSoul on Fri Feb 22, 2013 4:53 pm

Mr.Hart wrote:
bigj231 wrote:Open the Menu, search for keyboard, adjust shortcuts from there.

How does that get me back the control + F function in programs like browser or editor?
I mean there is a 'search' t bind, and I tried binding it there successfully, but it just doesn't work when I want to use it.


This works well for me in Mint 14 Cinnamon,maybe you must change keybort settings.
Menu / System Tools / System Settings / Keyboard Layout.Keybort for your country,i have Finland and Antigua and Barbuda.
User avatar
FireSoul
Level 3
Level 3
 
Posts: 126
Joined: Mon Jan 28, 2013 5:15 am

Re: Control + F not working

Postby Mr.Hart on Sat Feb 23, 2013 6:11 am

Thanks for the answer I tried diferent layouts for different languages and there doesn't work the Control + F when I test it with the keyboard activation layout.
Mr.Hart
Level 1
Level 1
 
Posts: 3
Joined: Fri Feb 22, 2013 8:37 am

Re: Control + F not working

Postby rafi on Tue Mar 05, 2013 4:48 am

Just a un-useful complaint that I have the same problem and found no solution that would work for me. I tried, as was suggested elsewhere, to remove potentially offending keybindings using xbindkeys-config but with no success. Looks like, not only due to this particular issue, that keyboard shortcuts in Linux Mint are not really throught through with various different programs interfering with each other... annoying.
rafi
Level 1
Level 1
 
Posts: 10
Joined: Wed Jan 02, 2013 11:46 pm

Re: Control + F not working

Postby anonrate on Thu Mar 14, 2013 3:53 pm

I've just solved the same problem.
What happened: I created a .xbindkeysrc file with

xbindkeys --defaults > ~/.xbindkeysrc

and this was what caused my problem. I found in this file following entry:

# set directly keycode (here control + f with my keyboard)
"xterm"
c:41 + m:0x4

Which I find quite BD... ;-)

So, check your .xbindkeysrc if you have any, otherwise just check output of

xbindkeys --defaults

Maybe it helps.
anonrate
Level 1
Level 1
 
Posts: 5
Joined: Wed Jan 09, 2013 1:59 pm

Linux Mint is funded by ads and donations.
 

Return to Cinnamon

Who is online

Users browsing this forum: Yahoo [Bot] and 11 guests