[SOLVED] mixing with experimental release issue

Post your update and upgrade related errors here
Forum rules
Before you post please read this

[SOLVED] mixing with experimental release issue

Postby Barbalras on Sat Feb 23, 2013 2:57 pm

Hi LMDE users!

Here's my problem: I'm using LMDE and I wanted to update thunar to the current version (1.6.2). So I added the debian experimental release source to the source.list file and I used

Code: Select all
 sudo apt-get -t install experimental thunar


So I thought "Great! Now I have tabs working in thunar. ". But now everytime I want to install something else it fails with unmet dependencies errors. For instance, if I try to install

Code: Select all
 federico@chacoooo:~$ sudo apt-get install hugin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 hugin : Depends: hugin-tools (= 2011.4.0+dfsg-5) but it is not going to be installed
         Depends: enblend (>= 3.2) but it is not going to be installed
         Depends: enfuse but it is not going to be installed
         Depends: libimage-exiftool-perl but it is not going to be installed
         Depends: libboost-signals1.49.0 (>= 1.49.0-1) but it is not going to be installed
         Depends: libboost-system1.49.0 (>= 1.49.0-1) but it is not going to be installed
         Depends: libboost-thread1.49.0 (>= 1.49.0-1) but it is not going to be installed
         Depends: libpano13-2 (>= 2.9.18) but it is not going to be installed
         Depends: libwxbase2.8-0 (>= 2.8.12.1) but it is not going to be installed
         Depends: libwxgtk2.8-0 (>= 2.8.12.1) but it is not going to be installed
 libjpeg-turbo8-dev : Depends: libjpeg-turbo8 (= 1.2.1-1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


Anyway, "apt-get -f install" doesn't do any good:

Code: Select all
federico@chacoooo:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libjpeg-turbo8
The following NEW packages will be installed:
  libjpeg-turbo8
0 upgraded, 1 newly installed, 0 to remove and 10 not upgraded.
Need to get 0 B/121 kB of archives.
After this operation, 327 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  libjpeg-turbo8
Install these packages without verification [y/N]? y
(Reading database ... 229787 files and directories currently installed.)
Unpacking libjpeg-turbo8:amd64 (from .../libjpeg-turbo8_1.2.1-1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libjpeg-turbo8_1.2.1-1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libjpeg.so.8', which is also in package libjpeg8:amd64 8d-1
Errors were encountered while processing:
 /var/cache/apt/archives/libjpeg-turbo8_1.2.1-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


What can I do??? thanks!
Last edited by Barbalras on Mon Feb 25, 2013 8:08 pm, edited 1 time in total.
Barbalras
Level 1
Level 1
 
Posts: 5
Joined: Sat Feb 23, 2013 2:34 pm

Linux Mint is funded by ads and donations.
 

Re: mixing with experimental release issue

Postby Monsta on Sat Feb 23, 2013 3:56 pm

Barbalras wrote:
Code: Select all
WARNING: The following packages cannot be authenticated!
  libjpeg-turbo8
Install these packages without verification [y/N]? y
(Reading database ... 229787 files and directories currently installed.)
Unpacking libjpeg-turbo8:amd64 (from .../libjpeg-turbo8_1.2.1-1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libjpeg-turbo8_1.2.1-1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libjpeg.so.8', which is also in package libjpeg8:amd64 8d-1
Errors were encountered while processing:
 /var/cache/apt/archives/libjpeg-turbo8_1.2.1-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

That library is not present in Debian repos. Have you added any Ubuntu repos, e.g. while trying to install an older version of Steam (I heard it used to depend on that lib, but does not anymore)?

Please post the output of
Code: Select all
inxi -Sr
and
Code: Select all
cat /etc/apt/preferences
Monsta
Level 8
Level 8
 
Posts: 2497
Joined: Fri Aug 19, 2011 3:46 am

Re: mixing with experimental release issue

Postby Barbalras on Sat Feb 23, 2013 6:06 pm

Thanks for your reply!

I think I haven't used any ubuntu repo, but maybe I forgot about it. Anyway, here's the output you requested

Code: Select all
federico@chacoooo:~$ inxi -Sr
System:    Host chacoooo Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import
           deb http://debian.linuxmint.com/latest testing main contrib non-free
           deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
           deb http://debian.linuxmint.com/latest/multimedia testing main non-free
           deb http://suwako.nomanga.net/debian sid main contrib
           deb-src http://suwako.nomanga.net/debian sid main
           deb http://ftp.us.debian.org/debian/ sid main non-free contrib
           deb http://ftp.debian.org/debian experimental main


Code: Select all
federico@chacoooo:~$ cat /etc/apt/preferences
Package: *
Pin: release o=linuxmint
Pin-Priority: 700

Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700

Package: *
Pin: release o=Debian
Pin-Priority: 500

Package: *
Pin: release o=experimental
Pin-Priority: 200
Barbalras
Level 1
Level 1
 
Posts: 5
Joined: Sat Feb 23, 2013 2:34 pm

Re: mixing with experimental release issue

Postby Monsta on Sun Feb 24, 2013 2:28 am

Barbalras wrote:
Code: Select all
           deb http://suwako.nomanga.net/debian sid main contrib
           deb-src http://suwako.nomanga.net/debian sid main

Ah, so this one looks like the culprit. I can't check the repo right now (the website seems to be down), but a little googling hints this repo contains that libjpeg-turbo8 which conflicts with debian's libjpeg8. You can check it by running
Code: Select all
apt-cache policy libjpeg-turbo8
and
Code: Select all
apt show libjpeg-turbo8


Barbalras wrote:
Code: Select all
           deb http://ftp.us.debian.org/debian/ sid main non-free contrib
           deb http://ftp.debian.org/debian experimental main

And these two have a chance to break your LMDE unless you set the priorities right.


Barbalras wrote:
Code: Select all
federico@chacoooo:~$ cat /etc/apt/preferences
Package: *
Pin: release o=linuxmint
Pin-Priority: 700

Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700

Package: *
Pin: release o=Debian
Pin-Priority: 500

Package: *
Pin: release o=experimental
Pin-Priority: 200

IIRC, the last section with "experimental" should be placed before the section with "Pin: release o=Debian".
Also, I'd set the priority for the experimental repo to 1 to prevent any auto-installations during dist-upgrade. (See man apt_preferences for more info.)
As for the unstable repo (sid), I don't know what you need it for, but I'd make a similar entry for it with priority set to 1. I wouldn't want to make a mess of my LMDE install by accidentally dist-upgrading it to sid. :D
Monsta
Level 8
Level 8
 
Posts: 2497
Joined: Fri Aug 19, 2011 3:46 am

Re: mixing with experimental release issue

Postby Barbalras on Sun Feb 24, 2013 10:51 am

Ok!
I commented out the suwako repos (actually, I don't remember why I was using them) and changed the preferences according to your suggestions. I did an "apt-get update" and then "apt-get upgrade" but it's still failing:

Code: Select all
federico@chacoooo:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libjpeg-turbo8-dev : Depends: libjpeg-turbo8 (= 1.2.1-1) but it is not installable
E: Unmet dependencies. Try using -f.


Code: Select all
federico@chacoooo:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libjpeg8-dev
The following packages will be REMOVED:
  libjpeg-turbo8-dev
The following NEW packages will be installed:
  libjpeg8-dev
0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
Need to get 0 B/242 kB of archives.
After this operation, 630 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 229440 files and directories currently installed.)
Unpacking libjpeg8-dev:amd64 (from .../libjpeg8-dev_8d-1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libjpeg8-dev_8d-1_amd64.deb (--unpack):
 trying to overwrite '/usr/include/jpeglib.h', which is also in package libjpeg-turbo8-dev:amd64 1.2.1-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libjpeg8-dev_8d-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


I see that it's trying to install a different package now but it's still stuck
Barbalras
Level 1
Level 1
 
Posts: 5
Joined: Sat Feb 23, 2013 2:34 pm

Re: mixing with experimental release issue

Postby Monsta on Sun Feb 24, 2013 12:49 pm

Well... the situation is complicated because I don't know how many packages you've already installed from sid, experimental and that suwako repo.

As for this libjpeg8 case, looks like some other package depends on it. Try removing libjpeg-turbo8-dev first, if something depends on it then apt-get should tell you that. You can even simulate the deletion first to play it safe (nothing will actually be removed):
Code: Select all
apt-get -s remove libjpeg-turbo8-dev
Monsta
Level 8
Level 8
 
Posts: 2497
Joined: Fri Aug 19, 2011 3:46 am

Re: mixing with experimental release issue

Postby Barbalras on Sun Feb 24, 2013 1:08 pm

The problem is that I can't remove or install any package without this error coming up:

Code: Select all
federico@chacoooo:~$ sudo apt-get remove libjpeg-turbo8-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libcupsimage2-dev : Depends: libjpeg8-dev but it is not going to be installed or
                              libjpeg-dev
 libtiff4-dev : Depends: libjpeg-dev
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Barbalras
Level 1
Level 1
 
Posts: 5
Joined: Sat Feb 23, 2013 2:34 pm

Re: mixing with experimental release issue

Postby Monsta on Mon Feb 25, 2013 3:06 am

Well, this doesn't look too good. Looks like you'll have to use a lower level tool (dpkg). This is risky since you can introduce more dependency breakages with dpkg, but there's also a good chance of fixing what's broken.

Run this:
Code: Select all
dpkg --force-all --remove libjpeg-turbo8-dev
and then
Code: Select all
apt-get -f install
which should automatically install libjpeg8-dev as a missing dependency.
Monsta
Level 8
Level 8
 
Posts: 2497
Joined: Fri Aug 19, 2011 3:46 am

Re: mixing with experimental release issue

Postby Barbalras on Mon Feb 25, 2013 8:06 pm

heyyy thank you monsta

I'm marking this thread as SOLVED
Barbalras
Level 1
Level 1
 
Posts: 5
Joined: Sat Feb 23, 2013 2:34 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 7 guests