(Solved) Can't connect a 3G modem using Network Manager

Questions about WIFI networks and devices
Forum rules
Before you post please read this

(Solved) Can't connect a 3G modem using Network Manager

Postby rojopablo on Tue Feb 26, 2013 3:14 pm

Hello, I'm trying to connect my ZTE mf264 3g modem in my LMDE UP6 Mate-64bits version. So I configured it in Network Manager just like before in UP3,4 and 5 but now I can't make it work. The modem is recognized and starts to dial but then the connection fails. I've set only the PAP and CHAP methods (the only two supported by my modem). Now I'm using wvdial to connect and it works perfect so the problem could be on network manager configuration. Also the modem works fine in windows xp with the same configuration. Any idea?
Last edited by rojopablo on Mon Jul 01, 2013 1:23 pm, edited 2 times in total.
Veni Vidi Vici
User avatar
rojopablo
Level 1
Level 1
 
Posts: 4
Joined: Tue Jul 24, 2012 9:41 pm
Location: Córdoba, Argentina

Linux Mint is funded by ads and donations.
 

Re: (Solved) Can't connect a 3G modem using Network Manager

Postby rojopablo on Thu Feb 28, 2013 12:51 am

I had to install the latest network manager packages from Debian Wheezy repos.
gir1.2-networkmanager-1.0 (0.9.4.0-6) to 0.9.4.0-10
network-manager (0.9.4.0-6) to 0.9.4.0-10
network-manager-gnome (0.9.4.1-2) to 0.9.4.1-5
usb-modeswitch-data (20120531-1) to 20120815-2
Veni Vidi Vici
User avatar
rojopablo
Level 1
Level 1
 
Posts: 4
Joined: Tue Jul 24, 2012 9:41 pm
Location: Córdoba, Argentina

Re: (Solved) Can't connect a 3G modem using Network Manager

Postby daniel227 on Fri Apr 19, 2013 1:40 pm

did it work?
no problems?
i have the same problem on 2 debian stable based installs and am trying your solution.
User avatar
daniel227
Level 1
Level 1
 
Posts: 37
Joined: Sat Nov 05, 2011 6:37 am

Re: (Solved) Can't connect a 3G modem using Network Manager

Postby daniel227 on Fri Apr 19, 2013 2:44 pm

nope.
not here.
i did everything through gdebi, made at least 3x shutdown & restart, the modem still doesn't show up. it shows up as a drive in the "computer" file manager window. right-clicking the network-manager systray icon, mobile networking doesn't even show up.
wvdial connects the modem fine, though. it's a huawei e180.
i'm stumped, because i know it's been working on other (not debian stable based) installs.
User avatar
daniel227
Level 1
Level 1
 
Posts: 37
Joined: Sat Nov 05, 2011 6:37 am

Re: (Solved) Can't connect a 3G modem using Network Manager

Postby daniel227 on Sat Apr 20, 2013 3:25 pm

continuing my monologue...
it is working now, it seems it needed un- and re-plugging while linux is running. or maybe it needed exactly 5 reboots, i really don't know.
but now i have the desired behaviour, too.
User avatar
daniel227
Level 1
Level 1
 
Posts: 37
Joined: Sat Nov 05, 2011 6:37 am


Return to Wireless

Who is online

Users browsing this forum: No registered users and 4 guests