Would like to enter WPA/WPA2 pass code one time only.

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Would like to enter WPA/WPA2 pass code one time only.

Postby Pythzor on Tue Feb 26, 2013 9:01 am

Hello,

I'm running LMDE 201204. Each time I boot, I have to put in the WPA/WPA2 pass code to connect to wi-fi. This is the only os I've used that requires me to do this; all others (including other LMDE installs) only require it once. What do I need to do to rectify this?

Any help is much appreciated. Thanks.

The computer is the one in my signature below.

rmd@lmde:~$ sudo /usr/lib/linuxmint/mintWifi/mintWifi.py
[sudo] password for rmd:
-------------------------
* I. scanning WIFI PCI devices...
-- Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
==> PCI ID = 10ec:8178 (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
lo no wireless extensions.

vboxnet0 no wireless extensions.

eth1 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"WOW!480389"
Mode:Managed Frequency:2.447 GHz Access Point: 00:1D:D1:3E:6C:80
Bit Rate=54 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=57/70 Signal level=-53 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:200132 Missed beacon:0

-------------------------
* IV. querying ifconfig...
eth1 Link encap:Ethernet HWaddr f8:0f:41:25:2b:23
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:43 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1456 errors:0 dropped:0 overruns:0 frame:0
TX packets:1456 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:149847 (146.3 KiB) TX bytes:149847 (146.3 KiB)

wlan0 Link encap:Ethernet HWaddr c8:60:00:d4:b5:bc
inet addr:192.168.0.4 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::ca60:ff:fed4:b5bc/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1251095 errors:0 dropped:0 overruns:0 frame:0
TX packets:730857 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1833152125 (1.7 GiB) TX bytes:62638860 (59.7 MiB)

-------------------------
* V. querying DHCP...
Reloading /etc/samba/smb.conf: smbd only.
RTNETLINK answers: File exists
-------------------------
* VI. querying nslookup google.com...
Server: 64.233.222.2
Address: 64.233.222.2#53

Non-authoritative answer:
Name: google.com
Address: 74.125.228.65
Name: google.com
Address: 74.125.228.67
Name: google.com
Address: 74.125.228.71
Name: google.com
Address: 74.125.228.64
Name: google.com
Address: 74.125.228.69
Name: google.com
Address: 74.125.228.68
Name: google.com
Address: 74.125.228.72
Name: google.com
Address: 74.125.228.70
Name: google.com
Address: 74.125.228.73
Name: google.com
Address: 74.125.228.66
Name: google.com
Address: 74.125.228.78

rmd@lmde:~$
AMD Athlon II X2 220 Processor × 2 , 2.8 GHz, 6 GB, Nvidia PNY 210, 1 TB hdd: Windows 7; Ubuntu 13.10; Linux Mint 16 Petra. /// Gateway E4000, Intel Pentium 4, 1.8 Ghz; 1.0 GB RAM, Geforce 5500; 32 bit; Windows 7, PCLinuxOS 201404 Mate Desktop.
Pythzor
Level 3
Level 3
 
Posts: 157
Joined: Fri Jul 09, 2010 7:05 pm

Linux Mint is funded by ads and donations.
 

Re: Would like to enter WPA/WPA2 pass code one time only.

Postby Dark Corner on Thu Feb 28, 2013 11:43 am

I have been struggling with this problem for two weeks (ever since installing my first ever use of Linux Mint on a brand new build). Note: Linux Mint 14 64-bit, Netgear WG311v3 wireless card. I have several times thought that I found a solution, but after several cycles of shut down/power up, the automatic wireless network login has reverted to asking (repeatedly) for the network password. The solution that currently seems to be working is to open Network Settings and, under Wireless Options, check both the "Connect automatically" and the "Available to all users" checkboxes. The downside of this solution is that any user can now open Network Settings and view the wireless password by checking the "Show password" checkbox under the Wireless Options, Wireless Security tab.
Dark Corner
Level 1
Level 1
 
Posts: 2
Joined: Tue Feb 19, 2013 10:51 am

Re: Would like to enter WPA/WPA2 pass code one time only.

Postby eanfrid on Thu Feb 28, 2013 1:53 pm

Dark Corner wrote:The solution that currently seems to be working is to open Network Settings and, under Wireless Options, check both the "Connect automatically" and the "Available to all users" checkboxes.
This is the right move. Only an admin user can do or modify this. Then
Code: Select all
The downside of this solution is that any user can now open Network Settings and view the wireless password by checking the "Show password" checkbox under the Wireless Options, Wireless Security tab
is a non-issue: this user is then already 0wning your machine. This is not a wireless security problem anymore.
Main desktop: Debian GNU/Linux Wheezy 64bit w/custom 3.14 longterm kernel - MATE 1.8.1
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
User avatar
eanfrid
Level 7
Level 7
 
Posts: 1591
Joined: Mon Apr 30, 2012 2:49 am
Location: there is no place like ~

<SOLVED> Would like to enter WPA/WPA2 pass code one time onl

Postby Pythzor on Sun Mar 17, 2013 6:57 pm

Dark Corner wrote: The solution that currently seems to be working is to open Network Settings and, under Wireless Options, check both the "Connect automatically" and the "Available to all users" checkboxes. .


Thank you! That works just fine.
AMD Athlon II X2 220 Processor × 2 , 2.8 GHz, 6 GB, Nvidia PNY 210, 1 TB hdd: Windows 7; Ubuntu 13.10; Linux Mint 16 Petra. /// Gateway E4000, Intel Pentium 4, 1.8 Ghz; 1.0 GB RAM, Geforce 5500; 32 bit; Windows 7, PCLinuxOS 201404 Mate Desktop.
Pythzor
Level 3
Level 3
 
Posts: 157
Joined: Fri Jul 09, 2010 7:05 pm

Re: Would like to enter WPA/WPA2 pass code one time only.

Postby Pythzor on Sun Mar 17, 2013 6:59 pm

eanfrid wrote:
Dark Corner wrote:The solution that currently seems to be working is to open Network Settings and, under Wireless Options, check both the "Connect automatically" and the "Available to all users" checkboxes.
This is the right move. Only an admin user can do or modify this. Then
Code: Select all
The downside of this solution is that any user can now open Network Settings and view the wireless password by checking the "Show password" checkbox under the Wireless Options, Wireless Security tab
is a non-issue: this user is then already 0wning your machine. This is not a wireless security problem anymore.


Not so. My root password is not my WPA/WPA2 pass code.
AMD Athlon II X2 220 Processor × 2 , 2.8 GHz, 6 GB, Nvidia PNY 210, 1 TB hdd: Windows 7; Ubuntu 13.10; Linux Mint 16 Petra. /// Gateway E4000, Intel Pentium 4, 1.8 Ghz; 1.0 GB RAM, Geforce 5500; 32 bit; Windows 7, PCLinuxOS 201404 Mate Desktop.
Pythzor
Level 3
Level 3
 
Posts: 157
Joined: Fri Jul 09, 2010 7:05 pm

Re: Would like to enter WPA/WPA2 pass code one time only.

Postby eanfrid on Sun Mar 17, 2013 7:21 pm

My root password is not my WPA/WPA2 pass code.

This not what I meant :)
Main desktop: Debian GNU/Linux Wheezy 64bit w/custom 3.14 longterm kernel - MATE 1.8.1
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
User avatar
eanfrid
Level 7
Level 7
 
Posts: 1591
Joined: Mon Apr 30, 2012 2:49 am
Location: there is no place like ~

Re: Would like to enter WPA/WPA2 pass code one time only.

Postby MarkDW on Fri Jul 26, 2013 10:06 am

I have similar problem. Linux Mint 15, ASUS USB-N-13 wireless adapter.

Mint automatically found and ran the adapter, saw all the available wireless networks. When I connect to mine, it continually came back reasking for the (already correctly filled in) password. Again and again.

Last night I booted Mint and Voila! out of the blue it connected first time without even asking for the password.

This morning I booted...it prompted for the password. I kept hitting "enter" and after about 10 tries, it connected.

"Connect automatically" and "everyone can connect" is already checked.

Really frustrating. It's not a signal strength issue.

Oh and another fun inconsistency: If I turn my Android phone into a hotspot, also WPK passworded, my Mint will connect everytime (like it's supposed to).

EDIT to add:

It seems like 6-7 are the magic numbers. Whenever I boot up, I get the "connect" prompt (with correct WPA password prefilled out), and I have to click it 6 or 7 times for it to stop re-asking for the password, and connect.

That's an irritant.
MarkDW
Level 1
Level 1
 
Posts: 1
Joined: Fri Jul 26, 2013 10:01 am

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: No registered users and 1 guest