No k9copy in LMDE? (solved)

Questions about applications and software
Forum rules
Before you post please read this

No k9copy in LMDE? (solved)

Postby Whitefort on Thu Feb 28, 2013 3:48 pm

Hi. I'm running various flavours of Mint on all my computers now, but I really love the idea of LMDE and I've installed it on my main day-to-day PC.

All great, until I tried to install k9copy and discovered that it doesn't show up at all in Synaptic package manager. I'm a bit surprised by this, because it's still alive and well in all my other Mint distros. I'm guess this is some repository thing. Is there a repository I can add to get access to K9copy?

(if so, and tip on how to add it would also be much appreciated! Newbie to this sort of thing!)

Thanks!
Last edited by Whitefort on Fri Mar 01, 2013 6:34 pm, edited 1 time in total.
Whitefort
Level 1
Level 1
 
Posts: 42
Joined: Mon Oct 17, 2011 2:53 pm

Linux Mint is funded by ads and donations.
 

Re: No k9copy in LMDE?

Postby phlux on Thu Feb 28, 2013 6:38 pm

Hello there,

According to Sourceforge, K9Copy has been inactive since 2011. I can try to put some instructions together on how to get it working on LMDE regardless.

In the meantime, have you tried XDVDShrink? It is in the repositories, and I hear it works well for what you're trying to accomplish with K9Copy.
Image
User avatar
phlux
Level 1
Level 1
 
Posts: 24
Joined: Wed Feb 27, 2013 9:49 am
Location: Houston, TX

Re: No k9copy in LMDE?

Postby zerozero on Thu Feb 28, 2013 7:09 pm

k9copy was removed from debian http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=686504 in sept last year because it was not maintained upstream anymore (since http://k9copy.sourceforge.net/web/index.php/en/news july 2011)
DVD95 is another option
zerozero
Level 16
Level 16
 
Posts: 6470
Joined: Tue Jul 07, 2009 2:29 pm

Re: No k9copy in LMDE?

Postby Whitefort on Fri Mar 01, 2013 9:44 am

Many thanks for the replies.

I knew that development had stopped on K9copy, but I keep using it because it still 'just works'. I wasn't previously aware of either XDVDShrink or DVD95. I've had a look at both of them this morning, but haven't yet managed to get either of them working (one stops with a one-line error message in what looks like French, and the other gives me a long error log that's totally beyond my comprehension.)

I'll keep trying with them on of my other machines, but in the meantime I think I'll keep the Ubuntu-based Mint on my main PC.

Thanks again for replying!
Whitefort
Level 1
Level 1
 
Posts: 42
Joined: Mon Oct 17, 2011 2:53 pm

Re: No k9copy in LMDE?

Postby phlux on Fri Mar 01, 2013 10:03 am

Whitefort wrote:Many thanks for the replies.

I knew that development had stopped on K9copy, but I keep using it because it still 'just works'. I wasn't previously aware of either XDVDShrink or DVD95. I've had a look at both of them this morning, but haven't yet managed to get either of them working (one stops with a one-line error message in what looks like French, and the other gives me a long error log that's totally beyond my comprehension.)

I'll keep trying with them on of my other machines, but in the meantime I think I'll keep the Ubuntu-based Mint on my main PC.

Thanks again for replying!


Would you mind posting the error messages you're receiving? Perhaps we can either A) help solve them or B) file necessary bug reports to get them working.
Image
User avatar
phlux
Level 1
Level 1
 
Posts: 24
Joined: Wed Feb 27, 2013 9:49 am
Location: Houston, TX

Re: No k9copy in LMDE?

Postby Whitefort on Fri Mar 01, 2013 11:11 am

Hi,
No problem, here's the log.

It's just probably something stupid I'm doing, or that I ought to know but don't - that seems to be the case with 98% of my Linux problems!

Here's the log from DVDshrink:

Code: Select all
03/01/13 14:56:38    DVDShrink log for MTD5777\n
                     Project variables
                     -----------------------------------------------

                     WDEVICE=/dev/sr0
                     RDEVICE=/dev/sr0
                     RMFILES=0
                     AUTOBURN=1
                     AUDIO=0
                     TITLE=1
                     SUBTITLE=0
                     ALANG=en
                     SLANG=en
                     PROJNAME=MTD5777
                     CHAPFILE=/tmp/MTD5777/MTD5777.chap
                     WORKDIR=/tmp/MTD5777
                     VIDEOFILE=/tmp/MTD5777/MTD5777.m2v
                     SHRNKFILE=/tmp/MTD5777/shrunken.MTD5777.m2v
                     AUDIOFILE=/tmp/MTD5777/MTD5777.ac3
                     SUBFILE=/tmp/MTD5777/MTD5777.sub
                     MPGFILE=/tmp/MTD5777/MTD5777.mpg
                     MUXFILE=/tmp/MTD5777/muxed.mpg
                     VFIFO=/tmp/videofifo
                     AFIFO=/tmp/audiofifo
                     SFIFO=/tmp/subtitlefifo
                     CMDFILE=/tmp/dvdshrink.prog
                     VARFILE=/tmp/dvdshrink.var
                     INFOFILE=/tmp/MTD5777/MTD5777.info
                     ISOONLY=0
                     SHRINK=1
                     STREAMONLY=0
                     BIGSTREAMONLY=0
                     MPEGONLY=0
                     BIGMPEGONLY=0
                     RMFILES=0
                     ADDTITLES=0
                     MYSHRINK=0
                     AUTHORONLY=0
                     DELETELOGS=1
                     
                     Source DVD Selections
                     -----------------------------------------------

                     Title:                   1
                     Audio stream:            0
                     Audio language:          en
                     
                     Chapter list
                     -----------------------------------------------

                     00:00:00.000,00:00:10.000
03/01/13 14:56:38    Commenced DVD rip.
                     Video stream: /tmp/MTD5777/MTD5777.m2v
                     Audio stream: /tmp/MTD5777/MTD5777.ac3
03/01/13 14:56:39    DVD rip completed. Elapsed time [00:00:01]
                     Maximum size per title allowed:   4700000000
                     Size of elemental streams: Video: 5528430
                                                Audio: 256512
                                                Sub:   0
                     Calculated shrink factor:         .0
                     No shrink required
03/01/13 14:56:39    Re-multiplexing of /tmp/MTD5777/MTD5777.mpg started.
03/01/13 14:56:39    nice -n +19 mplex -f 8 -o /tmp/MTD5777/MTD5777.mpg -S 0 /tmp/MTD5777/MTD5777.m2v /tmp/MTD5777/MTD5777.ac3 2> /tmp/MTD5777/mplexdebug.txt failed!
                     mplex reported an error re-multiplexing the MPEG2!
                     Run terminated!
                       
                     Output of debug file
                       
   INFO: [mplex] mplex version 1.9.0 (2.2.7 $Date: 2006/02/01 22:23:01 $)
   INFO: [mplex] File /tmp/MTD5777/MTD5777.m2v looks like an MPEG Video stream.
   INFO: [mplex] File /tmp/MTD5777/MTD5777.ac3 looks like an AC3 Audio stream.
   INFO: [mplex] Video stream 0: profile 8 selected - ignoring non-standard options!
   INFO: [mplex] Found 1 audio streams and 1 video streams
   INFO: [mplex] Selecting dvdauthor DVD output profile
   INFO: [mplex] Multiplexing video program stream!
   INFO: [mplex] Scanning for header info: Video stream e0 (/tmp/MTD5777/MTD5777.m2v)
   INFO: [mplex] VIDEO STREAM: e0
   INFO: [mplex] Frame width     : 720
   INFO: [mplex] Frame height    : 576
   INFO: [mplex] Aspect ratio    : 16:9 display
   INFO: [mplex] Picture rate    : 25.000 frames/sec
   INFO: [mplex] Bit rate        : 8000000 bits/sec
   INFO: [mplex] Vbv buffer size : 229376 bytes
   INFO: [mplex] CSPF            : 0
   INFO: [mplex] Scanning for header info: AC3 Audio stream 00 (/tmp/MTD5777/MTD5777.ac3)
   INFO: [mplex] AC3 frame size = 768
   INFO: [mplex] AC3 AUDIO STREAM:
   INFO: [mplex] Bit rate       :    24576 bytes/sec (192 kbit/sec)
   INFO: [mplex] Frequency      :     48000 Hz
   INFO: [mplex] SYSTEMS/PROGRAM stream:
   INFO: [mplex] rough-guess multiplexed stream data rate    : 8365848
   INFO: [mplex] target data-rate specified               : 10080000
   INFO: [mplex] Setting specified specified data rate: 10080000
   INFO: [mplex] Scanned to end AU 0
   INFO: [mplex] Run-in delay = 10800 Video delay = 10800 Audio delay = 14400
   INFO: [mplex] New sequence commences...
   INFO: [mplex] Video e0: buf=      0 frame=000000 sector=00000000
   INFO: [mplex] Audio bd: buf=      0 frame=000000 sector=00000000
   INFO: [mplex] Sequence end marker! Running out...
   INFO: [mplex] Run out PTS limit to AU 1 25200 SCR=5997
   INFO: [mplex] Video e0: buf=  80987 frame=000000 sector=00000040
   INFO: [mplex] Audio bd: buf=      0 frame=000000 sector=00000000
**ERROR: [mplex] Need to split output but there appears to be no %d in the filename pattern /tmp/MTD5777/MTD5777.mpg



The error message fromDVD95 is "Alcun utilitaire de gravure install!" According to Google translate, this is "Alcun burning utility install!", which made me think I needed to install something called alcun - but I can't find anything of the sort. When I click that message away, there's another that says 'conversion error.'

If anyone has time to help that would be great. Great as the ubuntu-mint is, I kinda like the idea of moving entirely to LMDE. (though I'm beginning to realise I'll need to learn a lot more about Linux to do so... but that's a GOOD thing, right?)
Whitefort
Level 1
Level 1
 
Posts: 42
Joined: Mon Oct 17, 2011 2:53 pm

Re: No k9copy in LMDE?

Postby phlux on Fri Mar 01, 2013 11:24 am

Thanks for the logging information. Quick question: Are you trying to convert an MPEG to DVD using this software, or are you using it to copy DVDs? If it's the former, may I suggest using bombono-dvd? It's the best tool I've found for converting compressed video files to DVD format. If it's the latter, give me a few minutes to find a solution, and I will get back to you.
Image
User avatar
phlux
Level 1
Level 1
 
Posts: 24
Joined: Wed Feb 27, 2013 9:49 am
Location: Houston, TX

Re: No k9copy in LMDE?

Postby Whitefort on Fri Mar 01, 2013 11:30 am

Hi Phlux,

I'm trying to use it as a DVD copier, though the info about Bombono sounds useful too. Thanks!
Whitefort
Level 1
Level 1
 
Posts: 42
Joined: Mon Oct 17, 2011 2:53 pm

Re: No k9copy in LMDE?

Postby phlux on Fri Mar 01, 2013 11:45 am

Roger that. I'll have to debug DVD95 and XDVDShrink when I get home, as I'm not on my LMDE workstation at the moment. I will be able to look further into those issues (and hopefully fix them) in about 4 hours. I'm thinking a patch may be in order for DVD95, as it's trying to split the mpeg files when they don't necessarily need to be. Passing -M to mplex would help resolve this.

Until then, perhaps you could take a look at http://pkgs.org/debian-squeeze/multimedia-main-amd64/k9copy_2.3.6-0.0_amd64.deb.html for an AMD64 architechture, or http://pkgs.org/debian-squeeze/multimedia-main-i386/k9copy_2.3.6-0.0_i386.deb.html for a potential K9Copy repository. Again, I'm not on my workstation, or I'd test that for you. The website walks you through adding the repository about halfway down the page. You can also try downloading the .deb files individually and running them that way.

If you'd rather me test it out first this afternoon, I'd be glad to do so. If I can grab the packages manually and get them to install, I'll gzip them up (dependencies and all) and send them your way if you'd wish. Regardless, I'll also look into the DVD95 and XDVDShrink issues and see if I can come up with some sort of resolution.

---

As to your statement about learning a lot more, being more hands-on like this will get you there. I'm coming to LMDE after using Gentoo for several years, and Gentoo (along with FreeBSD) has taught me many, many things about my favorite operating system (Linux!). Learning is absolutely a good thing! Knowledge is power, my friend!
Image
User avatar
phlux
Level 1
Level 1
 
Posts: 24
Joined: Wed Feb 27, 2013 9:49 am
Location: Houston, TX

Re: No k9copy in LMDE?

Postby Whitefort on Fri Mar 01, 2013 12:09 pm

MANY thanks for all your help with this. I'm tied up for the next few hours, but I'll definitely be taking a look at the links you mentioned at the first opportunity.

Gentoo!!! When I first thought of trying Linux, Gentoo was one of the Distros I looked at - I ran away crying like a baby!! But one of these days, when I learn a lot more, I'm going to install Gentoo or some other 'experts only' distro on a non-critical machine and start learning by trial and error.
Whitefort
Level 1
Level 1
 
Posts: 42
Joined: Mon Oct 17, 2011 2:53 pm

Re: No k9copy in LMDE?

Postby grizzler on Fri Mar 01, 2013 2:28 pm

Whitefort wrote:The error message fromDVD95 is "Alcun utilitaire de gravure install!"

Looks like somewhat 'unusual' French to me, using the alternative form 'alcun' instead of 'aucun' and cutting off the final e from 'installé'.

According to Google translate, this is "Alcun burning utility install!"

"No burning utility installed!", according to 'grizzler translate', but I admit my French is more than a little rusty.

Does DVD95 need to have something else installed to work with, by any chance?
grizzler
Level 4
Level 4
 
Posts: 422
Joined: Wed Jun 15, 2011 5:19 pm
Location: The Hague, NL

Re: No k9copy in LMDE?

Postby phlux on Fri Mar 01, 2013 3:54 pm

OK, for the sake of our sanity, I decided not to built K9Copy from source as it uses CMake, and I don't have a working KDE environment. Here's what I have done, however:

1) Install the necessary dependencies:

Code: Select all
sudo apt-get install dvd+rw-tools dvdauthor genisoimage kdebase-runtime libc6 libkdecore5 libkdesu5 libkdeui5 libkio5 libmpeg2-4 libphonon4 libqt4-dbus libqt4-xml libqtcore4 libqtgui4 libsolid4 libstdc++6 libswscale0 libx11-6 libxine1 libxine1-x mjpegtools phonon cmake


2) Download the "Stable" k9copy .deb file. For amd64, this will be: http://www.deb-multimedia.org/pool/main/k/k9copy/k9copy_2.3.6-0.0_amd64.deb For i386, use http://www.deb-multimedia.org/pool/main/k/k9copy/k9copy_2.3.6-0.0_i386.deb

3) Open a terminal and issue:

Code: Select all
sudo dpkg -i /path/to/k9copy_2.3.6.deb


Afterwards, you should have a working copy of k9copy on LMDE. Enjoy!

If you have any issues with this, just respond here and we'll see if we can't sort them.
Last edited by phlux on Fri Mar 01, 2013 5:56 pm, edited 1 time in total.
Image
User avatar
phlux
Level 1
Level 1
 
Posts: 24
Joined: Wed Feb 27, 2013 9:49 am
Location: Houston, TX

Re: No k9copy in LMDE?

Postby Whitefort on Fri Mar 01, 2013 3:58 pm

Thanks a million, phlux!

Today has turned very busy, but I'll definitely give this a shot over the weekend and report back!
Whitefort
Level 1
Level 1
 
Posts: 42
Joined: Mon Oct 17, 2011 2:53 pm

Re: No k9copy in LMDE?

Postby phlux on Fri Mar 01, 2013 4:01 pm

Whitefort wrote:Thanks a million, phlux!

Today has turned very busy, but I'll definitely give this a shot over the weekend and report back!


Sounds good! I'm running it right now to ensure everything goes smoothly, and so far, so good! :D

EDIT: Everything worked as expected here. Hope you have the same results!
Image
User avatar
phlux
Level 1
Level 1
 
Posts: 24
Joined: Wed Feb 27, 2013 9:49 am
Location: Houston, TX

Re: No k9copy in LMDE?

Postby Whitefort on Fri Mar 01, 2013 6:34 pm

OK - past bedtime here, but I thought I'd give it a go (expecting to make a mess that I'd have to sort out tomorrow!)

But it couldn't have been smoother or more painless. I've just burned a test disk and it's all working perfectly.

I'm in awe. HOW do you ever learn all this stuff??

Anyway, many thanks again! Thread solved, I think!
Whitefort
Level 1
Level 1
 
Posts: 42
Joined: Mon Oct 17, 2011 2:53 pm

Re: No k9copy in LMDE? (solved)

Postby phlux on Fri Mar 01, 2013 6:43 pm

Glad I could be of assistance! Hope it all works out for you! If you run into any issues with it, either update this thread or feel free to shoot me a private message. I'm always down to help!
Image
User avatar
phlux
Level 1
Level 1
 
Posts: 24
Joined: Wed Feb 27, 2013 9:49 am
Location: Houston, TX

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 2 guests