[SOLVED] Doesn't recognize Wifi on Dell Vostro 1000

Questions about WIFI networks and devices
Forum rules
Before you post please read this

[SOLVED] Doesn't recognize Wifi on Dell Vostro 1000

Postby turvarya on Fri Mar 01, 2013 8:20 am

I am currently trying to install linux mint 14 on my gf's Laptop and the WiFi is giving me some hard time.
It works fine in Wndows Vista, at startup you have to activate it, by pressing FN+F2(no hard switch).
As far as I can tell, Mint seem to just don't know, that there is a WiFi-card, FN+F2 doesn't work. I looked around in the Internet, but I am getting realy frustrated about that.

mintwifi gives me this output
-------------------------
Code: Select all
* I. scanning WIFI PCI devices...
  -- Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
      ==> PCI ID = 14e4:4315 (rev 01)
-------------------------
* II. querying ndiswrapper...
bcmwl6 : driver installed
   device (14E4:4315) present (alternate driver: ssb)
-------------------------
* III. querying iwconfig...
ppp0      no wireless extensions.

lo        no wireless extensions.

eth0      no wireless extensions.

-------------------------
* IV. querying ifconfig...
eth0      Link encap:Ethernet  HWaddr 00:21:70:72:a1:d0 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:21

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:88 errors:0 dropped:0 overruns:0 frame:0
          TX packets:88 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:8825 (8.8 KB)  TX bytes:8825 (8.8 KB)

ppp0      Link encap:Point-to-Point Protocol 
          inet addr:10.70.43.200  P-t-P:10.64.64.64  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:4394 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2967 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:4859879 (4.8 MB)  TX bytes:413132 (413.1 KB)

-------------------------
* V. querying DHCP...
-------------------------
* VI. querying nslookup google.com...
Server:      127.0.1.1
Address:   127.0.1.1#53

Non-authoritative answer:
Name:   google.com
Address: 173.194.70.102
Name:   google.com
Address: 173.194.70.101
Name:   google.com
Address: 173.194.70.139
Name:   google.com
Address: 173.194.70.138
Name:   google.com
Address: 173.194.70.113
Name:   google.com
Address: 173.194.70.100


I also tried Windows Wireless Drivers, but even it seems to have installed the Driver, it doesn't change anything.

Any suggestions?

Thanks in advance
Last edited by turvarya on Fri Mar 01, 2013 6:10 pm, edited 1 time in total.
turvarya
Level 1
Level 1
 
Posts: 3
Joined: Fri Mar 01, 2013 7:55 am

Linux Mint is funded by ads and donations.
 

Re: Doesn't recognize Wifi on Dell Vostro 1000

Postby kc1di on Fri Mar 01, 2013 8:47 am

Hello turvarya and welcome to Mint.

In linux Broadcom drivers are not open source and must be install you'll need a hardwire connection to the internet temporarily.

you can install the correct driver by following the instructions on this page:
http://www.howopensource.com/2012/10/install-broadcom-sta-wireless-driver-in-ubuntu-12-10-12-04/

good luck
you have the same card as mine and it works fine once you get the right driver installed.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1211
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Doesn't recognize Wifi on Dell Vostro 1000

Postby turvarya on Fri Mar 01, 2013 9:49 am

ok, thanks, that helped me a lot, but still it's not perfect
The Tutorial says
Once it finished installing the driver Activate the driver using Additional Drivers, then restart your system. After restarting your system it should work.

I am not sure, what that means. Does it mean to use "Windows Wireless Drivers", which I did before?

Now, when I restart mint and use iwconfig, the eth0 is gone. I need to use "modprobe wl", then both, the ethernet card and the wifi-card(which is called eth1) are there again and it works.
So, how can I activate both cards at startup?
turvarya
Level 1
Level 1
 
Posts: 3
Joined: Fri Mar 01, 2013 7:55 am

Re: Doesn't recognize Wifi on Dell Vostro 1000

Postby kc1di on Fri Mar 01, 2013 4:28 pm

Forget the additonal drivers tool it not installed on mint 14.

in order to make the modeprobe wl perminant at boot you'll have edit the /etc/modules file.
you can do that by going to a terminal and entering the following command:

Code: Select all
gksudo gedit /etc/modules


when the file comes up add "wl" (without the quotes) to the list
make sure you leave the last line in the file blank
and save the file,
now reboot and it should load the wl driver automatically.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1211
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Doesn't recognize Wifi on Dell Vostro 1000

Postby turvarya on Fri Mar 01, 2013 6:10 pm

ok, thanks
now it works as expected
turvarya
Level 1
Level 1
 
Posts: 3
Joined: Fri Mar 01, 2013 7:55 am

Re: [SOLVED] Doesn't recognize Wifi on Dell Vostro 1000

Postby kc1di on Fri Mar 01, 2013 7:41 pm

Your welcome, enjoy ;)
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1211
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA


Return to Wireless

Who is online

Users browsing this forum: No registered users and 9 guests