How to install the Nvidia proprietary drivers in LinuxMint

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby moriarty on Sat Feb 09, 2013 6:52 am

Napi2003 wrote:Hello and thanks for the instructions.

One point that keeps popping everywhere and I assume has the failure rate at installing the NVIDIA propietary drivers is the following:

There are no clear / working instructions on how to get rid or even disable the odious "Nouveau" drivers that are deeply rooted on Nadia's (Mint 14.1) distro. Period.

If you can't disable said drivers, all the following steps are totally moot.

1. You can attempt at STOPping the service, and everytime you reboot the system, it will load the GUI, waiting to be "disabled" again and again.
Code: Select all
sudo service mdm stop
sudo /etc/init.d/gdm stop
sudo /etc/init.d/mdm stop

2. Not even an apt-get -remove --PURGE command will do the trick. It will always reinstall and reload each time you reboot the OS.
Code: Select all
sudo apt-get remove --purge nouveau*

3. the NVIDIA installer won't acknowledge your override command that stops checking for nouveau drivers (--no-nouveau-check, --disable-nouveau)
Code: Select all
sudo sh NVIDIA-Linux-x86_64-310.32.run --disable-nouveau
sudo sh NVIDIA-Linux-x86_64-310.32.run --no-nouveau-check

4. The NVIDIA driver installer adds the "nvidia-installer-disable-nouveau.conf" in /etc/modprobe.d with these lines:
Code: Select all
# generated by nvidia-installer
blacklist nouveau
options nouveau modeset=0

Guess what? That doesn't work either. Something as stubborn as this driver should legally be called a virus: It does no good and also refuses to move out.

What is needed is definitive instructions on how oliberate the oudious Nouevau drivers.

The NVIDIA installer acknowledges that it previously added some "trick file" to unload the drivers, but at this point it directs you to read some non-existent (or very well hidden) "README" file or consult your "distro manual" so you can wrestle it yourself at some machine code level.

This thing is starting to feel as hopeless and a total waste of time as ATI equally half-baked propietary drivers. The message is clear: Go back to Windows and forget this nightmare.

Anybody, please help. Thank you.


Napi2003 I completely agree! I have tried pretty much all thinkable tutorials on this, and still couldn't get the driver to work. Linux mint was the first distro that actually made me say "hey linux CAN actually be quite nice", but the sheer horror of countless OS reinstalls, following countless guides - where super-user linux know-how is needed to actually follow the guides - and to no avail makes me frustrated beyond comprehension. I just want to install a freaking display-driver without having to follow long complicated guides including rebooting several time, shifting to the textbased terminal, blacklisting stuff, editing config files, only to find out it didn't work.
moriarty
Level 1
Level 1
 
Posts: 1
Joined: Sat Feb 09, 2013 6:28 am

Linux Mint is funded by ads and donations.
 

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby Otyugh on Sat Feb 09, 2013 7:09 am

Dudes, I have now some problem running free games, but what i can say, it's I made problem up myself (I hope it's your case too, because it's easy, then).
Using the NVIDIA .run just bought problems.
At the end of the day, all i needed was to use the built-in service : Control Panel > Software Source > Aditional Drivers > nvidia-experimental-310

And then i could use softwares like "Starcraft2", which is actually a pretty actual games using last graphic effect (and i'm able to use them all).

So what the problem ? (nb : drivers always been a mess. Don't blame your teacher that the world is complicated. Or use straight on Archlinux if you want to play more with the terminal and think you control everything and stuff ;) -even if you don't understand the heck about what imply what you are tiping at it)
Otyugh
Level 3
Level 3
 
Posts: 125
Joined: Wed Jan 02, 2013 9:52 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby skywolfblue on Sun Feb 10, 2013 8:35 pm

Napi2003 wrote:Hello and thanks for the instructions.

One point that keeps popping everywhere and I assume has the failure rate at installing the NVIDIA propietary drivers is the following:

There are no clear / working instructions on how to get rid or even disable the odious "Nouveau" drivers that are deeply rooted on Nadia's (Mint 14.1) distro. Period.

If you can't disable said drivers, all the following steps are totally moot.

1. You can attempt at STOPping the service, and everytime you reboot the system, it will load the GUI, waiting to be "disabled" again and again.
Code: Select all
sudo service mdm stop
sudo /etc/init.d/gdm stop
sudo /etc/init.d/mdm stop

2. Not even an apt-get -remove --PURGE command will do the trick. It will always reinstall and reload each time you reboot the OS.
Code: Select all
sudo apt-get remove --purge nouveau*

3. the NVIDIA installer won't acknowledge your override command that stops checking for nouveau drivers (--no-nouveau-check, --disable-nouveau)
Code: Select all
sudo sh NVIDIA-Linux-x86_64-310.32.run --disable-nouveau
sudo sh NVIDIA-Linux-x86_64-310.32.run --no-nouveau-check

4. The NVIDIA driver installer adds the "nvidia-installer-disable-nouveau.conf" in /etc/modprobe.d with these lines:
Code: Select all
# generated by nvidia-installer
blacklist nouveau
options nouveau modeset=0

Guess what? That doesn't work either. Something as stubborn as this driver should legally be called a virus: It does no good and also refuses to move out.

What is needed is definitive instructions on how oliberate the oudious Nouevau drivers.

The NVIDIA installer acknowledges that it previously added some "trick file" to unload the drivers, but at this point it directs you to read some non-existent (or very well hidden) "README" file or consult your "distro manual" so you can wrestle it yourself at some machine code level.

This thing is starting to feel as hopeless and a total waste of time as ATI equally half-baked propietary drivers. The message is clear: Go back to Windows and forget this nightmare.

Anybody, please help. Thank you.


This has been my experience as well.

1st try: http://forums.linuxmint.com/viewtopic.php?f=59&t=124653

Since those were older drivers, and I couldn't find out how to make them be "in use" I came to this thread.

2nd try: Followed the instructions in the first post, it installed, but got an API mismatch.

So I had to do some digging, stripped out all the nvidia drivers.

Then started over again.

3rd try: The nvidia installer found and ran it's modprobe on the nouveau drivers.

But when I restarted it didn't work. I got:
WARNING: The modprobe configuration file to disable Nouveau, /etc/modprobe.d/nvidia-installer-disable-nouveau.conf, is already
present. Please be sure you have rebooted your system since that file was written. If you have rebooted, then
Nouveau may be enabled for other reasons, such as being included in the system initial ramdisk or in your X
configuration file. Please consult the NVIDIA driver README and your Linux distribution's documentation for details
on how to correctly disable the Nouveau kernel driver.


So blindly following the advice of of the 4th post in this thread I typed:

Code: Select all
sudo apt-get purge xserver-xorg-video-nouveau libdrm-nouveau1a nvidia*
sudo update-initramfs -u -k all


Bad idea.

The purge wiped out pretty much every single system file, and since it had been wiped "update-initramfs" didn't work.

So I've completely destroyed the system.

I'm feeling really discouraged right now. Installing a driver should not be this bloody hard.
Image
User avatar
skywolfblue
Level 2
Level 2
 
Posts: 78
Joined: Sun Feb 03, 2013 6:59 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby Otyugh on Mon Feb 11, 2013 2:06 am

What about just use the packets that is already done for your card ?
Otyugh
Level 3
Level 3
 
Posts: 125
Joined: Wed Jan 02, 2013 9:52 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby captaindallas on Mon Feb 11, 2013 2:52 am

Napi2003 wrote:
This thing is starting to feel as hopeless and a total waste of time as ATI equally half-baked propietary drivers. The message is clear: Go back to Windows and forget this nightmare.



I can only echo this statement. I've gone through the same ordeal as you and the driver is still refusing to work. I love this distro in every way, except for the unbelievable nightmare it is to get nvidia drivers installed and working. An effort has to be made to make something so simple as installing a display-driver and getting the system to use it easier. I bought a computer with a good graphics card in it because I want to use it, I don't want it to sit inside my computer doing nothing because mint is a complete clusterfudge in getting it to work.

/rant end.
captaindallas
Level 1
Level 1
 
Posts: 3
Joined: Sun Feb 10, 2013 3:32 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby Otyugh on Mon Feb 11, 2013 5:55 am

I'm disturbed guys... Have you tried the EASY WAY first ? I feel not. But you are keeping ignoring me, and that is insulting :evil:

If I'm wrong, just say it. If I'm not, your problem is as hard to solve than two clicks. And you will feel so dumb about it for weeks, because it's so easy. So. Anyone having "omagad omagad" issue have tried to install the proprietary driver by the "Software Source" module ?
Otyugh
Level 3
Level 3
 
Posts: 125
Joined: Wed Jan 02, 2013 9:52 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby zerozero on Mon Feb 11, 2013 6:53 am

this topic is starting to look like the house of horrors;

there's a few issues here:
1- nobody that posted issues in this topic provided a bit of information about the graphic card (a simple inxi -Gx would be enough);

2- is still to be probed that for most of you there's a real added value installing the drivers directly from nvidia instead of using the ones that mint provides in softwares sources;

3- still about the point above: mint (same as ubuntu) makes it very easy to install nvidia and ati drivers; for most users and most user-cases those drivers are most than enough and give a solid performance; the method described here requires some expertise and unless you are having problems with the official drivers there's no need to try this

4- an addenda to point 1): some hardware setups are not as well supported (sli, nvidia+intel dual gpu) and for tose the standard driver installation probably will fail (will for sure in the nvidia+intel dual gpu) but there's ways around that;

so:
before engaging in something that you are not sure, ask the forum; provide the info about the release you are using and the graphics card you have;

life can be so easy
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby captaindallas on Mon Feb 11, 2013 8:27 am

Otyugh wrote:I'm disturbed guys... Have you tried the EASY WAY first ? I feel not. But you are keeping ignoring me, and that is insulting :evil:

If I'm wrong, just say it. If I'm not, your problem is as hard to solve than two clicks. And you will feel so dumb about it for weeks, because it's so easy. So. Anyone having "omagad omagad" issue have tried to install the proprietary driver by the "Software Source" module ?


Of course I have tried that. The drivers do not show in the software source proprietary drivers tab. And installing nvidia-current from the package gui does not work either. Oh and I have a very widely used geforce card so the problem is not with the hardware. The problem lies with mint and the way the nouveau driver is almost impossible to remove or get mint to not use.

There are threads upon threads about this issue so it is a problem affecting a wide variety of hardware setups which all have the simple thing in common that they want to get a nvidia driver installed. It works fine in ubuntu, why can't it in mint?

"Life can be so easy?" What is easy? Spending an entire day wrestling with the problem, reading forum posts, being fairly new to linux. No, that is not easy. The easy thing is going back to windows where everything just works. If people who are reasonably tech savy just can't be bothered with a stubborn problem like this, which is so simple on other platforms, how is the averge joe ever going to give up their mac or the windows-system for a linux distro. The answer is that it is not going to happen.
Last edited by captaindallas on Mon Feb 11, 2013 8:31 am, edited 1 time in total.
captaindallas
Level 1
Level 1
 
Posts: 3
Joined: Sun Feb 10, 2013 3:32 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby zerozero on Mon Feb 11, 2013 8:31 am

captaindallas
what is the output of
Code: Select all
inxi -SGx
without the minimum info is impossible to access the problem
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby captaindallas on Mon Feb 11, 2013 8:33 am

zerozero wrote:captaindallas
what is the output of
Code: Select all
inxi -SGx
without the minimum info is impossible to access the problem


I've removed mint from my PC of course. I'm not spending more time with this idiotic problem. Gonna check back in a few releases when this mess is sorted.
captaindallas
Level 1
Level 1
 
Posts: 3
Joined: Sun Feb 10, 2013 3:32 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby zerozero on Mon Feb 11, 2013 8:35 am

so please don't spam the board with nonexistent problems.
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby vayth on Wed Feb 13, 2013 11:58 pm

I read the thread, but still not sure about the installation, so I'll ask first before try it.. I guess ask won't hurt..

I have dual gpu (acer v5-471g). I don't know how to check nvidia version, since Details and inxi -Gx only show intel as my graphic.
Code: Select all
Graphics:
Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
bus id: 00:02.0
Xorg: 1.13.0
drivers: intel (unloaded: fbdev, vesa)
Resolution 1366x768@60.0hz
GLX Rendered: Mesa DRI Intel Sandybridge Mobile
GLX Version: 3.0 Mesa 9.0
Direct Rendering: Yes


After browsing for a while, I found that this product is supposed to have GT 620M.

some hardware setups are not as well supported (sli, nvidia+intel dual gpu) and for tose the standard driver installation probably will fail (will for sure in the nvidia+intel dual gpu) but there's ways around that;

that 'will fail for sure', is that referring to the installation tutorial in page 1? so how do I install it?
and once I installed it, will I be able to switch between intel and nvidia driver, or set some program to run with nvidia like in Windows? Because for notebook, I heard that Linux isn't too battery-friendly compared to Windows, especially with proprietary driver.

thx before
vayth
Level 1
Level 1
 
Posts: 37
Joined: Tue Feb 14, 2012 7:09 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby Steamix on Thu Feb 14, 2013 4:17 am

I searched the forum for a solution to the problem of proprietary nvidia drivers either 310.32 or 313.18 and kernels 3.7.6 & 3.7.7 and there were no clear cut instructions or explanations. I don't feel like creating another thread just for the sake of leaving the forum a little less cluttered. Going green, lol!

With the last two stable kernel versions from the 3.7.x branch there is an error with the DKMS module when installing the proprietary drivers. The problem lies in the installer getting confused of the kernel version on which it is installed. Mistaking a 3.7 for a 2.6. I do not understand why this happens with version 3.7.6 and not 3.7.5 maybe someone can explain.

Ok, enough chit-chat. You need to create a symlink. I run Mint 14 Cinnamon 64-bit kernel version 3.7.5 and upgrading to kernel 3.7.7 so if you're in the same shoes as me, copy & paste this:

Code: Select all
sudo ln -s /usr/src/linux-headers-3.7.5-030705-generic/include/generated/uapi/linux/version.h /usr/src/linux-headers-3.7.7-030707-generic/include/linux/version.h


The worst that can happen is you'll get a "no such directory" message

Next, you'll have to reboot your system into the new kernel and perform a reinstall of the driver. You can grab the latest ones here http://www.nvidia.ca/object/unix.html

My thanks go to the guys from here http://ubuntuforums.org/showthread.php?t=2113280

Cheers and let me know how it went!
Steamix
Level 1
Level 1
 
Posts: 7
Joined: Fri Dec 14, 2012 6:23 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby zerozero on Thu Feb 14, 2013 12:10 pm

@vayth
searching online for your laptop specs i found
:: Graphics adapter
NVIDIA GeForce GT 620M - 1024 MB, Core: 630 MHz, Memory: 900 MHz, ForceWare 305.46, Optimus

what is strange is that your nvidia card is not being recognized by inxi. do you have any settings in the bios to disable it?

anyway 2 ideas:
1- you have direct rendering at the moment (provided by the intel gpu); of course it's not the best performance-wise but unless you do intensive gaming should be enough;
2- if you want to use the nvidia card (assuming that it is disabled in the bios right now) you'll have to use bumblebee https://wiki.ubuntu.com/Bumblebee
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby vayth on Fri Feb 15, 2013 5:11 am

the only graphic related in bios setting is already switched to 'switchable', with the other option being 'integrated' (which I believe is about intel)

I've tried bumblebee, and it works :D
nvidia is now detected, and I don't have to use nvidia all the time.
although the performance is still inferior to the same program I tried in Windows, but I guess that's different topic (openGL vs DirectX maybe)..

Thanks a lot :D
vayth
Level 1
Level 1
 
Posts: 37
Joined: Tue Feb 14, 2012 7:09 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby zbyna on Sat Feb 16, 2013 6:39 pm

captaindallas wrote:
zerozero wrote:captaindallas
what is the output of
Code: Select all
inxi -SGx
without the minimum info is impossible to access the problem


I've removed mint from my PC of course. I'm not spending more time with this idiotic problem. Gonna check back in a few releases when this mess is sorted.


Hold your horses :) , everybody was green beginner. I feel like beginner everytime I encounter new thing :lol: .
Linux needs a lot of patience and beginning from simple things. Yes of course and time, a lot of time. Installing drivers from Nvidia site and blacklisting free driver is not piece of cake I had problems too and this tutorial helped:
http://community.linuxmint.com/tutorial/view/176
zbyna
Level 1
Level 1
 
Posts: 3
Joined: Sat Feb 16, 2013 1:25 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby skywolfblue on Tue Feb 19, 2013 1:33 am

Otyugh wrote:What about just use the packets that is already done for your card ?


What packets? The drivers listed under Additional Drivers?

I already explained why they don't work in: viewtopic.php?f=59&t=124653
Short version, system says it's "Active But not in use".

(after some reading around on the ubuntu forms it seems it may have to do with a program called "Jockey", which I believe is the "Additional Drivers" program for mint. Apparently it's screwed all to high hell. And so is the default Ubuntu "additional drivers". But running all the software updates on Ubuntu fixed the problem, and now drivers under Ubuntu work fine. I think the software update makes ubuntu use a new "additional drivers" program (or something).) I'm not fully clear as to the "why" but Ubuntu works and Mint doesn't.

I gave up and tried Ubuntu instead. I like Mint's UI better, but until the drivers work properly it's not much good to me.

(that may have come across as harsh-toned but I didn't mean it to be, i'm just a little exasperated.)

zbyna wrote:
captaindallas wrote:
zerozero wrote:captaindallas
what is the output of
Code: Select all
inxi -SGx
without the minimum info is impossible to access the problem


I've removed mint from my PC of course. I'm not spending more time with this idiotic problem. Gonna check back in a few releases when this mess is sorted.


Hold your horses :) , everybody was green beginner. I feel like beginner everytime I encounter new thing :lol: .
Linux needs a lot of patience and beginning from simple things. Yes of course and time, a lot of time. Installing drivers from Nvidia site and blacklisting free driver is not piece of cake I had problems too and this tutorial helped:
http://community.linuxmint.com/tutorial/view/176


Isn't it like a really really bad idea for new people to be messing with the GRUB though? At least that is what I was reading. Things like "making your computer unbootable" are scary warnings to me.
Image
User avatar
skywolfblue
Level 2
Level 2
 
Posts: 78
Joined: Sun Feb 03, 2013 6:59 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby abstra34 on Thu Feb 28, 2013 6:53 am

The Last Hurdle
Glad to have at last found a serious column on this problem of Nvidia proprietary drivers under Linux. The right proprietary driver for my recognized video card is installed and activated in Mint under “Additional Drivers”. Yet there remains one problem, that of a scintillating screen. Certainly, I have written these lines without being much bothered by a certain flickering in the top left part of the CRT screen. However, it is known that prolonged reading from a 60 Herz screen can cause a headache. The refreshment on a CRT (as still used by graphic artists) ought to be 75 Hz or more. With Windows running the same set of hardware, I can choose a rate of 85 Hz.

If you type “xrandr -q” in a Terminal window, it will show you how your graphics card is treated by Mint. For a resolution of 1024 x 768 (just fine) the Terminal replied with a rate of only 50!
True, suggestions have been made in diverse Mint and Ubuntu forums, but I have yet to find a solution where one can successfully add a higher refresh rate to the displays interface in the “System Settings”. Such a shame, it seems to be the last hurdle. The response to the command $ xrandr in the Terminal was:

“xrandr: failed to get size of gamma for output default
Screen 0: minimum 320 x 220, current 1024 x 768, maximum 1024 x 768
Default connected 1024x768+0+0 0mm x 00mm
1024 x 768 50.0*”
etc., etc………..

For the Mint installation (12 +14), I used a slightly-dated office PC to avoid demanding too much from current system configuration:
Motherboard Asus M2N-E SLI, socket AM2, Athlon 64 X2, PCI Express 16X with Nvidia GeForce 210 card.
CRT Monitors: iiyama Vision Master 1404 or Hyundai Q770.
abstra34
Level 1
Level 1
 
Posts: 1
Joined: Sun Feb 24, 2013 3:47 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby tossman101 on Sat Mar 02, 2013 3:34 pm

So I followed the steps laid out by McLovin plus the two additional commands provided by Enkidu. After the final reboot and Mint loading I was greeted with a desktop with no panel and no border around the windows with the maximize, minimize and close icons. As well as the ability to re-size them and if I have two windows open, no way to bring the window in the back to the front. I'm sure it's an easy fix, I'm just unsure of what the cause was so I don't know what I need to change to fix it. Anyone have a similar problem or any ideas of what did this and what the fix is?
tossman101
Level 1
Level 1
 
Posts: 5
Joined: Wed Feb 27, 2013 2:04 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby McLovin on Sat Mar 02, 2013 5:30 pm

tossman101 wrote:So I followed the steps laid out by McLovin plus the two additional commands provided by Enkidu. After the final reboot and Mint loading I was greeted with a desktop with no panel and no border around the windows with the maximize, minimize and close icons. As well as the ability to re-size them and if I have two windows open, no way to bring the window in the back to the front. I'm sure it's an easy fix, I'm just unsure of what the cause was so I don't know what I need to change to fix it. Anyone have a similar problem or any ideas of what did this and what the fix is?

What desktop are you running? If you are running either MATE or XFCE and have Compiz running, just open CompizconfigSettingsManager, and put check marks next to window decorations, move windows, and resize windows, that will give you back your basic functionality. If you are running Cinnamon, I'm really not sure what to tell you, as I don't use Cinnamon, and really don't know too much about it
User avatar
McLovin
Level 5
Level 5
 
Posts: 788
Joined: Thu Aug 23, 2007 6:53 pm

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: No registered users and 7 guests