¿ Porque no funciona este script ?

Spanish Forum

Moderator: vrkalak

¿ Porque no funciona este script ?

Postby hatteras on Sun Mar 03, 2013 10:36 am

No se por que el script screencapturesound.sh graba un archivo de vídeo en formato .mkv , del escritorio, pero sin sonido , que si que debería grabarlo, de hecho antes me grababa el vídeo con el sonido.

El contenido del script es:

#!/bin/bash
if [ ! -e $HOME/Videos ]
then
mkdir -p $HOME/Videos
fi
dir="$HOME/Videos"
size=$( xdpyinfo | grep 'dimensions:' | awk '{print $2}' )
name=$( date +'%b.%d_%I:%M%#p' )
video="$dir/$name.mkv"
ffmpeg -f alsa -ac 2 -i pulse -f x11grab -s $size -r 30 -qscale 1 -i :0.0 $video
User avatar
hatteras
Level 6
Level 6
 
Posts: 1149
Joined: Fri Sep 24, 2010 6:43 pm

Linux Mint is funded by ads and donations.
 

Re: ¿ Porque no funciona este script ?

Postby nestoriano on Sun Mar 03, 2013 3:14 pm

Prueba si ffmpeg esta tomando la tarjeta de audio correctamente con algo mas simple como
ffmpeg -f alsa -i hw:0,0 audio.wav
en caso de que funcione, grabar audio y video con
ffmpeg -f alsa -i hw:0,0 -f x11grab -s hd720 -i :0.0 video.avi

Tambien podrias usar una tarjeta de audio virtual con http://crysol.org/es/node/1063
No lo he probado todavia.
nestoriano
Level 4
Level 4
 
Posts: 333
Joined: Thu Nov 08, 2012 7:15 pm

Re: ¿ Porque no funciona este script ?

Postby hatteras on Sun Mar 03, 2013 7:56 pm

Con ninguna de las dos lineas de comandos que me has dado se crea un archivo que reproduzca el sonido que se estaba oyendo mientras se ejecutaba el comando.
--------------------------
El script es parte de la extensión de cinnamon: ScreenShot+RecordDesktop la cual me funcionaba en mi Mint13 , pero ha dejado de haberlo, creo que tras desinstalar algún paquete, que no se cual pueda ser (en mi pc tengo otra partición en la que tengo instalado Mint14 cinnamon, y en ésta la extensión me funciona).
Vamos que lo que me gustaria es recuperar la extensión ScreenShot+RecordDesktop en Mint13 cinnamon
User avatar
hatteras
Level 6
Level 6
 
Posts: 1149
Joined: Fri Sep 24, 2010 6:43 pm

Re: ¿ Porque no funciona este script ?

Postby nestoriano on Sun Mar 03, 2013 8:23 pm

Fijate si estan instalado los paquetes:
ffmpeg
pulseaudio
pulseaudio-alsa
alsa-utils
pavucontrol (controlador de volumen de pulseaudio)

No tengo mint a mano, los nombres pueden variar e incluso no existir. Si no funciona prueba grabar audio con este otro comando.
ffmpeg -f alsa -i pulse audio.mp3
Puede pasar que grabe todo bien, algun error o generar un archivo de audio con la duracion correcta pero sin volumen.
Si es el 2do caso, sube el mensaje de error. Si es el 3er caso, ejecuta pavucontrol y revisa la salida de audio.
Este tema me ha dado bastante dolor de cabeza en su momento pero luego de varias horas de intento lo pude solucionar...
nestoriano
Level 4
Level 4
 
Posts: 333
Joined: Thu Nov 08, 2012 7:15 pm

Re: ¿ Porque no funciona este script ?

Postby hatteras on Mon Mar 04, 2013 5:33 am

- ffmpeg: esta instalado
- pulseaudio. esta instalado
- pulseaudio-alsa: no esta instalado, ni aparece en synaptic, tanto en el Mint13 cinnamon en el que tengo el problema, como en un mint14 cinnamon recien instalado.
- alsa-utils. esta instalado
- pavucontrol: esta instalado
User avatar
hatteras
Level 6
Level 6
 
Posts: 1149
Joined: Fri Sep 24, 2010 6:43 pm


Return to Español (Spanish)

Who is online

Users browsing this forum: No registered users and 9 guests