software-sources-gtk error

Forum rules
Before you post please read this

software-sources-gtk error

Postby lindy on Mon Mar 04, 2013 5:25 pm

I had the bright idea of adding the Wine ppa to my list of sources, but when I've tried to open software sources it immediately crashes. So I tried running software-sources-gtk from the cli and I get the following:
Code: Select all
lindy@contraption ~ $ software-properties-gtk

** (software-properties-gtk:2172): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Traceback (most recent call last):
  File "/usr/bin/software-properties-gtk", line 103, in <module>
    app = SoftwarePropertiesGtk(datadir=options.data_dir, options=options, file=file)
  File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 96, in __init__
    SoftwareProperties.__init__(self, options=options, datadir=datadir)
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 104, in __init__
    self.reload_sourceslist()
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 592, in reload_sourceslist
    self.distro.get_sources(self.sourceslist)   
  File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 87, in get_sources
    raise NoDistroTemplateException("Error: could not find a "
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template


I've also tried sudo add-apt-repository ppa:ubuntu-wine/ppa , but I get an identical traceback... Anybody have an idea of what's going on here?
Obscurum per obscurius
-the obscure (explained) by the more obscure.
lindy
Level 1
Level 1
 
Posts: 2
Joined: Fri Feb 08, 2013 12:31 am
Location: 45° 57' 9.43" N 86° 14' 39.55" W

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 2 guests