Cannot disable trackpad on Dell Latitude E6330

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Cannot disable trackpad on Dell Latitude E6330

Postby mychance on Thu Dec 27, 2012 4:27 pm

Hi,

I usually disable the trackpad on laptops when I have a mouse plugged in so that I don't get the cursor jumping every now and then by accidentally hitting the trackpad with my thumb.

The usual fashion to disable the trackpad on my Dell Latitude is to hold on Fn key and press F5. Although I get to see the trackpad icon poping up with a red "x" on it, the trackpad still stays active. The command does work when I boot in Windowd however so it should not be a hardware problem.

I don't see a trackpad setting in the Control Center either.

Any idea ?
Aspire One 150
Quad boot, Linux Mint, Xpud, Moblin and Win XP
User avatar
mychance
Level 3
Level 3
 
Posts: 122
Joined: Mon Nov 24, 2008 8:48 pm

Linux Mint is funded by ads and donations.
 

Re: Cannot disable trackpad on Dell Latitude E6330

Postby igor83 on Fri Dec 28, 2012 1:38 pm

mychance wrote:Hi,

I usually disable the trackpad on laptops when I have a mouse plugged in so that I don't get the cursor jumping every now and then by accidentally hitting the trackpad with my thumb.

The usual fashion to disable the trackpad on my Dell Latitude is to hold on Fn key and press F5. Although I get to see the trackpad icon poping up with a red "x" on it, the trackpad still stays active. The command does work when I boot in Windowd however so it should not be a hardware problem.

I don't see a trackpad setting in the Control Center either.

Any idea ?


Under the principle that a reply is better than no reply, I reply. I'd prefer a permanent fix, unless you sometimes need the trackpad (I don't use the one on my Thinkpad R61, preferring the mouse, never did take a shine to those touchpads). I believe you can disable certain kernel services the GUI won't let you touch by modifying a certain file... I did that once, but I can't remember which file, or whether it worked, or whether recompiling the kernel is necessary. There is a config file however that lists all the kernel services, bluetooth, printing, floppy driver, and a lot of services that one wouldn't find necessary for most systems, but are there for compatibility, and I think you can disable them by removing them from the list or commenting them out, thus conserving system resources, in theory, maybe. But I'm not sure whether the change takes without a recompile. And then there's the question whether you want the change to be made this way, because if your mouse goes on the fritz, then to activate your touchpad you'd have to modify the file and then reboot, a little bit more trouble than just not tapping Fn and F5.
My desktop runs 64-bit Kubuntu 13.04, my htpc runs 64-bit Linux Mint Nadia Xfce, my answering machine runs 64-bit windows 7, and my laptop runs 64-bit Linux Mint Nadia KDE. Each seems suited to its purpose.
Image
User avatar
igor83
Level 4
Level 4
 
Posts: 317
Joined: Wed Aug 08, 2012 8:23 pm

Re: Cannot disable trackpad on Dell Latitude E6330

Postby mychance on Sun Dec 30, 2012 9:40 am

Thanks for your reply. I guess this would be the only solution.
Aspire One 150
Quad boot, Linux Mint, Xpud, Moblin and Win XP
User avatar
mychance
Level 3
Level 3
 
Posts: 122
Joined: Mon Nov 24, 2008 8:48 pm

Re: Cannot disable trackpad on Dell Latitude E6330

Postby igor83 on Sun Dec 30, 2012 3:23 pm

mychance wrote:Thanks for your reply. I guess this would be the only solution.


Also, check your BIOS settings--may be a way to turn off the Touchpad there.
My desktop runs 64-bit Kubuntu 13.04, my htpc runs 64-bit Linux Mint Nadia Xfce, my answering machine runs 64-bit windows 7, and my laptop runs 64-bit Linux Mint Nadia KDE. Each seems suited to its purpose.
Image
User avatar
igor83
Level 4
Level 4
 
Posts: 317
Joined: Wed Aug 08, 2012 8:23 pm

Re: Cannot disable trackpad on Dell Latitude E6330

Postby tdockery97 on Sun Dec 30, 2012 3:31 pm

Have you tried this on the command line?
Code: Select all
synclient TouchpadOff=1

If it works for you, just add it to your startup applications if you don't want to enter it each session.
Image

HP Pavilion 17 Notebook, 8GB DDR3, 2.5GHZ A10-APU, Radeon HD 8650G
Registered Linux User #520972
User avatar
tdockery97
Level 13
Level 13
 
Posts: 4866
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon

Re: Cannot disable trackpad on Dell Latitude E6330

Postby mychance on Tue Jan 01, 2013 1:50 pm

tdockery97 wrote:Have you tried this on the command line?
Code: Select all
synclient TouchpadOff=1



I tried it and got this:

"Couldn't find synaptics properties. No synaptics driver loaded?"
Aspire One 150
Quad boot, Linux Mint, Xpud, Moblin and Win XP
User avatar
mychance
Level 3
Level 3
 
Posts: 122
Joined: Mon Nov 24, 2008 8:48 pm

Re: Cannot disable trackpad on Dell Latitude E6330

Postby mychance on Sun Mar 03, 2013 10:48 am

Just a reminder on that topic. I really would like to find an easy solution for disabling the touchpad on a Dell Lalltitude E6330. The FN + F5 shortcut that works in Windows doesn't work in LinuxMint 14 Main. I do see the pop up on the screen telling me that the touchpad is disabled, but it's not.

Thanks in advance for any hints you can give.
Aspire One 150
Quad boot, Linux Mint, Xpud, Moblin and Win XP
User avatar
mychance
Level 3
Level 3
 
Posts: 122
Joined: Mon Nov 24, 2008 8:48 pm

Re: Cannot disable trackpad on Dell Latitude E6330

Postby igor83 on Tue Mar 05, 2013 2:06 am

mychance wrote:
tdockery97 wrote:Have you tried this on the command line?
Code: Select all
synclient TouchpadOff=1



I tried it and got this:

"Couldn't find synaptics properties. No synaptics driver loaded?"


My guess is you should install synclient, then do as dockery suggested.
My desktop runs 64-bit Kubuntu 13.04, my htpc runs 64-bit Linux Mint Nadia Xfce, my answering machine runs 64-bit windows 7, and my laptop runs 64-bit Linux Mint Nadia KDE. Each seems suited to its purpose.
Image
User avatar
igor83
Level 4
Level 4
 
Posts: 317
Joined: Wed Aug 08, 2012 8:23 pm

Re: Cannot disable trackpad on Dell Latitude E6330

Postby mychance on Wed Mar 06, 2013 6:47 pm

Thanks for answering. Sorry for the noob question. How do you install synclient ? If I search that term in synaptics, it brings me "xserver-xorg-input-synaptics" which is alreday installed.
Aspire One 150
Quad boot, Linux Mint, Xpud, Moblin and Win XP
User avatar
mychance
Level 3
Level 3
 
Posts: 122
Joined: Mon Nov 24, 2008 8:48 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 14 guests