Brightness control not working Mint 14 Sony Vaio Intel Video

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

Brightness control not working Mint 14 Sony Vaio Intel Video

Postby whiterabbitwonder on Wed Mar 06, 2013 3:48 pm

Hi there, I would very much appreciate some help with this vexing little issue. Thank you for any insights anyone has.

This is a fresh install of Mint 14 64 bit on a Sony Vaio laptop VPC-Y115FX.

The only thing not working is the brightness of the screen. It is stuck at 100%

The Fn keys pop up the indicator showing the brightness adjusting, however the brightness does not actually change. Likewise with the "Brightness and lock" dimmer. It moves but nothing changes.

I have tried the other solutions involving:
1. i915.modeset=0 after quiet splash in grub [kills xserver, does not work]
2. xserver-xorg-video-intel is already installed
3. GRUB_CMDLINE_LINUX="acpi_backlight=vendor" (disabled the "brightness and lock" slider and my Fn keys, but did nothing to adjust brightness)
4. xbacklight did nothing at all
5. GRUB_CMDLINE_LINUX="acpi=force" [does nothing]
6. tried installing the xserver-xorg-video-intel driver from https://launchpad.net/~glasen/+archive/ ... er=quantal
[result is no different]

I have not yet tried adding this to xorg.conf as I'm trying to figure out how to do that since it appears to not exist...:
Option "RegistryDwords" "EnableBrightnessControl=1"

Here is the output of inxi -Fxz
Graphics: Card: Intel Mobile 4 Series Chipset Integrated Graphics Controller bus-ID: 00:02.0
X.Org: 1.13.0 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz
GLX Renderer: Mesa DRI Mobile Intel GM45 Express Chipset GLX Version: 2.1 Mesa 9.0.2 Direct Rendering: Yes

System: Kernel: 3.5.0-17-generic x86_64 (64 bit, gcc: 4.7.2)
Desktop: Gnome Distro: Linux Mint 14 Nadia
Machine: System: Sony product: VPCY115FXI version: C9000NF4
Mobo: Sony model: VAIO Bios: INSYDE version: R0230H1 date: 05/13/2010
CPU: Dual core Intel CPU U7300 (-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 5187.44
Runlevel: 2 Gcc sys: 4.7.2 Client: Shell inxi: 1.8.4

The lspci output is:
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
whiterabbitwonder
Level 1
Level 1
 
Posts: 4
Joined: Wed Mar 06, 2013 3:09 pm

Linux Mint is funded by ads and donations.
 

Re: Brightness control not working Mint 14 Sony Vaio Intel V

Postby whiterabbitwonder on Fri Mar 08, 2013 8:03 am

bump?
whiterabbitwonder
Level 1
Level 1
 
Posts: 4
Joined: Wed Mar 06, 2013 3:09 pm

Re: Brightness control not working Mint 14 Sony Vaio Intel V

Postby AlbertP on Fri Mar 08, 2013 9:55 am

That xorg.conf option you mentioned is specific to the NVIDIA graphics driver, and you have Intel graphics. In fact backlight should just work.

Could you run this command and post the output:
Code: Select all
dmesg | grep sony-laptop
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Brightness control not working Mint 14 Sony Vaio Intel V

Postby whiterabbitwonder on Sat Mar 09, 2013 7:52 pm

Hi Albert, thank you for your reply. I entered that command and there was no output to screen.
On a hunch i removed the last part and below is the output from searching just for sony.
Turns out it was underscore instead of hyphen...

dmesg|grep sony
[ 2.249548] sony_laptop: Sony Notebook Control Driver v0.6
[ 2.360338] sony_laptop: brightness ignored, must be controlled by ACPI video driver
[ 608.290346] sony_laptop: Failed to evaluate [SN07]
[ 608.292707] sony_laptop: Failed to evaluate [SN05]
[ 608.292836] sony_laptop: Failed to evaluate [SN07]
[ 608.293392] sony_laptop: Failed to evaluate [SN05]
[ 608.323703] sony_laptop: Failed to evaluate [SN07]
[ 608.324366] sony_laptop: Failed to evaluate [SN05]
[ 608.438018] sony_laptop: Failed to evaluate [SN07]
[ 608.438585] sony_laptop: Failed to evaluate [SN05]
[ 608.735611] sony_laptop: Failed to evaluate [SN07]
[ 608.736231] sony_laptop: Failed to evaluate [SN05]
[ 608.814874] sony_laptop: Failed to evaluate [SN07]
[ 608.815436] sony_laptop: Failed to evaluate [SN05]
[ 608.919914] sony_laptop: Failed to evaluate [SN07]
[ 608.920518] sony_laptop: Failed to evaluate [SN05]
[ 608.996334] sony_laptop: Failed to evaluate [SN07]
[ 608.996901] sony_laptop: Failed to evaluate [SN05]
[ 609.105041] sony_laptop: Failed to evaluate [SN07]
[ 609.105386] sony_laptop: Failed to evaluate [SN05]
[ 609.186483] sony_laptop: Failed to evaluate [SN07]
[ 609.186828] sony_laptop: Failed to evaluate [SN05]
[ 609.292403] sony_laptop: Failed to evaluate [SN07]
[ 609.292963] sony_laptop: Failed to evaluate [SN05]
[ 609.377982] sony_laptop: Failed to evaluate [SN07]
[ 609.378547] sony_laptop: Failed to evaluate [SN05]
[ 609.487108] sony_laptop: Failed to evaluate [SN07]
[ 609.487672] sony_laptop: Failed to evaluate [SN05]
[ 609.567228] sony_laptop: Failed to evaluate [SN07]
[ 609.567821] sony_laptop: Failed to evaluate [SN05]
[ 609.665041] sony_laptop: Failed to evaluate [SN07]
[ 609.665606] sony_laptop: Failed to evaluate [SN05]
[ 609.741037] sony_laptop: Failed to evaluate [SN07]
[ 609.741630] sony_laptop: Failed to evaluate [SN05]
[ 609.836221] sony_laptop: Failed to evaluate [SN07]
[ 609.836780] sony_laptop: Failed to evaluate [SN05]
[ 609.946708] sony_laptop: Failed to evaluate [SN07]
[ 609.947269] sony_laptop: Failed to evaluate [SN05]
whiterabbitwonder
Level 1
Level 1
 
Posts: 4
Joined: Wed Mar 06, 2013 3:09 pm

Re: Brightness control not working Mint 14 Sony Vaio Intel V

Postby AlbertP on Sun Mar 10, 2013 10:16 am

Ok, that brightness issue (at the top of the output) seems common on Sony computers. Maybe the sony_laptop driver will be fixed in future; I don't know anything else you could do.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

<partial SOLVED> Brightness not work Mint14 SonyVaio Intel V

Postby whiterabbitwonder on Sun Mar 10, 2013 6:11 pm

Hi Albert! I think I may have found something!
When I muck about with changing the value in the file
/sys/class/backlight/intel_backlight/brightness
from 1992060 to say 199206 (approx 10% of original value) as soon as i save the file my brightness decreases!
Phew, my eyes have stopped bleeding.
I wonder then, since the Fn keys and "brightness and lock" slider are modifying the values in
/sys/class/backlight/acpi_video0/brightness
and
/sys/class/backlight/acpi_video1/brightness

Is there anyway to have the Fn keys and slider modify the correct file instead?

I found this post with the same issue: http://forums.debian.net/viewtopic.php?f=5&t=78471
and this script which helps, but ideally I'd love to just have the Fn keys mapping to the correct file.
http://superlinux.zxq.net/downloads/xrandr.tar.gz

Thank you for any insight!

David
whiterabbitwonder
Level 1
Level 1
 
Posts: 4
Joined: Wed Mar 06, 2013 3:09 pm

Re: Brightness control not working Mint 14 Sony Vaio Intel V

Postby AlbertP on Mon Mar 11, 2013 5:56 am

You can try adding this boot argument to the next-to-last line in Grub when editing Mint using the E key: acpi_backlight=vendor
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Linux Mint is funded by ads and donations.
 

Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: No registered users and 3 guests