HOW TO : Install Grub Customizer (Grub2 Editor Gui) in LMDE

Write tutorials and howtos in here
More tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please, Before you post please read this

Re: HOW TO : Install Grub Customizer (Grub2 Editor Gui) in L

Postby KilUma on Sun Mar 10, 2013 5:05 pm

I've tried both ways, following zero's instructions for compiling. Neither work. I'm certain it has something to do with sources, but I can't figure out what.

The following is the output for:
Code: Select all
inxi -r

Repos: Active apt sources in file: /etc/apt/sources.list.d/danielrichter2007-grub-customizer-quantal.list
deb http://ppa.launchpad.net/danielrichter2 ... zer/ubuntu quantal main
deb-src http://ppa.launchpad.net/danielrichter2 ... zer/ubuntu quantal main
Active apt sources in file: /etc/apt/sources.list.d/ingalex-super-boot-manager-quantal.list
deb http://ppa.launchpad.net/ingalex/super- ... ger/ubuntu quantal main
deb-src http://ppa.launchpad.net/ingalex/super- ... ger/ubuntu quantal main
Active apt sources in file: /etc/apt/sources.list.d/local-repository.list
deb file:///usr/share/local-repository binary/
Active apt sources in file: /etc/apt/sources.list.d/medibuntu.list
deb-src http://packages.medibuntu.org/ quantal free non-free
Active apt sources in file: /etc/apt/sources.list.d/mint.list
deb http://packages.linuxmint.com/ nadia main upstream import backport
Active apt sources in file: /etc/apt/sources.list.d/ubuntu.list
deb-src http://archive.ubuntu.com/ubuntu/ quantal main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ quantal-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ quantal-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ quantal-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu/ quantal-security main restricted universe multiverse
deb-src http://archive.canonical.com/ubuntu/ quantal partner


Not sure if this is helpful, but the following is my output for(abbreviated):
Code: Select all
apt install cmake g++ libgtkmm-2.4-dev gettext libssl-dev

Package cmake is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'cmake' has no installation candidate
E: Unable to locate package libgtkmm-2.4-dev
E: Couldn't find any package by regex 'libgtkmm-2.4-dev'
Inspiron n5110; 4 X Intel Core i5-2450 2.5ghz; 8G ddr3; Intel Sandybridge Mobile; Intel 2nd gen integrated graphics controller; Dual-boot Mint14KDE; Win7.

Image
KilUma
Level 2
Level 2
 
Posts: 63
Joined: Sat Feb 12, 2011 9:08 pm

Linux Mint is funded by ads and donations.
 

Re: HOW TO : Install Grub Customizer (Grub2 Editor Gui) in L

Postby zerozero on Sun Mar 10, 2013 5:15 pm

KilUma
if you are using nadia and have the ppa (as i see you do) you don't need to compile it
try
Code: Select all
apt install grub-customizer
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: HOW TO : Install Grub Customizer (Grub2 Editor Gui) in L

Postby KilUma on Sun Mar 10, 2013 5:25 pm

This is the output of that command(note: the broken package is grub-customizer, itself):

Code: Select all
kiluma@kiluma ~ $ sudo apt install grub-customizer
[sudo] password for kiluma:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 grub-customizer : Depends: libatkmm-1.6-1 (>= 2.22.1) but it is not installable
                   Depends: libcairomm-1.0-1 (>= 1.6.4) but it is not installable
                   Depends: libglibmm-2.4-1c2a (>= 2.33.13) but it is not installable
                   Depends: libgtkmm-2.4-1c2a (>= 1:2.24.0) but it is not installable
                   Depends: libpangomm-1.4-1 (>= 2.27.1) but it is not installable
                   Recommends: hwinfo but it is not installable
E: Unable to correct problems, you have held broken packages.
Inspiron n5110; 4 X Intel Core i5-2450 2.5ghz; 8G ddr3; Intel Sandybridge Mobile; Intel 2nd gen integrated graphics controller; Dual-boot Mint14KDE; Win7.

Image
KilUma
Level 2
Level 2
 
Posts: 63
Joined: Sat Feb 12, 2011 9:08 pm

Re: HOW TO : Install Grub Customizer (Grub2 Editor Gui) in L

Postby zerozero on Sun Mar 10, 2013 5:31 pm

sure, you're missing the main ubuntu repo
Code: Select all
deb http://archive.ubuntu.com/ubuntu/ quantal main restricted universe multiverse

you have the source-code repo but not the "regular" one
add it, update and upgrade and try again
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: HOW TO : Install Grub Customizer (Grub2 Editor Gui) in L

Postby KilUma on Sun Mar 10, 2013 5:56 pm

It's usually something simple. Thanks for tolerating my oversight. It works, all is fine. :roll:
Inspiron n5110; 4 X Intel Core i5-2450 2.5ghz; 8G ddr3; Intel Sandybridge Mobile; Intel 2nd gen integrated graphics controller; Dual-boot Mint14KDE; Win7.

Image
KilUma
Level 2
Level 2
 
Posts: 63
Joined: Sat Feb 12, 2011 9:08 pm

Re: HOW TO : Install Grub Customizer (Grub2 Editor Gui) in L

Postby zerozero on Sun Mar 10, 2013 5:57 pm

glad you got it sorted :D
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: HOW TO : Install Grub Customizer (Grub2 Editor Gui) in L

Postby KilUma on Tue Mar 12, 2013 6:55 pm

So, I prefer BURG over GRUB. But I'm have an issue getting it installed using either Grub Customizer, or Super Boot Manager. So here is what I have tried, and my results:

When I open Grub Customizer, it finds BURG. I click 'yes' to configure BURG, and then get the following error message:
burg-mkconfig couldn't be executed successfully. error message:
Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.


I choose the "Environment" option, and confirm everything is correct. It is. After confirming the failure, I exit out and look up the info provided in the error message.

As a result of that, I input the following in the term:
Code: Select all
sudo /usr/sbin/burg-probe --device /dev/sda

I get this as the output:
Code: Select all
/usr/sbin/burg-probe: error: unknown filesystem.


This leads me to specify a partition. This is my input:
Code: Select all
sudo /usr/sbin/burg-probe --device /dev/sda5

This is the output:
Code: Select all
ext2

Which is weird, because it's an ext4 fs. Either way, it doesn't solve the problem.
Inspiron n5110; 4 X Intel Core i5-2450 2.5ghz; 8G ddr3; Intel Sandybridge Mobile; Intel 2nd gen integrated graphics controller; Dual-boot Mint14KDE; Win7.

Image
KilUma
Level 2
Level 2
 
Posts: 63
Joined: Sat Feb 12, 2011 9:08 pm

Re: HOW TO : Install Grub Customizer (Grub2 Editor Gui) in L

Postby massexy on Fri May 24, 2013 9:57 am

I just successfully installed Grub Customizer in LMDE UP6 following the instructions here but with the latest .deb I could find on this page:

https://launchpad.net/grub-customizer/+download

There is a 3.0.4 release but only tar.gz files so you would need to follow the instructions to build it.
My netbook has a 32bit processor so I used that .deb file.

1. I downloaded the file:
Code: Select all
wget -c https://launchpad.net/grub-customizer/3.0/2.99/+download/grub-customizer_2.99-0ubuntu1%7Eppa1p_i386.deb


I guess this one should work on 64bit PCs:
Code: Select all
wget -c https://launchpad.net/grub-customizer/3.0/2.99/+download/grub-customizer_2.99-0ubuntu1%7Eppa1p_amd64.deb


2. And then installed it:
Code: Select all
sudo dpkg -i grub-customizer*
massexy
Level 1
Level 1
 
Posts: 6
Joined: Fri Jun 22, 2012 7:05 am

Re: HOW TO : Install Grub Customizer (Grub2 Editor Gui) in L

Postby excollier on Sun May 26, 2013 10:04 am

Didn't work at all for me. :(
It's there in the main menu, (after a reboot) but it doesn't respond at all.
Registered Linux user #557695
CompTIA A+
CompTIA Network+
KWheezy , Debian Wheezy 7.6 XFCE (headless on an old P4 desktop), SolydX BE, Raspberry Pi
excollier
Level 4
Level 4
 
Posts: 310
Joined: Mon Oct 01, 2012 3:31 pm
Location: Way off centre.

Re: HOW TO : Install Grub Customizer (Grub2 Editor Gui) in L

Postby tux-sven on Sat Jun 01, 2013 8:21 am

Thank you massexy,

So easy and working so well! :D
I installed it in a friends LMDE to get a Windows restoring entry away (i didn't delete this partition for eventually coming needs)

Now it's no risk somebody hits the start-entry of this dangerous row. (I think it would destroy the whole Linux installation)

Thanks again!! :mrgreen: :mrgreen:
User avatar
tux-sven
Level 3
Level 3
 
Posts: 111
Joined: Sun Mar 08, 2009 6:44 am
Location: Sweden (@ Kinnekulle)

Linux Mint is funded by ads and donations.
 
Previous

Return to Tutorials / Howtos

Who is online

Users browsing this forum: Exabot [Bot] and 2 guests