No HDMI sound -ATI Radeon 4570 [RESOLVED]

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

No HDMI sound -ATI Radeon 4570 [RESOLVED]

Postby TheKernel on Thu Feb 07, 2013 12:40 am

I am a real newbie who has downloaded LM Nadia to my Acer Aspire 5536G notebook. Most initial problems I have managed to resolve but I have not been able to get any HDMI sound when I connect the laptop to my TV via an HDMI cable (under Windows it was AOK) .

I note from the Nadia release docs that my HDMI hardware (ATI Radeo HD4570) is no longer supported by ATI and an option exists to use the open source driver that comes with Mint. I have presumed this was the case and after trawling the forum and the web I ran two recommended commands in terminal that gave me the following screenshot:
[rimg]Image
sound devices by Fernebergia, on Flickr [/rimg]

... which seems to tell me that the correct 'snd_hda_intel' driver is loaded for HDMI output. But if that is the case why no sound? ... I did specifically select the HDMI Audio on the output tab under 'sound preferences'.

I have searched across the forums for info/solution but as a 'Linux neophyte', I am now quite confused as to what to do. Any assistance would be appreciated. Thankyou.

Update as at 21/02/13 ... I have searched further across Ubuntu/Linux forums and tried several suggestions for similar reported problems, including "unmuting everything via alsa mixer". There was another suggestion, which I attempted, to reconfigure using "alsaconf" but that program seems to be missing/obsolete now - so if there are any suggestions to help this struggling newbie they would be appreciated. Thanks.


Further update as at 10/03/13 - thanks 'anandrkris' for your support; please see my separate response below as I am embarrassed to say I need further assistancehttp.

Final Update as at 12/03/13 - thank you very much 'anandrkris' and 'cymbaline' ... I followed your advice and now have HDMI sound and have learnt a fair bit along the way also. Thanks again
Last edited by TheKernel on Tue Mar 12, 2013 12:08 am, edited 3 times in total.
With age comes knowledge
User avatar
TheKernel
Level 1
Level 1
 
Posts: 22
Joined: Thu Jan 24, 2013 6:40 pm
Location: Sydney

Linux Mint is funded by ads and donations.
 

Re: No HDMI sound -ATI Radeon 4570

Postby Chraz Ritt on Thu Feb 07, 2013 10:41 pm

I read on the AMD website that the proprietary drivers for many of their sound and video hardware will not be updated to run under the newer kernel used by mint 14, but they are still supporting the drivers that run under the kernel that is used in mint 13, so if all other options fail you could consider going to it. With that said, please try the info below, it works for me.

Have you tried looking for the sound device control interface? On 13 it can be easily found by clicking menu, then pointing to system tools, followed by clicking system settings, where I can then find an icon for sound, this is likely the same for 14. Once there I find the following interface:

Image

Notice the on/off toggle, make sure it's on, and that the HDMI device is highlighted. Connector needs to be set to "HDMI/DisplayPort".

In the Hardware tab your version of HDMI Audio should be highlighted.

Also the "Profile" at the bottom of the window should be set to something saying HDMI, and not to off.

I find the other 3 tabs unimportant to running sound out through my TV speakers.

I'm not saying that this will cure your problem, but it is a place to look.
Chraz Ritt
Level 1
Level 1
 
Posts: 7
Joined: Wed May 23, 2012 8:46 pm

Re: No HDMI sound -ATI Radeon 4570

Postby TheKernel on Mon Feb 11, 2013 11:39 pm

Thank you Chraz Ritt but it seems the 'sound preferences' window in LM 14 has beeen slightly reconfigured. The output tab now features a 'mute' checkbox for the highlighted device and not an 'on/off' switch and I have just had a look to ensure that the HDMI device is not set to mute. There is also a'profile' settings box for the devices on the hardware tab and everything there looks OK too.

Hopefully something will pop up but thanks again for your response.
With age comes knowledge
User avatar
TheKernel
Level 1
Level 1
 
Posts: 22
Joined: Thu Jan 24, 2013 6:40 pm
Location: Sydney

Re: No HDMI sound -ATI Radeon 4570

Postby anandrkris on Tue Mar 05, 2013 12:54 am

Did you try the aplay command?

Code: Select all
aplay -l
**** List of PLAYBACK Hardware Devices ****
Code: Select all
aplay -D device_id


Check if this link helps.

Intended Digression - http://community.linuxmint.com/idea/view/3844 - Plese note that I have posted an idea on having a Troubleshotting wizard in Mint for audio related issues. Request you have a look at it and provide your views and if it makes sense - cast your vote on it. Thanks

Am rallying the user forums who have sound issues to get consensus on the idea. Let us join our hands together in building a user-friendly Linux Mint.
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 862
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: No HDMI sound -ATI Radeon 4570

Postby TheKernel on Sat Mar 09, 2013 8:27 pm

Thanks 'anandrkris' for your post but I am having problems still; wow ... using the terminal can be a really steep learning curve for newbies. I tried your first aplay command and got -
[rimg]Image
aplay1 by Fernebergia, on Flickr[/rimg]

I was not sure just what the 'device_id' is but I tried the 'aplay -D' command several times .. but just received error messages
[rimg]Image
aplay3 by Fernebergia, on Flickr[/rimg]

I also listed all devices using 'aplay -L' and those mentioning HDMI were -
[rimg]Image
aplay2 by Fernebergia, on Flickr[/rimg]

So I checked on the web for 'device id' for aplay ... but that did not help me ... a bit embarassing really. Can you or somebody else please assist further. Thanks again.
With age comes knowledge
User avatar
TheKernel
Level 1
Level 1
 
Posts: 22
Joined: Thu Jan 24, 2013 6:40 pm
Location: Sydney

Re: No HDMI sound -ATI Radeon 4570

Postby anandrkris on Sat Mar 09, 2013 10:19 pm

Sincere apologies, I should have given complete instructions but am not an expert :oops: and only remembered vaguely using the command few times.
I think before going the command way, try installing pavucontrol and set the preferences, it might just easily work.
If pavucontrol does not work - try this
I had to search again and the syntax and it is not very intuitive. Check the quote below from ALSA site.
http://alsa.opensrc.org/Aplay
Device name
It would be nice, to have device name explained (i.e. hw:0,0)
It's ALSA-geek-speak for the initial hardware device that will convert digitzed sample to a smooth analog voltage or vice-versa. See below.
It would be even nicer if the --help and man output of aplay would define what NAME of "--device=NAME" should be set to. Then people would not have to search the Internet to find out.

From the screenshots, the below command should work.
Code: Select all
aplay -D hw:0,1 /usr/share/sounds/alsa/Front_Center.wav

First digit 0 refers to the card ID and second digit refers to the device ID.
I think and easier option is to go to terminal and select the default sound card. (F6)
Code: Select all
alsamixer

Below links are of custom search engines that help in searching linux related topics. I find them to be very useful to solve linux related issues and have them bookmarked..
http://home.windstream.net/joelwest/ - You can filter for 'Mint' to show only results from Mint forums.
http://www.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 862
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: No HDMI sound -ATI Radeon 4570

Postby cymbaline on Mon Mar 11, 2013 8:35 pm

I had this issue when I first installed Linux Mint 14 the other day. I googled and found this answer somewhere online and it worked for me. Hope it helps you. :)


you will need to be root for the following.

you have to edit your grub config. open /etc/default/grub with your preferred text editor and look for GRUB_CMDLINE_LINUX_DEFAULT and add radeon.audio=1 to the end of it.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

becomes

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

now save the file and run update-grub
cymbaline
Level 1
Level 1
 
Posts: 2
Joined: Mon Mar 11, 2013 8:33 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 9 guests