Can't install Wine.

Questions about applications and software
Forum rules
Before you post please read this

Can't install Wine.

Postby Fra on Mon Mar 11, 2013 4:38 pm

Hi guys,

I have Linux mint 14 64 bit and can't install Wine. Can you help me ?

thanks

f
Fra
Level 1
Level 1
 
Posts: 45
Joined: Sun Jan 20, 2013 7:04 am

Linux Mint is funded by ads and donations.
 

Re: Can't install Wine.

Postby karlchen on Mon Mar 11, 2013 7:57 pm

Hello, Fra.

Open a terminal window and execute
Code: Select all
sudo apt-get update
sudo apt-get install wine

This should yield the desired result.
If you experience any problems and/or receive any error messages, be so kind to post back and include any relevant details. (cf. How To Get Help, in particular item [5])

Kind regards,
Karl
Image
Enlightened by Lucid Lynx, enchanted by Maya, impressed by Petra.
User avatar
karlchen
Level 9
Level 9
 
Posts: 2554
Joined: Sat Dec 31, 2011 7:21 am

Re: Can't install Wine.

Postby Fra on Tue Mar 12, 2013 12:11 pm

Thanks karlchen. Can you please tell me how to copy and paste here what the terminal reports ?

f
Fra
Level 1
Level 1
 
Posts: 45
Joined: Sun Jan 20, 2013 7:04 am

Re: Can't install Wine.

Postby karlchen on Tue Mar 12, 2013 12:37 pm

Hello, Fra.

Inside the terminal window mark the text which you want to copy with your mouse. Next select Edit => Copy from the terminal window menu or press <Ctrl>C - like you would do in Windows.
Next switch to your post here and click the [Code] button inside the post editor. Finally paste the text inside your clipboard into the editor between the starting and ending code tags.
That's it.

Kind regards,
Karl
Image
Enlightened by Lucid Lynx, enchanted by Maya, impressed by Petra.
User avatar
karlchen
Level 9
Level 9
 
Posts: 2554
Joined: Sat Dec 31, 2011 7:21 am

Re: Can't install Wine.

Postby Fra on Wed Mar 13, 2013 4:36 am

Hello karlchen,

Thanks for your guidance. This is the report of the terminal:


Code: Select all
francesco@francesco-Vostro-3460 ~ $ sudo apt-get install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  binfmt-support fonts-horai-umefont fonts-unfonts-core gnome-exe-thumbnailer
  icoutils imagemagick imagemagick-common libcapi20-3 libgif4:i386 liblqr-1-0
  libmagickcore5 libmagickcore5-extra libmagickwand5 libmpg123-0 libnetpbm10
  libnss-winbind libodbc1 libpam-winbind netpbm ttf-mscorefonts-installer
  ttf-umefont ttf-unfonts-core unixodbc update-notifier-common winbind
  wine-gecko1.4 wine-gecko1.4:i386 wine1.4 wine1.4-amd64 wine1.4-common
  wine1.4-i386:i386 winetricks
Suggested packages:
  libterm-readline-gnu-perl libterm-readline-perl-perl imagemagick-doc
  autotrace curl enscript ffmpeg gnuplot grads hp2xx html2ps libwmf-bin povray
  radiance texlive-base-bin transfig ufraw-batch libmyodbc odbc-postgresql
  tdsodbc unixodbc-bin dosbox
Recommended packages:
  gettext:i386 unixodbc:i386
The following NEW packages will be installed
  binfmt-support fonts-horai-umefont fonts-unfonts-core gnome-exe-thumbnailer
  icoutils imagemagick imagemagick-common libcapi20-3 libgif4:i386 liblqr-1-0
  libmagickcore5 libmagickcore5-extra libmagickwand5 libmpg123-0 libnetpbm10
  libnss-winbind libodbc1 libpam-winbind netpbm ttf-mscorefonts-installer
  ttf-umefont ttf-unfonts-core unixodbc update-notifier-common winbind wine
  wine-gecko1.4 wine-gecko1.4:i386 wine1.4 wine1.4-amd64 wine1.4-common
  wine1.4-i386:i386 winetricks
0 upgraded, 33 newly installed, 0 to remove and 5 not upgraded.
Need to get 20.0 MB/106 MB of archives.
After this operation, 402 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Err http://archive.ubuntu.com/ubuntu/ quantal/main fonts-unfonts-core all 1.0.3.is.1.0.2-080608-5ubuntu2
  Connection failed [IP: 91.189.92.201 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/f/fonts-unfonts-core/fonts-unfonts-core_1.0.3.is.1.0.2-080608-5ubuntu2_all.deb  Connection failed [IP: 91.189.92.201 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
Fra
Level 1
Level 1
 
Posts: 45
Joined: Sun Jan 20, 2013 7:04 am

Re: Can't install Wine.

Postby catweazel on Wed Mar 13, 2013 4:55 am

Run the Software Sources application. On the LinuxMint Software tab, where it sdays, "Download from:", choose 'Other...". When the download server dialog appears, click 'Choose Best Server'.

After that has completed, try to install your desired application again.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: Can't install Wine.

Postby Fra on Wed Mar 13, 2013 2:05 pm

TehGhodTrole wrote:Run the Software Sources application. On the LinuxMint Software tab, where it sdays, "Download from:", choose 'Other...". When the download server dialog appears, click 'Choose Best Server'.

After that has completed, try to install your desired application again.



I tried but unfortunately it didn't work. It just shows the same error message.
Fra
Level 1
Level 1
 
Posts: 45
Joined: Sun Jan 20, 2013 7:04 am

Re: Can't install Wine.

Postby karlchen on Wed Mar 13, 2013 7:22 pm

Hello, Fra.

Changing the server for Linux Mint software from packages.linuxmint.com to a mirror server closer to your geographical location is fine. I have done so, too. Because the internet connection of the main Linux Mint repository server is often overloaded and slow.
Yet, this is pretty unrelated to the error
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/m ... u2_all.deb Connection failed [IP: 91.189.92.201 80]
This is a Ubuntu repository, not a Linux Mint repository. So switching to a differen Mint mirror server will not solve this problem.
Just tried the address http://archive.ubuntu.com/ubuntu/pool/main/f/fonts-unfonts-core/fonts-unfonts-core_1.0.3.is.1.0.2-080608-5ubuntu2_all.deb in my Firefox. And Firefox immediately offered to download the software package.
This seems to be a strong hint that
+ either you experience a temporary problem, and it is fixed by now
+ or your system experiences a general problem finding valid internet addresses.
If you paste the address http://archive.ubuntu.com/ubuntu/pool/main/f/fonts-unfonts-core/fonts-unfonts-core_1.0.3.is.1.0.2-080608-5ubuntu2_all.deb into your Firefox address bar and press enter, what happens?
If you ping the corresponding IP address 91.189.92.201, what happens?

Another thought, maybe a workaround:
Wine wants to install the software package ttf-unfonts-core 1.0.3. This package is only a meta-package which will in turn try to get fonts-unfonts-core 1.0.3. You might try to
Code: Select all
sudo apt-get update
sudo apt-get install ttf-unfonts-core
and hope that this will in fact install those 2 packages.
If this succeeds you might try again to get Wine by running
Code: Select all
sudo apt-get update
sudo apt-get install wine


Yet, another not totally absurd approach would be to do as the error message instructs:
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
This means
Code: Select all
sudo apt-get update
sudo apt-get install --fix-missing wine

Kind regards,
Karl
Image
Enlightened by Lucid Lynx, enchanted by Maya, impressed by Petra.
User avatar
karlchen
Level 9
Level 9
 
Posts: 2554
Joined: Sat Dec 31, 2011 7:21 am

Re: Can't install Wine.

Postby Fra on Thu Mar 14, 2013 3:22 am

Hi Karl,

thanks for your help. I tried to do what you suggested but nothing worked; it really seems that the system can't find the files to download, as you said. The problem is not a temporary one though.


1) If I paste the link, a download will start immediately.


2) As regards the second operation, the following error is reported:

Code: Select all
Err http://archive.ubuntu.com/ubuntu/ quantal/main fonts-unfonts-core all 1.0.3.is.1.0.2-080608-5ubuntu2
  Connection failed [IP: 91.189.92.202 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/f/fonts-unfonts-core/fonts-unfonts-core_1.0.3.is.1.0.2-080608-5ubuntu2_all.deb  Connection failed [IP: 91.189.92.202 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?



3) Instead, this is the result of the third one:

Code: Select all
francesco@francesco-Vostro-3460 ~ $ sudo apt-get install --fix-missing wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  binfmt-support fonts-horai-umefont fonts-unfonts-core gnome-exe-thumbnailer
  icoutils imagemagick imagemagick-common libcapi20-3 libgif4:i386 liblqr-1-0
  libmagickcore5 libmagickcore5-extra libmagickwand5 libmpg123-0 libnetpbm10
  libnss-winbind libodbc1 libpam-winbind netpbm ttf-mscorefonts-installer
  ttf-umefont ttf-unfonts-core unixodbc update-notifier-common winbind
  wine-gecko1.4 wine-gecko1.4:i386 wine1.4 wine1.4-amd64 wine1.4-common
  wine1.4-i386:i386 winetricks
Suggested packages:
  libterm-readline-gnu-perl libterm-readline-perl-perl imagemagick-doc
  autotrace curl enscript ffmpeg gnuplot grads hp2xx html2ps libwmf-bin povray
  radiance texlive-base-bin transfig ufraw-batch libmyodbc odbc-postgresql
  tdsodbc unixodbc-bin dosbox
Recommended packages:
  gettext:i386 unixodbc:i386
The following NEW packages will be installed
  binfmt-support fonts-horai-umefont fonts-unfonts-core gnome-exe-thumbnailer
  icoutils imagemagick imagemagick-common libcapi20-3 libgif4:i386 liblqr-1-0
  libmagickcore5 libmagickcore5-extra libmagickwand5 libmpg123-0 libnetpbm10
  libnss-winbind libodbc1 libpam-winbind netpbm ttf-mscorefonts-installer
  ttf-umefont ttf-unfonts-core unixodbc update-notifier-common winbind wine
  wine-gecko1.4 wine-gecko1.4:i386 wine1.4 wine1.4-amd64 wine1.4-common
  wine1.4-i386:i386 winetricks
0 upgraded, 33 newly installed, 0 to remove and 5 not upgraded.
Need to get 20.0 MB/106 MB of archives.
After this operation, 402 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Err http://archive.ubuntu.com/ubuntu/ quantal/main fonts-unfonts-core all 1.0.3.is.1.0.2-080608-5ubuntu2
  Connection failed [IP: 91.189.92.200 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/f/fonts-unfonts-core/fonts-unfonts-core_1.0.3.is.1.0.2-080608-5ubuntu2_all.deb  Connection failed [IP: 91.189.92.200 80]
Unable to correct missing packages.
E: Aborting install.



4) This is the only thing I didn't try, because I don't understand it.

If you ping the corresponding IP address 91.189.92.201, what happens?



Thank you.

Francesco.
Fra
Level 1
Level 1
 
Posts: 45
Joined: Sun Jan 20, 2013 7:04 am

Re: Can't install Wine.

Postby karlchen on Thu Mar 14, 2013 5:54 am

Hello, Francesco.

No need to send pings to the IP address of archive.ubuntu.com any more. As your browser wanted to download the file from their server immediately, your machine can reach the Ubuntu servers. No general DNS or routing problem, which is good. :)

Summary so far:
Whatever you tried the error message remained the same. This obviously means we have not identified the root cause, yet. :(

Could you please run these commands and post the results:

Code: Select all
inxi -r
to confirm their is no flaw in the repository list.

Code: Select all
sudo apt-get check
to verify the current cached list on your system does not suffer from a problem.

Karl
Image
Enlightened by Lucid Lynx, enchanted by Maya, impressed by Petra.
User avatar
karlchen
Level 9
Level 9
 
Posts: 2554
Joined: Sat Dec 31, 2011 7:21 am

Re: Can't install Wine.

Postby Fra on Thu Mar 14, 2013 3:06 pm

Hello Karl,

I am amazed because you guys are really knowledgeable and full of resources. I have to admit that I.T. requires intelligence :D I myself may one day become intelligent thanks to this forum :mrgreen:. Anyway, joking apart, this is what you required:


1) this is the report for the first command:

Code: Select all
francesco@francesco-Vostro-3460 ~ $ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://mint-mirror.gwendallebihan.net/packages/ nadia main upstream import
           deb http://archive.ubuntu.com/ubuntu/ quantal main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu/ quantal-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ quantal-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ quantal partner
           deb http://packages.medibuntu.org/ quantal free non-free
           Active apt sources in file: /etc/apt/sources.list.d/google-talkplugin.list
           deb http://dl.google.com/linux/talkplugin/deb/ stable main



2) this is the report for the second command:

Code: Select all
francesco@francesco-Vostro-3460 ~ $ sudo apt-get check
[sudo] password for francesco:
Reading package lists... Done
Building dependency tree       
Reading state information... Done



Thank you.

Francesco
Fra
Level 1
Level 1
 
Posts: 45
Joined: Sun Jan 20, 2013 7:04 am

Re: Can't install Wine.

Postby karlchen on Thu Mar 14, 2013 6:52 pm

Good evening, Francesco.

Good news first:
The "inxi -r" does not reveal any obvious flaw in the list. The "apt-get check" looks all right as well.

So I start assuming their might be a problem affecting Wine or one of its dependent packages (the fonts package which provokes the error message) perhaps. Will have to ask our best friend, Mr Google, and search the Ubuntu forum, the Wine forum and maybe Launchpad as well.

A short while ago a flaw was detected which prevented people that had performed a fresh installation of Ubuntu 12.04.2 x64 (corresponds to Mint 13 x64) from installing Wine under certain circumstances. The Ubuntu 12.04.2 x64 installation ISO was lacking a particular software package which caused a Wine installation to suggest - incorrectly - to remove a lot of essential software packages. Installing the absent package first and Wine next fixed the problem in that case.

Maybe there is a similar bug affecting Ubuntu 12.10 x64 (corresponds to Mint 14 x64) as well. Yet, at this point in time, without having found any reports to this effect, yet, this is only my personal assumption. Will report back whether any reports about similar problem when installing Wine can be found.

Kind regards,
Karl
Image
Enlightened by Lucid Lynx, enchanted by Maya, impressed by Petra.
User avatar
karlchen
Level 9
Level 9
 
Posts: 2554
Joined: Sat Dec 31, 2011 7:21 am

Re: Can't install Wine.

Postby Fra on Fri Mar 15, 2013 3:18 am

Good morning Karl,

thank you so much for having explained all this and helped me. It is a very good news that system is healthy... I have never experienced any issue but this one, indeed. My installation is quite recent though, which makes me think of the Ubunto problem that you mentioned; but in this case, anybody should have the very same problem with their PCs, if I grasp what you said. I suppose I have the latest version of Nadia 64 bit / cinnamon. If I manage to try something that works or something noticeable occurs, I will report it here immediately.

Thank you.
All the best,
Francesco
Fra
Level 1
Level 1
 
Posts: 45
Joined: Sun Jan 20, 2013 7:04 am

Re: Can't install Wine.

Postby ibizamale on Sun Mar 31, 2013 5:50 pm

Hiya.

I have been having the same problem.

While searching around the web i have found the following solution

I had to install using the following command

sudo apt-get install --no-install-recommends wine1.5

This had completed the install

i found the info a¡in the following post

viewtopic.php?f=47&t=102684

Will reply back if it worked

Regards
ibizamale
Level 1
Level 1
 
Posts: 1
Joined: Sun Mar 31, 2013 5:44 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 20 guests