How to disable Alt+apostrophe

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

How to disable Alt+apostrophe

Postby crazyproger on Tue Dec 11, 2012 11:01 am

Hello!
I'm using cinnamon about two weeks and almost fine except
that I didn't find how to disable <Alt>+apostrophe combination.
When I press this combination window switching tab appeared.
I need this combination in my application as hotkey, but cinnamon catches it.

Can you help me?
I'm using:
Linux Mint Nadia Cinnamon

Thanks in advance!
crazyproger
Level 1
Level 1
 
Posts: 4
Joined: Tue Dec 11, 2012 10:53 am

Linux Mint is funded by ads and donations.
 

Re: How to disable Alt+apostrophe

Postby Dngrsone on Tue Dec 11, 2012 1:00 pm

Cinnamon Settings/Keyboard/Keyboard settings... don't know where you have that binding under there, but you should be able to find it and remove it from there.
User avatar
Dngrsone
Level 3
Level 3
 
Posts: 180
Joined: Thu Nov 29, 2012 12:18 pm

Re: How to disable Alt+apostrophe

Postby crazyproger on Wed Dec 12, 2012 1:45 am

I didn't find this binding in Keyboard settings - that's why I'm asking this question in forum.
crazyproger
Level 1
Level 1
 
Posts: 4
Joined: Tue Dec 11, 2012 10:53 am

Re: How to disable Alt+apostrophe

Postby crazyproger on Wed Dec 12, 2012 11:06 am

Sorry for my mistake - I'm talking about <Alt>+grave combination, think this is more convenient.
Also I found another guy with this problem http://cinnamon.linuxmint.com/?p=207#comment-4481
crazyproger
Level 1
Level 1
 
Posts: 4
Joined: Tue Dec 11, 2012 10:53 am

Re: How to disable Alt+apostrophe

Postby Dngrsone on Wed Dec 12, 2012 11:42 am

AH, that is definitely a horse of a different color.

That is a Gnome 3 default key combination for window switching.

Try this: Change 'Key to flip through windows' in the switcher from disabled to something else.

I pulled that out of an Ubuntu/Unity how-to and I am in the 12.04 OS right now so I can't test it out for you. But what it boils down to is that the alt+` key combination is a default setting, so by changing the combination for flipping through windows to something other than 'disabled' which means (to Gnome 3) default setting, then you should be able to stop the window manager from responding to that key combination.

ref 1
User avatar
Dngrsone
Level 3
Level 3
 
Posts: 180
Joined: Thu Nov 29, 2012 12:18 pm

Re: How to disable Alt+apostrophe

Postby crazyproger on Wed Dec 12, 2012 1:13 pm

Sadly, there is no such option in cinnamon key bindings :(
I found this workaround(similar to your) https://bugs.launchpad.net/unity/+bug/874734/comments/6 , after installing compiz settings manager I didn't find ubuntu unity plugin.
Also I installed gconf-editor but didn't find anything with word 'flip' or 'grave' or 'backtick'.
crazyproger
Level 1
Level 1
 
Posts: 4
Joined: Tue Dec 11, 2012 10:53 am

Re: How to disable Alt+apostrophe

Postby Dngrsone on Wed Dec 12, 2012 1:34 pm

Well, Unity is an entirely different desktop environment than Cinnamon...

There doesn't seem to be anything in the native Unity Keyboard mapping. :/

Okay, look here. It looks like the binding code is actually <alt>above_tab so if you can use gconf-editor or its equivalent, you might be able to track that binding code down that way.
User avatar
Dngrsone
Level 3
Level 3
 
Posts: 180
Joined: Thu Nov 29, 2012 12:18 pm

Re: How to disable Alt+apostrophe

Postby marianbonczek on Sun Mar 03, 2013 6:19 am

I haven't found :( that binding code in my gconf-editor. Any other ideas?
marianbonczek
Level 1
Level 1
 
Posts: 1
Joined: Sun Mar 03, 2013 6:04 am

Re: How to disable Alt+apostrophe

Postby grizzler on Sun Mar 03, 2013 8:06 am

Try /org/gnome/desktop/wm/keybindings in dconf-editor (part of the dconf-tools package).
grizzler
Level 4
Level 4
 
Posts: 432
Joined: Wed Jun 15, 2011 5:19 pm
Location: The Hague, NL

Re: How to disable Alt+apostrophe

Postby marcindomanski on Fri Mar 15, 2013 7:26 pm

grizzler wrote:Try /org/gnome/desktop/wm/keybindings in dconf-editor (part of the dconf-tools package).


Hi, I am having the same problem on a fresh Mint 14 Cinamon. I did find that key in dconf, plus the exact key where Alt + ` appears to be assigned (it's the switch-group key with ['<Alt>Abote_Tab'] default setting), but unfortunately disabling it does not seem to have any effect. The key combination still works as before, even after a reboot :(

Has anyone figured out how to change it? I would love to see an answer to that question ...

Many thanks,
Marcin
marcindomanski
Level 1
Level 1
 
Posts: 4
Joined: Fri Mar 15, 2013 7:13 pm

Re: How to disable Alt+apostrophe

Postby marcindomanski on Sat Mar 16, 2013 5:31 am

Ok, found it!

First see this: viewtopic.php?f=208&p=655543#p655476. It explains why custom shortcuts are not working in Mint 14 Cinamon and there is a workaround for this, a working one!

Now, when you restore "Keyboard" settings under System Tools -> System Settings, then simply go there and go to the Shortcuts tab. Then find "Switch windows of an application" and assign a shortcut. By default there is no key assigned so the default one (Alt + `) is used. But if you assign a different shortcut, which does work, then Alt + ` is no longer used! That allows you to assign that shortcut to anything else. In my case, I used that as an alternative shortcut for Toggle Scale, which can be set under Cinamon Settings -> Keyboard -> Keyboard shortcuts tab.
marcindomanski
Level 1
Level 1
 
Posts: 4
Joined: Fri Mar 15, 2013 7:13 pm

Re: How to disable Alt+apostrophe

Postby boekhold on Tue Jul 23, 2013 8:06 am

I found a reasonably easy workaround for this:

  • Install dconf-editor
  • Launch dconf-editor
  • Locate /org/gnome/desktop/wm/keybindings
  • Find the definition for switch-group. It should be set to ['<Alt>AboveTab']
  • Change this to ['<Alt>~']
  • Logoff/logon

To be fair, this doesn't allow you to type 'Alt-~' to get the previous behaviour back (maybe ['<Alt>Tilde'] would work?), but it does allow your other applications to receive Alt-` as a keyboard shortcut (for example IntelliJ Idea for the VCS popup window).

Maarten
boekhold
Level 1
Level 1
 
Posts: 25
Joined: Thu Nov 10, 2011 8:10 am

Re: How to disable Alt+apostrophe

Postby lexmint on Fri Jan 31, 2014 3:49 pm

marcindomanski wrote:
grizzler wrote:Try /org/gnome/desktop/wm/keybindings in dconf-editor (part of the dconf-tools package).


Hi, I am having the same problem on a fresh Mint 14 Cinamon. I did find that key in dconf, plus the exact key where Alt + ` appears to be assigned (it's the switch-group key with ['<Alt>Abote_Tab'] default setting), but unfortunately disabling it does not seem to have any effect. The key combination still works as before, even after a reboot :(

Has anyone figured out how to change it? I would love to see an answer to that question ...

Many thanks,
Marcin



Yes, same thing happened to me. This is how I solved it:

Change the switch-group value /org/gnome/desktop/wm/keybindings in dconf-editor AND ALSO change it here:

/org/cinnamon/muffin/keybindings

Then log off / log on, and that's it.

Hope it works for you too :)
lexmint
Level 1
Level 1
 
Posts: 1
Joined: Fri Jan 31, 2014 3:19 pm

Linux Mint is funded by ads and donations.
 

Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 2 guests