Huge volume notification in the middle of screen

Huge volume notification in the middle of screen

Postby .mouse on Sun Mar 17, 2013 2:22 pm

I'm running Mint 13 MATE x64 and any time I mute or change the volume via media keys a huge indicator pops up in the middle of the screen. I can't figure out how to move it to a corner or change the color or icon or resize it or anything. I also haven't found anybody else that has experience with this problem either. Installing notify-osd created multiple conflict issues, such as pidgin notifications requiring confirmation any time someone logs in or things of that nature. Does anyone know how to move this notifier to a corner?
.mouse
Level 1
Level 1
 
Posts: 7
Joined: Sun Feb 17, 2013 1:39 pm

Linux Mint is funded by ads and donations.
 

Re: Huge volume notification in the middle of screen

Postby TheDynamicHamza21 on Mon Mar 18, 2013 7:53 pm

Haven't treid myself but you could try using the configuration editor (Menu>System Tools>Configuration Editor).

In the editor navigate to apps>Mate-notifcation-daemon> there you can change the pop notification.
Linux Registered User: # 573034

www.domeshotsandfatlaces.com
User avatar
TheDynamicHamza21
Level 5
Level 5
 
Posts: 757
Joined: Thu Oct 04, 2012 7:24 pm
Location: California

Re: Huge volume notification in the middle of screen

Postby .mouse on Tue Mar 19, 2013 7:41 pm

TheDynamicHamza21 wrote:Haven't treid myself but you could try using the configuration editor (Menu>System Tools>Configuration Editor).

In the editor navigate to apps>Mate-notifcation-daemon> there you can change the pop notification.


Oh duh I forgot to check mateconf-editor. Sadly though it seems changing the entries at /apps/mate-notification-daemon/popup_location have no effect on the much larger volume icon in the middle of the screen and after some digging in mateconf-editor I still can't find any entry for it so the values for the huge icon must be some where else(or hardcoded).

As a side note mate-notification-properties also edits some of these values except for the sound alerts so I'm guessing anyone interested can also add sound effects to popup notifications using mateconf-editor.
.mouse
Level 1
Level 1
 
Posts: 7
Joined: Sun Feb 17, 2013 1:39 pm

Re: Huge volume notification in the middle of screen

Postby a2m on Tue Apr 30, 2013 3:00 pm

Same problem for me. I'm running Mint 14 Nadia x64, but my user account/homedir has lived through a number of system upgrades (Mint 9 Isadora, Gnome2 => Mint 10 Julia, Gnome2 => Mint 11 Katya, Gnome2 => Mint 14 Nadia, MATE). It is to be noted, that there are three other user accounts in my system which have lived through dist-upgrades mentioned above, but these users don't experience any problem: the volume popups are small and neat for them (and gtk-styled as well). So I think there might be some legacy settings saved somewhere in {gconf2,mateconf,gsettings,dconf}. I have no idea how to find the exact source of the issue.
a2m
Level 1
Level 1
 
Posts: 3
Joined: Tue Apr 30, 2013 2:45 pm

Re: Huge volume notification in the middle of screen

Postby a2m on Sat May 11, 2013 3:15 am

Hello guys. I've just tried my luck and disabled Marco window manager's simple compositing mode:

Code: Select all
$ mateconftool-2 --set /apps/marco/general/compositing_manager --type bool false


and this has rid me of the huge volume pop-up.
a2m
Level 1
Level 1
 
Posts: 3
Joined: Tue Apr 30, 2013 2:45 pm

Re: Huge volume notification in the middle of screen

Postby .mouse on Sat May 11, 2013 5:11 pm

a2m wrote:Hello guys. I've just tried my luck and disabled Marco window manager's simple compositing mode:

Code: Select all
$ mateconftool-2 --set /apps/marco/general/compositing_manager --type bool false


and this has rid me of the huge volume pop-up.


Compositing_manager was already set to false for me. I swapped it's value to true and back again and it's still an issue. I'm also using Compiz as the window handler but it was still an issue before that.
.mouse
Level 1
Level 1
 
Posts: 7
Joined: Sun Feb 17, 2013 1:39 pm

Re: Huge volume notification in the middle of screen

Postby a2m on Sun May 12, 2013 3:20 am

.mouse wrote:I'm also using Compiz as the window handler but it was still an issue before that.


And what happens when any compositing is disabled (both Compiz and Marco's one)?
a2m
Level 1
Level 1
 
Posts: 3
Joined: Tue Apr 30, 2013 2:45 pm

Re: Huge volume notification in the middle of screen

Postby .mouse on Mon May 13, 2013 8:49 am

a2m wrote:
.mouse wrote:I'm also using Compiz as the window handler but it was still an issue before that.


And what happens when any compositing is disabled (both Compiz and Marco's one)?


Well Marco's is already disabled and disabling Compiz's compositing will make it largely pointless.
.mouse
Level 1
Level 1
 
Posts: 7
Joined: Sun Feb 17, 2013 1:39 pm

Re: Huge volume notification in the middle of screen

Postby mideal on Fri May 24, 2013 10:21 am

That is not the appropriate answer (I came to that question when I found the "disable"-key in the conf-tool).

I also get those notifications (while I don't bother).
But if I did and diabled MARCO with the tip above, what would happen - with no COMPIZ installed?
Will there be any desktop displayed? Marco as default? No X at all? Only console login?
Thinkpad T500/4GB/1TB/UMTS/DVD-Multi, Samsung SFX-4500W+CLX3185FW
Mint Nadia Mate 1.6 64Bit
__________________________
Thank God there is none.
mideal
Level 1
Level 1
 
Posts: 12
Joined: Fri Jan 18, 2013 10:28 am
Location: Germany - Wilhelmshaven & Frankfurt

Re: Huge volume notification in the middle of screen

Postby .mouse on Sat May 25, 2013 12:04 am

mideal wrote:That is not the appropriate answer (I came to that question when I found the "disable"-key in the conf-tool).

I also get those notifications (while I don't bother).
But if I did and diabled MARCO with the tip above, what would happen - with no COMPIZ installed?
Will there be any desktop displayed? Marco as default? No X at all? Only console login?


I think you've misunderstood a few things in this thread. Installing Compiz doesn't solve the huge volume notification issue in the middle of the screen.

Removing marco as your window handler without setting another already installed on your system will have adverse effects. If you want to experiment with different window handlers, then first you should be sure that you know how to switch to another tty(alt+ctrl+F1-F6) to restart your session. After you're sure you know how to restart your desktop environment, in your case MATE, you can experiment with the following command:
Code: Select all
metacity --replace

NOTE: It's a better idea to run this from the run dialog box(alt+f2) rather than running it from the terminal since running it from a terminal will force the window handler to close once you close the terminal/kill the command. However if you want to see what your session will look like without a window handler then running the above command and closing the terminal will show you. Be sure to save anything you might be working on first though.

To get back to your old window handler(marco), run the following command from the dialog box:
Code: Select all
marco --replace


I hope that clears a few things up.
.mouse
Level 1
Level 1
 
Posts: 7
Joined: Sun Feb 17, 2013 1:39 pm

Linux Mint is funded by ads and donations.
 

Return to MATE

Who is online

Users browsing this forum: No registered users and 3 guests