New Cinnamon window theme not showing up in Settings

Forum rules
Before you post please read this

New Cinnamon window theme not showing up in Settings

Postby Fuzzy Penquin on Wed Mar 20, 2013 1:54 pm

So I'm trying to theme Cinnamon. I downloaded DarkCold theme http://linuxmint-art.org/content/show.php/DarkCold?content=143165 from linuxmint-art.org, and it installed fine. Simple drag and drop into usr/share/themes folder. This theme's download page also had a link to make the windows match the menu/task bar at the bottom. http://gnome-look.org/content/show.php/DarkCold+-+3xMetacity?content=148659 According to the instructions on the page, it's the same installation procedure into the same usr/share/themes folder. So I did that with his Metacity/Muffin window decorations theme pack (it contained files for both window managers). Next I went into my Cinnamon settings--->Themes--->Other Settings to switch my Window Theme from Mint-X to ColdDark. ColdDark doesn't appear, only the stock window themes that came with Mint (Adwaita, Aging Gorrilla, Mint-X, etc). What am I missing?

And while I'm asking questions about this.... do MetaCity themes work in Cinnamon? Various Linux theme sites have categories only for KDE, GTK, and MetaCity, but not Muffin. And as I now understand it, Muffin is what Cinnamon uses, and MetaCity is what Unity uses? What about GTK themes? What uses those? I didn't even know if DarkCold would install because it's a GTK theme and I'm not sure what's used by what since there are so many types out there. It was an experiment that happened to work for my menu/task bar theme.
Intel i7-3770k 3.5GHz, 16GB 1600MHz RAM, 3x 1TB HDD, MSI Z77A-G45 Thunderbolt motherboard, (MSI) Nvidia GeForce GTX770, Mint 17 64-bit w/Cinnamon.

I am a n00b! Please assume zero knowledge on my part. Sorry for any dumb questions, I am still learning.
Fuzzy Penquin
Level 2
Level 2
 
Posts: 86
Joined: Wed Feb 27, 2013 4:25 pm

Linux Mint is funded by ads and donations.
 

Re: New Cinnamon window theme not showing up in Settings

Postby samriggs on Wed Mar 20, 2013 3:12 pm

Hi Fuzzy Penguin
Yup yup and yup lol metacity does work in gnome version or normal cinnamon version (not xfce, thats uses a different one).
First of all you don't need to shove in that directory, thats the hard way or long way around it. Just make a folder in your home directory .themes and put it in there instead, it's a hidden file so just press ctl + h to unhide the hidden folders in your home directory.
The reason it most likely is not showing up is because of the index.theme file that should be included in the cinnamon/gtk/metacity folder, in it, it should have something like this
Code: Select all
[X-GNOME-Metatheme]
Name=SteampunkLinux
Type=X-GNOME-Metatheme
Comment=Feel the steam
Encoding=UTF-8
GtkTheme=SteampunkLinux
MetacityTheme=SteampunkLinux
IconTheme=Mint-X
CursorTheme=Adwaita
CursorSize=24

the name gtktheme and MetacityTheme should all have the same name if it's all in that folder and the folder its all in should also have the same name.
If the cinnamon theme is something diffferent it should have its own folder and no index.theme file is needed, there for the gtk/metacity parts of the theme.
Hope this helps you out.
"Windows: the worst system for the most money, Linux: the best system for free"
Registered Linux User #545430
SolydK
User avatar
samriggs
Level 5
Level 5
 
Posts: 843
Joined: Sun Apr 24, 2011 6:09 pm
Location: Canada

Re: New Cinnamon window theme not showing up in Settings

Postby Fuzzy Penquin on Wed Mar 20, 2013 6:41 pm

OMG you're the guy on Deviantart that made the Star Trek theme!!!!!!!!! I absolutely love it! Oh god, I think my nerd colors just showed.... :mrgreen: :lol: The rest of your stuff is awesome too. :D

Thank you for the tip on creating the .themes folder! I didn't even know about that, or that doing such a thing would work. I thought you had to put it into the system's original .themes folder. Cool beans.

Looking through the DarkCold metacity file, I don't see an index.theme file within it. So that's got to be why it didn't work. It's only got a metacity-theme.xml file to tell it what to do with all the stuff. Not sure why an index file wasn't included.... So for experiment, I downloaded a metacity title bar theme called Christmas (it's got snowflakes for the "- + x" buttons!!!) and put that into the new .themes folder you told me to make. Worked like a charm. The Christmas theme contained a index.theme file, so I guess that's why. Thank you soooo much for the info/help and confirmation that metacity and gtk do work in Cinnamon! This makes it all so much easier to theme out Cinnamon now that I know what works and how to do it. If I have any more questions, I'll be back. Lol.

Wait, one more question.... where do I stick new cursors? Do i also put them into this new .themes folder? Do new icons go into an .icons folder, made by me same as the .themes folder?

:?: EDIT:
It seems that many themes don't come with an index.theme file. There has to be a way to make them work, or else the authors would have included an index.theme file. Right?

Also, so far the only themes with an index.theme file within it that have installed and show up in my settings are DarkCold (the one that changed my menu/task bar, not the metacity one) and Chrismas (metacity). All others don't show up in my Cinnamon Settings' theme selection and modification sections. :(
Intel i7-3770k 3.5GHz, 16GB 1600MHz RAM, 3x 1TB HDD, MSI Z77A-G45 Thunderbolt motherboard, (MSI) Nvidia GeForce GTX770, Mint 17 64-bit w/Cinnamon.

I am a n00b! Please assume zero knowledge on my part. Sorry for any dumb questions, I am still learning.
Fuzzy Penquin
Level 2
Level 2
 
Posts: 86
Joined: Wed Feb 27, 2013 4:25 pm

Re: New Cinnamon window theme not showing up in Settings

Postby samriggs on Wed Mar 20, 2013 11:04 pm

Although those dark colds have a title cinnamon on them there not a cinnamon theme at all, I had to download the things to see for myself, if you notice there all metacity themes, every single last one of them, with duplicates in the cinnmaon folder of the ones in the other folders, none of these are cinnamon themes at all, a cinnamon theme should be in a cinnamon folder, they don't need an index.theme file only the gtk and metacity files do. And I might be wrong they must of changed things around, I just tried it without the index.theme for the gtk and metacity and it showed hmmm it's been too long since I made one I guess lol.
So yup it should show up it did in mine. Wow wonder when that happened I been away too long :lol:
Anyhow this is how it works now :lol: lets start this over again.
The theme has to have a main folder with the name of the theme on it, then within that first folder has to be either the metacity, the gtk or the cinnamon or the xfce or all of them at once, looks like the ole index.theme file is passe now (good riddens to it, just an added headache anyhow), if you look in that dark cold main folder you will notice it has a cinnamon-muffin folder and a metacity folder within each are three more folders, one set needs to be put in the .theme folder to show up (if you go in each you will see a metacity folder), you only need either the three that are in the metacity folder or the three that are in the muffin folder, do not place both because they have the same name.
wow this is sounding confusing to me lol sorry about this I'm riding on no sleep.
To make this clearer and because I'm dog tired here is an image to help explain it better.
I have a theme I made called SteampunkLinux within that folder you have you other folders like so.
scr1.png

I took away the index.theme that would normally go in here also and it shows up fine.
The darkcloud one you have is this.
scr2.png

notice it has two folders but this will not show up in the themes why? because within each of these are this:
scr3.png

Then within each of those you have a metacity file
The theme reads the first layer from the lead folder (main named theme folder) then it looks for a gtk, cinnamon, metacity,xfce,unity, folder etc from there then it only goes one more layer deep, if it goes into the metacity folder and doesn't see a metacity.xml it wont show up, same goes with the rest, it looks for the gtkrc file or the cinnamon.css etc. Does it hurt to have to a index.theme file? not that I see or know, but looks like we really don't need it anymore, thanks for getting me to look into this or I wouldn't of realized it things changed while I was gone either lol.
So to get all those dark cloud metacity files to show up just copy paste or drag the folders DarkCold4 DarkCold5 and DarkCold-First into the .themes folder and they should show up, sorry about the confusion, been away to long, and I need sleep lol.
Hope I didn't make this too confusing, and if you like an animated login screen I made 4 so far (mdm) but you have to have the new mdm installed to make them work, you can check them out on the deviantart site, I think Clem is adding the new mdm to the next linuxmint so no installement will be needed, not sure about this but i think so, but it can be added now, just some more eye candy for the login screen :)
all my crap is here: lol samriggs.deviantart.com
Have a good one I'm off to get finally get some sleep 8)
"Windows: the worst system for the most money, Linux: the best system for free"
Registered Linux User #545430
SolydK
User avatar
samriggs
Level 5
Level 5
 
Posts: 843
Joined: Sun Apr 24, 2011 6:09 pm
Location: Canada

Re: New Cinnamon window theme not showing up in Settings

Postby Fuzzy Penquin on Thu Mar 21, 2013 1:04 am

Thank you, it all makes much more sense now. I'll mess with it some more (and re-read your reply) tomorrow when I too am not so tired. Funny that you used your steampunk theme in your example, as I'm using it right now. I ended up installing it while continuing to look for themes that will work correctly. It looks fantastic! I like the stuff you've come up with on your Deviantart page. The last 30 minutes have been spent looking for some matching icon sets and menu/task bar....lol.

Bedtime calls now......
Intel i7-3770k 3.5GHz, 16GB 1600MHz RAM, 3x 1TB HDD, MSI Z77A-G45 Thunderbolt motherboard, (MSI) Nvidia GeForce GTX770, Mint 17 64-bit w/Cinnamon.

I am a n00b! Please assume zero knowledge on my part. Sorry for any dumb questions, I am still learning.
Fuzzy Penquin
Level 2
Level 2
 
Posts: 86
Joined: Wed Feb 27, 2013 4:25 pm

Re: New Cinnamon window theme not showing up in Settings

Postby samriggs on Thu Mar 21, 2013 1:24 am

I'm making a new steampunk cinnamon, gtk, metacity theme to match the mdm I made, soon as I get some more time to play with :)
"Windows: the worst system for the most money, Linux: the best system for free"
Registered Linux User #545430
SolydK
User avatar
samriggs
Level 5
Level 5
 
Posts: 843
Joined: Sun Apr 24, 2011 6:09 pm
Location: Canada

Re: New Cinnamon window theme not showing up in Settings

Postby Fuzzy Penquin on Thu Mar 21, 2013 6:39 pm

Oh! Oh! Oh!!! I can't wait! Please also make a menu/task bar theme to go with it. Your Steampunk theme is the only theme so far that has correctly changed everything on my entire user interface. Most leave portions of the windows untouched (or have incorrectly colored parts), even though the screen shot clearly showed everything changed if you also used theme x, y, z, along with the main theme. But they haven't quite worked like that for me. However, your's did! One thing to check when you make your new theme: the color of the text in the main page Cinnamin Settings menu (before you go into the sub-menus like Effects, Themes, Backgrounds, etc). The text and tan background are the same, so all you see are the icons.

Ooooh, I can't wait! :mrgreen:
Intel i7-3770k 3.5GHz, 16GB 1600MHz RAM, 3x 1TB HDD, MSI Z77A-G45 Thunderbolt motherboard, (MSI) Nvidia GeForce GTX770, Mint 17 64-bit w/Cinnamon.

I am a n00b! Please assume zero knowledge on my part. Sorry for any dumb questions, I am still learning.
Fuzzy Penquin
Level 2
Level 2
 
Posts: 86
Joined: Wed Feb 27, 2013 4:25 pm

Linux Mint is funded by ads and donations.
 

Return to Themes, Icons, & Wallpaper

Who is online

Users browsing this forum: No registered users and 2 guests