Steam LMDE

Discuss non-support related topics related to LMDE.
Forum rules
Before you post please read this

Steam LMDE

Postby bradsha on Sat Mar 23, 2013 6:25 pm

Hey Guys iv instaled the new linuxmint debian mate and was woundering if anyone got steam going with the drivers we have on wheezy i saw this https://github.com/GhostSquad57/Steam-I ... for-Wheezy but was woundering if anyone got it working thanks in advanced ! :D
bradsha
Level 1
Level 1
 
Posts: 22
Joined: Tue May 04, 2010 4:54 pm

Linux Mint is funded by ads and donations.
 

Re: Steam LMDE

Postby arcorreia on Fri Mar 29, 2013 9:47 am

Hi bradsha,

Yes, I've got it running. I downloaded steam-debian_1.0.0.36-4_all.deb from the site you mentioned.

PS - In my case it complains that "(Sorry about that, but we can't show files that are this big right now)", just ignore this and click the link above it (View Raw) and the download starts.

Open synaptic or whatever package manager you use and install realpath (steam needs it)

Go to your downloads folder, open a terminal:

sudo dpkg -i steam-debian_1.0.0.36-4_all.deb

sudo sh /usr/lib/steam/steam-debian-depends.sh (this will install jockey-common and other dependencies)

Run /usr/bin/steam-debian (if you don't have an account it offers to create one), configure it for your language, etc. It's done. :D

Best regards,
António
Image
User avatar
arcorreia
Level 1
Level 1
 
Posts: 5
Joined: Fri Dec 07, 2012 9:44 am
Location: Cascais, Portugal

Re: Steam LMDE

Postby eiver on Sun Mar 31, 2013 1:17 pm

using LMDE.x64; // installed 201303
using Nvidia.Optimus.Laptop.With.bumblebee;

installed steam-debian_1.0.0.36-4_all.deb
Steam works.
Installed world of goo, it works!
I didn't have to install any other dependencies.

Small Issues noticed:
The package does not show any progress during download, so patience.
The desktop link to the game does not work (it starts steam not steam-debian, replacing did not work, must launch games from steam application).
User avatar
eiver
Level 5
Level 5
 
Posts: 564
Joined: Fri Jan 23, 2009 5:51 am

Re: Steam LMDE

Postby eiver on Wed Apr 10, 2013 5:07 pm

Ok, it worked on my laptop, but it doesn't work with my desktop where I have GTX 570, LMDE x64 and default proprietary nvidia drivers from repos. It says:

Code: Select all
Running Steam on linuxmint 1 64-bit
STEAM_RUNTIME is enabled automatically
Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1

How do I get 32-bit opengl libs? And why I didn't have this kind of problem on my laptop?
User avatar
eiver
Level 5
Level 5
 
Posts: 564
Joined: Fri Jan 23, 2009 5:51 am

Re: Steam LMDE

Postby squig on Mon Apr 15, 2013 8:20 am

im not running steam atm but i used an older version of the deb file you linked on my old lmde install (32bit). worked fine.

Eiver:

perhaps this is relevant for you? there was also some information about flash which i didnt quote:

https://github.com/GhostSquad57/Steam-I ... heezy/wiki
Installing on 64bit systems

Enable 32bit repos with sudo dpkg --add-architecture i386
Update your repo with sudo apt-get update
Install 32bit driver files:

For ATI Cards: libgl1-fglrx-glx:i386

For Nvidia Cards: libgl1-nvidia-glx:i386
squig
Level 1
Level 1
 
Posts: 8
Joined: Wed Sep 26, 2012 1:20 pm

Re: Steam LMDE

Postby eiver on Mon Apr 15, 2013 5:48 pm

I recently installed LMDE from the latest release, so it already has multiarch enabled.
Code: Select all
$ sudo dpkg --print-foreign-architectures
i386


As for the libs. I do have the package installed, but not the 32-bit version. If I istall the 32-bit version it completely uninstalls the whole driver and I am dropped to console after reboot :(
Code: Select all
$ sudo apt-get install libgl1-nvidia-glx:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-nvidia-glx:i386 : Depends: libxvmc1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Code: Select all
$ sudo apt-get install libxvmc1:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libgl1-nvidia-glx libxvmc1 mplayer nvidia-glx xserver-xorg-video-nvidia
The following NEW packages will be installed:
  libxvmc1:i386
0 upgraded, 1 newly installed, 5 to remove and 0 not upgraded.
Need to get 0 B/24.0 kB of archives.
After this operation, 69.5 MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.


Notice:
The following packages will be REMOVED:
libgl1-nvidia-glx libxvmc1 mplayer nvidia-glx xserver-xorg-video-nvidia
User avatar
eiver
Level 5
Level 5
 
Posts: 564
Joined: Fri Jan 23, 2009 5:51 am

Re: Steam LMDE

Postby zerozero on Mon Apr 15, 2013 6:19 pm

Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: Steam LMDE

Postby eiver on Tue Apr 16, 2013 1:40 pm

Thanks. At least now I know the situation. Unfortunately the package from http://twolife.be/debian/todo/xvmc/ didn't work. It installs, but then I have broken dependencies and have to "sudo apt-get install -f" :(
I guess this is one of those "rough edges", that where mentioned at the LMDE download page.
User avatar
eiver
Level 5
Level 5
 
Posts: 564
Joined: Fri Jan 23, 2009 5:51 am

Re: Steam LMDE

Postby twelvedogs on Fri Aug 09, 2013 3:55 am

it's not really a rough edge, the steam linux client is only tested against ubuntu. if you're running lmde you're gonna have to do some work unless the guys doing the build go out of their way to bridge the gap from this side.
twelvedogs
Level 1
Level 1
 
Posts: 4
Joined: Wed Jul 31, 2013 5:31 am

Re: Steam LMDE

Postby zerozero on Fri Aug 09, 2013 5:37 am

twelvedogs wrote:the steam linux client is only tested against ubuntu
not anymore
http://packages.debian.org/jessie/steam
(unfortunately is not installable in lmde as-is)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: Steam LMDE

Postby Jerom on Sun Sep 22, 2013 1:45 pm

This .deb worked now with latest UP7 packages apparently... :P
(Intel default graphic driver, LMDE MATE 64bits refreshed from UP7/Incoming)

Downloading 210 MB worth of updates from Steam now and I should be rolling ! Yeah :twisted:
Thanx!
Jerom
Level 1
Level 1
 
Posts: 23
Joined: Tue Aug 27, 2013 3:43 pm

Re: Steam LMDE

Postby Guan on Mon Sep 23, 2013 9:52 pm

It's still busted for me after UP7. It calls for libGL.so.1. It then crashes with the error message, "Fatal Error: Failed to load steamui.so" So frustrating.
Guan
Level 1
Level 1
 
Posts: 42
Joined: Mon Jul 13, 2009 6:04 am
Location: Guangzhou, China

Re: Steam LMDE

Postby Jerom on Mon Sep 23, 2013 11:41 pm

Yes, you're right, same error message for me after the 210MB download and unpacking steam runtime... :(

I guess steamOS will roll and rock everything in its way (for gamers at least)... http://store.steampowered.com/livingroom/SteamOS/
:twisted:
Jerom
Level 1
Level 1
 
Posts: 23
Joined: Tue Aug 27, 2013 3:43 pm

Re: Steam LMDE

Postby zerozero on Mon Sep 23, 2013 11:58 pm

are you using a nvidia card?
if so
Code: Select all
apt install libgl1-mesa-glx
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: Steam LMDE

Postby Guan on Sat Sep 28, 2013 11:35 am

zerozero wrote:are you using a nvidia card?
if so
Code: Select all
apt install libgl1-mesa-glx


I have dual 680 GTX's

The package you mentioned is already installed and the latest version, so no joy there.
Guan
Level 1
Level 1
 
Posts: 42
Joined: Mon Jul 13, 2009 6:04 am
Location: Guangzhou, China

Re: Steam LMDE

Postby darco on Sat Dec 21, 2013 12:19 pm

Just installed Steam, all is working well!
TFC here I come!
darco
Level 3
Level 3
 
Posts: 166
Joined: Sat May 24, 2008 5:03 pm

Linux Mint is funded by ads and donations.
 

Return to Open Discussion

Who is online

Users browsing this forum: lake_wrangler and 2 guests