[SOLVED] fluxbox and xfce font settings (opera browser)

Forum rules
Before you post please read this

[SOLVED] fluxbox and xfce font settings (opera browser)

Postby Flemur on Sun Mar 24, 2013 5:28 pm

I've been having the typical problems making fonts look right in the opera browser - turns out the settings are working in Xfce4, but not in fluxbox.

Starting opera with:
$ opera -debugfont
Shows incorrect or undefined settings running opera in fluxbox:
...
Code: Select all
opera: Xft baseline settings:
opera: antialias: yes
opera: hinting: yes
opera: autohint: no
opera: hintstyle: full             <------- wrong
opera: rgba: not specified  <------- wrong
opera: lcdfilter: legacy          <----- ???

opera: Toolkit font render settings:
opera: antialias: yes
opera: hinting: yes
opera: autohint: not specified  <----- wrong
opera: hintstyle: full   <--------- wrong
opera: rgba: not specified  <----- wrong
opera: lcdfilter: not specified  <------- ???

opera: Final settings adjusted by fontconfig:
opera: antialias: yes
opera: hinting: yes
opera: autohint: no
opera: hintstyle: full   <--------- wrong
opera: rgba: not specified  <--------- wrong
opera: lcdfilter: default  <---------- ???


In both lxappearance and xfce4-appearance-settings I've set:
autohint = OFF
hintstyle = SLIGHT
rgba = NONE
the same as in the ~/.fonts.conf file and ~/.Xdefaults

My ~/.fonts.conf (settings to suppsedly make all fonts anti-aliased at all sizes):
Code: Select all
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/fonts.conf file to configure system font access -->
<fontconfig>
<match target="font">
<edit name="antialias" mode="assign"> <bool>true</bool>         </edit>
<edit name="autohint"  mode="assign"> <bool>false</bool>        </edit>
<edit name="hinting"   mode="assign"> <bool>true</bool>         </edit>
<edit name="hintstyle" mode="assign"> <const>hintslight</const> </edit>
<edit name="rgba"      mode="assign"> <const>none</const>       </edit>
</match>
</fontconfig>


.Xdefaults:
Code: Select all
# To fix opera fonts:
Xft.antialias:  1
Xft.autohint:   0
Xft.hinting:    1
Xft.hintstyle:  hintslight
Xft.rgba:       none
# End opera 'fix'



What can I do to trick opera into using the correct settings in fluxbox?assign
Last edited by Flemur on Mon Mar 25, 2013 9:17 am, edited 1 time in total.
Mint 17/Xfce/fluxbox & Mint 16/Xfce/fluxbox
User avatar
Flemur
Level 5
Level 5
 
Posts: 846
Joined: Mon Aug 20, 2012 9:41 pm

Linux Mint is funded by ads and donations.
 

Re: fluxbox and xfce font settings (opera browser)

Postby Flemur on Mon Mar 25, 2013 9:16 am

Solved: when starting fluxbox, run "gnome-settings-daemon"
Mint 17/Xfce/fluxbox & Mint 16/Xfce/fluxbox
User avatar
Flemur
Level 5
Level 5
 
Posts: 846
Joined: Mon Aug 20, 2012 9:41 pm


Return to Others

Who is online

Users browsing this forum: No registered users and 0 guests