desktop backgroound image

Forum rules
Before you post please read this

desktop backgroound image

Postby jsplicer on Mon Mar 25, 2013 1:00 am

I feel like an idiot. But I have been pulling my hair out of my head trying to change the dektop background. I can not find any of the usual ways to do it.

Someone please save my sanity! All I want to do is change the picture in the background why do they make it so difficult?

John
OS: Linux Mint 16 KDE
Motherboard: Gigabyte EP45-UD3P Rev. 1.6 FE BIOS
CPU: Intel Core2Quad Q8400 2.66 GHz.
Memory: GSkill: 4 GB DDR2 800 MHz.
GPU: PCI-E 3 NVidia GEFORCE GTX 650 DDR 5, 1GB Ram
Drives: Int: 500 GiB WD HDD, Ext: USB 2 500 GiB HDD
jsplicer
Level 2
Level 2
 
Posts: 87
Joined: Sun Dec 30, 2012 2:39 pm

Linux Mint is funded by ads and donations.
 

Re: desktop backgroound image

Postby caf4926 on Mon Mar 25, 2013 1:40 am

You really need to say if you are using KDE, Mate, XFCE, Cinnamon
Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1746
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: desktop backgroound image

Postby jsplicer on Mon Mar 25, 2013 1:20 pm

My apologies...I was so agravated that I thought I did. I am using Linux Mint 14 KDE 64 bit.

I usually just right click to change background image, or click on the wallpaper and right click on that to set as desktop background. I can't find even any other choices for other backgrounds the OS suplies. The Mate version of linux mint at least gives you choices of pictures to change to. There has to be a way...I never used KDE before, so I am not familiar with it.

Thanks for any help,

John
OS: Linux Mint 16 KDE
Motherboard: Gigabyte EP45-UD3P Rev. 1.6 FE BIOS
CPU: Intel Core2Quad Q8400 2.66 GHz.
Memory: GSkill: 4 GB DDR2 800 MHz.
GPU: PCI-E 3 NVidia GEFORCE GTX 650 DDR 5, 1GB Ram
Drives: Int: 500 GiB WD HDD, Ext: USB 2 500 GiB HDD
jsplicer
Level 2
Level 2
 
Posts: 87
Joined: Sun Dec 30, 2012 2:39 pm

Re: desktop backgroound image

Postby Orbmiser on Mon Mar 25, 2013 1:55 pm

What's so hard as I right-click desktop properties and the View opens up with default wallpapers.
If none I want there then I click on Open which allows me to browse to any folder I may have wallpaper stored.

The nice thing in KDE is when I apply it then is copied into the default wallpapers so is there in the list for future use.
And KDE also allows me to set different wallpaper on dual displays.
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1513
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: desktop backgroound image

Postby caf4926 on Mon Mar 25, 2013 1:57 pm

Because kde uses activity workspaces it's different
Right click> unlock widgets
Right click > desktop/folder view settings (depends on what you have), you should see what I mean and what to do from there

when you are done > right click lock widgets
Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1746
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: desktop backgroound image

Postby Orbmiser on Mon Mar 25, 2013 2:00 pm

caf4926 wrote:Because kde uses activity workspaces it's different
Right click> unlock widgets
Right click > desktop/folder view settings (depends on what you have), you should see what I mean and what to do from there

when you are done > right click lock widgets


???? what's that got to do with changing desktop wallpaper. And don't understand the need and what this accomplishes?
As we are talking of just changing desktop wallpaper here?
Sorry new and always willing to learn something new.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1513
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: desktop backgroound image

Postby jsplicer on Mon Mar 25, 2013 2:17 pm

I tried both of your suggestions. "What is so hard here" is that when I right click on the desktop, I dont get any properties or any list of wall papers. I do get the lock or unlock widgets, which I also tried, but to no avail.

This stubborn OS is not letting me change my desktop picture, plain and simple. Does it have anything to do with themes? Is there a way to get rid of a theme?
OS: Linux Mint 16 KDE
Motherboard: Gigabyte EP45-UD3P Rev. 1.6 FE BIOS
CPU: Intel Core2Quad Q8400 2.66 GHz.
Memory: GSkill: 4 GB DDR2 800 MHz.
GPU: PCI-E 3 NVidia GEFORCE GTX 650 DDR 5, 1GB Ram
Drives: Int: 500 GiB WD HDD, Ext: USB 2 500 GiB HDD
jsplicer
Level 2
Level 2
 
Posts: 87
Joined: Sun Dec 30, 2012 2:39 pm

Re: desktop backgroound image

Postby jsplicer on Mon Mar 25, 2013 2:47 pm

I got it back to where Orbmiser had his settings, by following caf4926 settings, and clicking on 'Default Desktop'. It then went back to normal. So thank you both for your help! :D I never thought changing a desktop picture would be so damn frustrating. lol!

KDE is a beautiful desktop environment, it just has so many differrent configurations, more than Mate even. That it gets confusing as to what you are used to doing without even giving it a second thought.

Thanks again guys!

John
OS: Linux Mint 16 KDE
Motherboard: Gigabyte EP45-UD3P Rev. 1.6 FE BIOS
CPU: Intel Core2Quad Q8400 2.66 GHz.
Memory: GSkill: 4 GB DDR2 800 MHz.
GPU: PCI-E 3 NVidia GEFORCE GTX 650 DDR 5, 1GB Ram
Drives: Int: 500 GiB WD HDD, Ext: USB 2 500 GiB HDD
jsplicer
Level 2
Level 2
 
Posts: 87
Joined: Sun Dec 30, 2012 2:39 pm

Re: desktop backgroound image

Postby Orbmiser on Mon Mar 25, 2013 3:22 pm

Hmmm glad you figured it out. Just don't know enough I guess why just right-clicking desktop doesn't work.
As never had to unlock widgets first.

6668.png
6668.png (32.9 KiB) Viewed 2051 times


Panel/Widgets are not unlocked and right-click always seemed to work for me.
So maybe will learn something new? If someone chimes in and explain why it didn't work for you.

Glad you got it solved tho!
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1513
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: desktop backgroound image

Postby jsplicer on Mon Mar 25, 2013 3:38 pm

Orbmiser -Thanks Bro, it had me going nuts. But not only did I have to unlock the widgets, on the bottom of the panel I had to check the 'default desktop' also. And as you stated, I dont know why this happened, I just installed KDE yesterday, so it may have been something in the updating I let it do after installing it. Matter of fact after right clicking on the desktop just now I get the same panel, and on the bottom of the panel says 'Default Desktop Settings ALT + D, ALT + S . I don't get the usual panel, that I got in Mate.

I'm going to dig around further try to get to the bottom of this to help others if they come across it. Doesn't matter to me, my problems started yesterday, when I lost everything on both hard drives. Luckily I had my music backed up, and important photo's on my phone. I was able to restore my bookmarks into firefox from sync on my phone. Anyway after Mate became bricked after installing Wine and Play for Linux, my problems started. I was no longer even able to install Mate the login window would go into an endless loop, even after wiping both drives clean, then it said grub refused to install because of a fatal error. So I tried Ubunto 12.10, that installed but was so buggy I couldnt take it, it froze on me every 10 minutes for something a few different reasons. So my last hope was to try my KDE .iso, that installed without a hitch.
OS: Linux Mint 16 KDE
Motherboard: Gigabyte EP45-UD3P Rev. 1.6 FE BIOS
CPU: Intel Core2Quad Q8400 2.66 GHz.
Memory: GSkill: 4 GB DDR2 800 MHz.
GPU: PCI-E 3 NVidia GEFORCE GTX 650 DDR 5, 1GB Ram
Drives: Int: 500 GiB WD HDD, Ext: USB 2 500 GiB HDD
jsplicer
Level 2
Level 2
 
Posts: 87
Joined: Sun Dec 30, 2012 2:39 pm

Re: desktop backgroound image

Postby Orbmiser on Mon Mar 25, 2013 5:58 pm

I was able to restore my bookmarks into firefox from sync on my phone.


Use the xmarks extension on all devices for firefox and believe it is available for Chrome.
First thing I do fresh install firefox is the xmarks extension. Tablet,Windows or Linux I have my bookmarks.
And retrieves them from their server for pain free bookmarks. And keeps them synced for freshness.

Good luck as sounds like maybe hardware issues are giving a run for your money.
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1513
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: desktop backgroound image

Postby Cariboo on Thu Apr 18, 2013 12:33 pm

Hello,
I have the same setting and similar issue as jslicer:
I'm running Linux Mint 14 on my PC and I want to add some pictures to the "Change Desktop Background" Wallpaper pictures:

---> right-click anywhere on Desktop and
---> select "Change Desktop Background" then
---> the window "Cinnamon Settings - Backgrounds" opens

How can I add my own pictures so that they appear in this (attached) selection?

Orbmiser's answer was:

Orbmiser wrote:What's so hard as I right-click desktop properties and the View opens up with default wallpapers.
If none I want there then I click on Open which allows me to browse to any folder I may have wallpaper stored.


Now I want to ask Orbmiser what he means by "....If none I want there then I click on Open...."? because this is exactly what I want to do! Where is this Open button?
Attachments
Backgrounds.png
Self-built MSI-785GM-E51 Desktop, Dual boot: LM15-64bit-Cinnamon and Win7-64bit , Samsung Galaxy S4 un-locked.
User avatar
Cariboo
Level 4
Level 4
 
Posts: 203
Joined: Sun Jan 13, 2008 10:00 pm

Re: desktop backgroound image

Postby Orbmiser on Thu Apr 18, 2013 8:37 pm

Sorry Cariboo but Cinnamon is different then the KDE desktop that we were discussing.
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1513
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: desktop backgroound image

Postby Cariboo on Thu Apr 18, 2013 10:33 pm

Orbmiser wrote:Sorry Cariboo but Cinnamon is different then the KDE desktop that we were discussing.
.

OK got it ... :oops:
thank you anyway.,.
do you happen to know how it works in Cinnamon?
Self-built MSI-785GM-E51 Desktop, Dual boot: LM15-64bit-Cinnamon and Win7-64bit , Samsung Galaxy S4 un-locked.
User avatar
Cariboo
Level 4
Level 4
 
Posts: 203
Joined: Sun Jan 13, 2008 10:00 pm

Re: desktop backgroound image

Postby Orbmiser on Thu Apr 18, 2013 11:25 pm

When I ran Cinnamon just put the wallpapers in my pics folder and in Nemo right click set as background I believe.
Otherwise need to find where those wallpapers in root are and copy which ones you want to there.
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1513
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: desktop backgroound image

Postby Cariboo on Fri Apr 19, 2013 10:32 am

Orbmiser wrote:......
Otherwise need to find where those wallpapers in root are and copy which ones you want to there.
.

That's what I desperately try to do but there is kind of a discrepancy....the backgrounds listed in "Cinnamon Settings - Backgrounds" can not be found under these names. Is there another way to search for them? If I would find the location of those two I would be at the right place to put my own pictures in.
Attachments
Backgrounds.png
Self-built MSI-785GM-E51 Desktop, Dual boot: LM15-64bit-Cinnamon and Win7-64bit , Samsung Galaxy S4 un-locked.
User avatar
Cariboo
Level 4
Level 4
 
Posts: 203
Joined: Sun Jan 13, 2008 10:00 pm

Re: desktop backgroound image

Postby Orbmiser on Fri Apr 19, 2013 12:38 pm

Right picture shows a "Advanced Settings" did you click on that drop down menu and see what's in there?
Trying to remember been awhile using Cinnamon. But think you click on that to access loading wallpaper from other location?
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1513
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: desktop backgroound image

Postby sjmcc on Fri Apr 19, 2013 1:52 pm

The folder you are looking for is /usr/share/backgrounds. I am running the cinnamon nightlies and the new version of cinnamon that will be in Mint 15 allows you to add and remove them right from the backgrounds page in cinnamon settings.
sjmcc
Level 1
Level 1
 
Posts: 28
Joined: Thu May 03, 2012 10:16 pm

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 0 guests