"lm-sensors" need upgrading??? PS: Linux Mint Rocks!

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

"lm-sensors" need upgrading??? PS: Linux Mint Rocks!

Postby Tex1954 on Tue Mar 26, 2013 4:42 pm

Howdy folks. First of all, let me thank the Linux Mint team for making a perfectly working (for my uses) Linux Distro! Hats off to ya'll! For various reasons and my specific requirements, Linux Mint 14 "Nadia" Cinnamon 64b is the ONLY recent updated kernal distro that works for a noob like me. Please see my comments here: My BOINC Comments on good distro!

The one thing I have a problem with is that "sudo sensors-detect" comes up with a lack of support for a few of my boards. An example message on one Gigabyte GA-78LMT-USB3 reads as follows:

Driver `to-be-written':
* ISA bus, address 0x228
Chip `ITE IT8728F Super IO Sensors' (confidence: 9)

Driver `k10temp' (autoloaded):
* Chip `AMD Family 10h thermal sensors' (confidence: 9)

Note: there is no driver for ITE IT8728F Super IO Sensors yet.
Check http://www.lm-sensors.org/wiki/Devices for updates.

No modules to load, skipping modules configuration.

Unloading i2c-dev... OK
Unloading cpuid... OK


I checked the lm-sensors website and they are supposed to have an update for this device for a while now. Currently, Psensor only shows one temp1 sensor and the cpu use.

So, my questions are:

1) Can "I" easily install the updated driver? Never did a driver before that wasn't in the repository.

2) If I can't easily install it, can you please put it on the list of things to do?

Thanks! Love Linux Mint!

8-)
Tex1954
Level 1
Level 1
 
Posts: 3
Joined: Tue Mar 26, 2013 4:05 pm

Linux Mint is funded by ads and donations.
 

Re: "lm-sensors" need upgrading??? PS: Linux Mint Rocks!

Postby Tex1954 on Fri Mar 29, 2013 1:49 pm

I'm surprised I didn't get a single response. This is a pretty active board and I thought somebody would know something or perhaps a developer looked in on things from time to time.

Guess not, so Bump for attention!

8-)
Tex1954
Level 1
Level 1
 
Posts: 3
Joined: Tue Mar 26, 2013 4:05 pm

Re: "lm-sensors" need upgrading??? PS: Linux Mint Rocks!

Postby dagon on Fri Mar 29, 2013 3:21 pm

Hi!

I actually peeked into this but didn't get that much wiser from it.
I checked the lm-sensors website and they are supposed to have an update for this device for a while now. Currently, Psensor only shows one temp1 sensor and the cpu use.

As I understand it that chip should be supported already.

The terminal messege forwards to the list of supported devices at the lm-sensors homepage:
http://www.lm-sensors.org/wiki/Devices

searching for "IT8728" on that page gives that The chip ITE IT8728F is supported since kernel 3.3

You can try and search for backported later packages as launchpad .ppa's etc. but I couldn't find any.

I think your left to download the latest source from here and building it yourself:
http://www.lm-sensors.org/wiki/Download

Also from that page:
Please read the README and INSTALL files of your working copy for how to build the code.
Image
User avatar
dagon
Level 7
Level 7
 
Posts: 1690
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden

Re: "lm-sensors" need upgrading??? PS: Linux Mint Rocks!

Postby Tex1954 on Fri Mar 29, 2013 4:09 pm

I thought it was supported as well, but the messages and output seem to contradict that notion...

Appreciate the info! Thanks!

I suppose I will give it a try... after I learn how.

8-)
Tex1954
Level 1
Level 1
 
Posts: 3
Joined: Tue Mar 26, 2013 4:05 pm


Return to Hardware Support

Who is online

Users browsing this forum: Peter Thomassen and 15 guests