no sound after suspend lenovo t60

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

no sound after suspend lenovo t60

Postby tadpole1954 on Wed Dec 05, 2012 1:17 pm

Hi all. Since Mint 12, I think, I have been having a problem with having no sound after I suspend my laptop. I have this using Mint and the corrisponding Ubuntu versions as well. I usually just log out/in to get my sound working again. It's not really that much effort to do this, but after all this time it has gotten to be a hassle and I'm considering changing my os to see if that would fix things.

I've searched the forums here and ubuntu and found scores of sound problems, but none that sounded like what I needed. Googled it as well. So, if anyone could chime in here with some suggestions I would really appreciate it. I've been using Mint for a good while now and I really don't want to move on. Mint is the best there is imho.
tadpole1954
Level 2
Level 2
 
Posts: 53
Joined: Thu Sep 11, 2008 8:20 pm

Linux Mint is funded by ads and donations.
 

Re: no sound after suspend lenovo t60

Postby tadpole1954 on Fri Dec 07, 2012 1:05 pm

Well, for what it's worth, I'm now convinced that this problem isn't Mint/Ubuntu related. I guess it's a hardware issue of some kind. I've been using a Live usb of Manjaro, and I set it to suspend like I do Mint. It gave me the exact same result. No sound after suspend. That's kinda disappointing in a way, but on the other hand, if I have to deal with this then I might as well deal with it using Mint. Later guys......................
tadpole1954
Level 2
Level 2
 
Posts: 53
Joined: Thu Sep 11, 2008 8:20 pm

Re: no sound after suspend lenovo t60

Postby iamk2 on Wed Mar 20, 2013 3:13 am

Doubt you will see this but it actually is a mint problem and not your PC - and on that note I am not putting all the blame on Mint. You will most likely find that your system will not lose sound with Sabayon - Here is why - I tried 9 diff distros with the same issue - all of the distros using a version of grub where the grub.conf file can be updated using the update-grub command fail to keep the sound alive after suspend. The distros that require you to use the make config sommand to update the grub.conf file keep the sound alive.
iamk2
Level 1
Level 1
 
Posts: 6
Joined: Sat Mar 09, 2013 3:07 am

Re: no sound after suspend lenovo t60

Postby kurtschoen on Wed Mar 27, 2013 12:46 am

This sequence solved same problem on my Thinkpad X230 :

Solution:
1. Go to Software Manager and install the GNOME ALSA Mixer
2. Go to this link:
https://code.launchpad.net/~ubuntu-audi ... /+packages

- Click on the Quantal package
- Click on the .deb package
- Click on "Save File"
- When the "Downloads" box pops up, click on the new download and then click on "Install"
- Restart computer and then test it out. You should be able to close computer lid, suspend, and then hear sound from the speakers when resuming.
kurtschoen
Level 1
Level 1
 
Posts: 25
Joined: Mon Jul 04, 2011 2:31 pm

Re: no sound after suspend lenovo t60

Postby deltree on Tue Apr 16, 2013 9:23 pm

The link in your last post seems to be broken so I'm posting the fix I found on another thread.

I ran alsamixer from terminal and saw that Auto-Mute Mode was Enabled :?
I Disabled it and my sound came back right away :D

Solution by bassamie on viewtopic.php?f=90&t=122801
There are 10 types of people in the world, those that understand binary, and those that don't.
User avatar
deltree
Level 1
Level 1
 
Posts: 5
Joined: Wed Apr 03, 2013 8:45 pm


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: Google [Bot] and 6 guests