Google Chrome and start menu problem

Questions about applications and software
Forum rules
Before you post please read this

Google Chrome and start menu problem

Postby HisDudeness on Thu Mar 28, 2013 2:51 pm

Hiya! I have installed Google Chrome downloading it from the official site and opening the .deb package with GDebi because I needed the latest version of Adobe's Flash Player to run a specific game. I then created a Start Menu entry myself (as obviously installing with GDebi doesn't make one) the way I usually do: cloning a similar program's entry and editing it:

Code: Select all
sudo cp /usr/share/applications/firefox.desktop /usr/share/applications/google-chrome.desktop
sudo pluma /usr/share/applications/google-chrome.desktop


Now my google-chrome.desktop looks like this:

[Desktop Entry]
Name=Google Chrome
Comment=Google's own web browser
GenericName=Web Browser
Exec=google-chrome
Terminal=false
X-MultipleArgs=false
Type=Application
Icon=/home/dude/Pictures/Icons/google-chrome.svg
Categories=Application;Internet;Network;WebBrowser;
MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/vnd.mozilla.xul+xml;application/rss+xml;application/rdf+xml;image/gif;image/jpeg;image/png;
StartupNotify=true


Everything went fine. I had my own Google Chrome entry with an icon I downloaded myself (can't stand the default square icon set) which is this one.

But then an update came out (version 26.0.1410.43) and, after having installed it via MintUpdate, the icon returned to be the square one. I edited the .desktop voice again (it had the same icon written in, but I made a useless change to put mine in another time and make it refresh) and the entry disappeared. I tried reloading Cinnamon, reloading the system, deleting google-chrome.desktop and creating it again, but still nothing.
Then I tried deleting it and creating a new launcher in the Main Menu options. Nothing appeared in the menu, even if my new launcher was visible in the Main Menu editor under the Internet submenu. After deleting it, it was automatically moved in the Other submenu, and this time present in the menu itself. What can I do?

I installed my system via the 201204 image, so I have the double DE system, but I'm using Cinnamon. For any information needed, ask me. Thank you all!
The Dude minds.
User avatar
HisDudeness
Level 1
Level 1
 
Posts: 38
Joined: Tue Oct 09, 2012 5:02 am
Location: Melzo, Italy

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 5 guests