[SOLVED] Screen blanking, halting all operations

Forum rules
Before you post please read how to get help

[SOLVED] Screen blanking, halting all operations

Postby gurran on Fri Mar 29, 2013 6:46 pm

I have been fighting with this for a couple of days now... I start a file move from my laptop to my flash drive - 6.7 GB. When I walk away for ~10 minutes the screen blanks and the flash drive is unmounted, downloads stop, and processes go to sleep. I have tried the xset commands from here with no luck. I have rummaged through 50-60 pages on google. I have disabled power management completely. My screensaver is off. I have restarted the file moving 12 times. I am frustrated to no end. Any help is appreciated.
Last edited by gurran on Sat Apr 13, 2013 10:31 pm, edited 1 time in total.
Desktop:
  • 4GB Ram
  • AMD Phenom 9750 Quad-Core Processor
  • 500GB SATA HDD with Windows 7 64-bit
  • 160GB SATA HDD with Linux Mint Petra KDE Edition
  • Rosewill 3.5" Card Reader with 3 Powered USB Ports
gurran
Level 1
Level 1
 
Posts: 23
Joined: Sat Feb 02, 2013 9:30 pm

Linux Mint is funded by ads and donations.
 

Re: Screen blanking, halting all operations

Postby homerscousin on Sat Mar 30, 2013 8:46 pm

I have been through this screen blanking almost nightmare. I tried every combo of settings I could see, but nothing completely cured it. I think this is a buggy aspect of Linux, all desktops. You might try instead of disabling screenblanking completely turning up the value from the default 10 minutes to e.g. 300 minutes like I did. That did help. The only thing so far, for the last month or so, that seems to have cured the problem was a kernel update to 3.5.0-23 and the update to KDE 4.10. Hundreds of files updated. I don't know what did what.
i5 3570k, ASRock z77 Extreme 4, 8 Gb Ripjaws 1600, Antec 430w psu, HVR 1600 tv tuner, custom case- marble top, oak face. Carver & DCM Time Window sound system. Mint 14 KDE.
homerscousin
Level 5
Level 5
 
Posts: 541
Joined: Fri May 25, 2012 2:43 pm
Location: Somewhere on planet Earth (mostly)

Re: Screen blanking, halting all operations

Postby catweazel on Sat Mar 30, 2013 11:01 pm

homerscousin wrote:this is a buggy aspect of Linux, all desktops.

Rubbish.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1655
Joined: Fri Oct 12, 2012 9:44 pm

Re: Screen blanking, halting all operations

Postby homerscousin on Sun Mar 31, 2013 12:35 pm

Rubbish.

So, I assume by that statement that you have completely cured this issue. Please share your insights. We dingbats would really like to know.
i5 3570k, ASRock z77 Extreme 4, 8 Gb Ripjaws 1600, Antec 430w psu, HVR 1600 tv tuner, custom case- marble top, oak face. Carver & DCM Time Window sound system. Mint 14 KDE.
homerscousin
Level 5
Level 5
 
Posts: 541
Joined: Fri May 25, 2012 2:43 pm
Location: Somewhere on planet Earth (mostly)

Re: Screen blanking, halting all operations

Postby catweazel on Sun Mar 31, 2013 5:52 pm

homerscousin wrote:
Rubbish.

So, I assume by that statement that you have completely cured this issue.

Yes. My systems do not suffer the problem, and never have.
Please share your insights. We dingbats would really like to know.

I'd love to, but I'm installing LMDE at the moment, and school is out for the long weekend.

Cheers.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1655
Joined: Fri Oct 12, 2012 9:44 pm

Re: Screen blanking, halting all operations

Postby gurran on Mon Apr 01, 2013 5:37 pm

I was able to fix it with turning off power management and modifying the xorg config file in Kubuntu 12.10, however Linux Mint 13 KDE is based off of Kubuntu 12.04. Also I cannot find the xorg config file in Mint 13...
Desktop:
  • 4GB Ram
  • AMD Phenom 9750 Quad-Core Processor
  • 500GB SATA HDD with Windows 7 64-bit
  • 160GB SATA HDD with Linux Mint Petra KDE Edition
  • Rosewill 3.5" Card Reader with 3 Powered USB Ports
gurran
Level 1
Level 1
 
Posts: 23
Joined: Sat Feb 02, 2013 9:30 pm

Re: Screen blanking, halting all operations

Postby catweazel on Tue Apr 02, 2013 12:57 am

gurran wrote:I cannot find the xorg config file in Mint 13...

xorg.conf is pretty much obsolete in linux distributions these days due to much better hardware detection, which is why there isn't one. However you can create your own mini xorg.conf just for the options you need, without the hassle of messing up your mouse and keyboard, and goodness knows what else.

I wrote a tutorial for nVidia cards that does exactly what I just described. You can read it here.

Of course, you'll have to make it appropriate for your own situation, but you'll get the idea.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1655
Joined: Fri Oct 12, 2012 9:44 pm

Re: Screen blanking, halting all operations

Postby gurran on Sat Apr 13, 2013 2:55 pm

When I created the xorg.conf with the items in the link it went to tty1 after reboot.

EDIT:
I forgot to add EndSection

UPDATE:
I got it working. If you want the xorg.conf you can find it here.
Desktop:
  • 4GB Ram
  • AMD Phenom 9750 Quad-Core Processor
  • 500GB SATA HDD with Windows 7 64-bit
  • 160GB SATA HDD with Linux Mint Petra KDE Edition
  • Rosewill 3.5" Card Reader with 3 Powered USB Ports
gurran
Level 1
Level 1
 
Posts: 23
Joined: Sat Feb 02, 2013 9:30 pm

Re: [SOLVED] Screen blanking, halting all operations

Postby gurran on Sat Apr 27, 2013 6:47 pm

I recently switched to a Debian Wheezy based distro (not LMDE) and I found that I had to add "Identifiers" to the sections. So if anyone downloads the xorg.conf I posted and tries to use it and your computer boots to TTY then use nano, vim, or some other command line text editor to edit the file and add the following under Section "ServerLayout":
Code: Select all
   Identifier     "X.org Configured"

and this under Section "Monitor":
Code: Select all
   Identifier     "Monitor0"

and reboot. That should fix it.
Desktop:
  • 4GB Ram
  • AMD Phenom 9750 Quad-Core Processor
  • 500GB SATA HDD with Windows 7 64-bit
  • 160GB SATA HDD with Linux Mint Petra KDE Edition
  • Rosewill 3.5" Card Reader with 3 Powered USB Ports
gurran
Level 1
Level 1
 
Posts: 23
Joined: Sat Feb 02, 2013 9:30 pm

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: xenopeek and 4 guests