Linux 13Maya Mate/ wrong default to sound

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Linux 13Maya Mate/ wrong default to sound

Postby jsplicer on Sun Mar 31, 2013 1:48 pm

Happy Easter! I'm using linux 13 Maya Mate. This same problem has happened in linux 14 KDE, and in Ubunto linux 12.10. The sound codec defaults on startup after every reboot. It defaults to "HDA Nvidia digital stereo sound". Which I don't have on my mother board I don't have "any" sound cards hooked up to my motherboard. There is also a choice for "built in audio analog Stereo" I have built in Azelia codec that is set to Auto on the motherboard the only other choice is off (if I was using a sound card).

When I go back into Audio settings in the control panel and set it to 'built in Analog Audio- stereo output' my sound works fine.

The strange thing is, is that I don't have any sound cards in my computer at all. My Sound codec is "Realtek ALC889A Codec High definition Audio", the hookups are for either 2/4/5.1/7.1 it even has dolby digital surround sound. The sound on the mother board is working or I wouldn't get any sound at all when I choose "built in Audio" for output instead of the default nvidia digital sound it defaults to all the time.

I hope I provided enough info for someone to help me, my entire hardware specs are in my signature. Is there anyway to disable the Nvidia Digital souns choice from the control panel or the OS itself?

Thanks for any help,

John
OS: Linux Mint 17 KDE
Motherboard: Gigabyte EP45-UD3P Rev. 1.6 FE BIOS
CPU: Intel Core2Quad Q8400 2.66 GHz.
Memory: GSkill: 4 GB DDR2 800 MHz.
GPU: PCI-E 3 NVidia GEFORCE GTX 650 DDR 5, 1GB Ram
Drives: Int: 120 GiB SSD Samsumg REVO, 500 GiB WD HDD, Ext: USB 2 500 GiB HDD
jsplicer
Level 2
Level 2
 
Posts: 95
Joined: Sun Dec 30, 2012 2:39 pm

Linux Mint is funded by ads and donations.
 

Re: Linux 13Maya Mate/ wrong default to sound

Postby jsplicer on Sun Mar 31, 2013 3:53 pm

In case this is happening to any one else. I thought you may be pleased I found a solution that works for me anyway. There is a website on google called Techgage, well a search popped up in my query, therer were 2 options. Aparently my new Nvidia Video card had a sound codec on it that was taking over my sound. This isn't something that just happened to me, there are tons of people with the same problem.

So either rebuild the kernal and take out the offending driver, or do what I did...Blacklist it! You can always change it and its a lot safer than rebuilding you kernal if your not sure what you are doing (me) :).

So you go into /etc/modprobe.d/blacklist.conf with a text editor of your choice, I am used to nano so I used that, comment out what you are doing for future reference, then on the next line blacklist offending driver, save and reboot. Make sure you get the "exact name of the driver letter for letter, don't mis up underscores with dashes, even if you see dashes in the config file, there are underscores in there too. It matters because the first time I tried it I used dashes because that was the example the guy gave on the webpage, not his fault. If you are unsure of the exact name go into your control panel and go under kernals and look for the offending driver and write it down letter for letter.

I hope this helps someone else having this problem, no one seems to respond much in this forum to problems that don't have any obviuos solutions. If we help each other we can solve a lot of problems.

John
OS: Linux Mint 17 KDE
Motherboard: Gigabyte EP45-UD3P Rev. 1.6 FE BIOS
CPU: Intel Core2Quad Q8400 2.66 GHz.
Memory: GSkill: 4 GB DDR2 800 MHz.
GPU: PCI-E 3 NVidia GEFORCE GTX 650 DDR 5, 1GB Ram
Drives: Int: 120 GiB SSD Samsumg REVO, 500 GiB WD HDD, Ext: USB 2 500 GiB HDD
jsplicer
Level 2
Level 2
 
Posts: 95
Joined: Sun Dec 30, 2012 2:39 pm


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 2 guests