Problema con Grub

Spanish Forum

Moderator: vrkalak

Problema con Grub

Postby Adriana on Mon Apr 01, 2013 4:30 pm

Hola, he escrito en la consola el comando sudo update-grub y me dice esto:

/usr/sbin/grub-mkconfig: 12: /etc/default/grub: splash”: not found

¿Alguna solución para actualizar el Grub? Gracias.
Adriana
Level 1
Level 1
 
Posts: 44
Joined: Sat Nov 10, 2012 10:57 am

Linux Mint is funded by ads and donations.
 

Re: Problema con Grub

Postby linuxmint14 on Mon Apr 01, 2013 4:57 pm

Yo cuando tengo cualquier problemilla lo arreglo "a lo bruto manuel" tengo una particion independiente para mis datos, asi que formateo la particion del sistema y reinstalo mint14 en 10 minutos de reloj, y ya puedo seguir haciendole perrerias al sistema operativo...
Ya se que es poco ortodoxo, pero es una opcion mas.
linuxmint14
Level 1
Level 1
 
Posts: 36
Joined: Sun Feb 10, 2013 7:04 am

Re: Problema con Grub

Postby Adriana on Mon Apr 01, 2013 5:19 pm

Ésa es la opción que intento evitar, pero yo también le tengo mucha fe...
Adriana
Level 1
Level 1
 
Posts: 44
Joined: Sat Nov 10, 2012 10:57 am

Re: Problema con Grub

Postby nestoriano on Mon Apr 01, 2013 6:12 pm

Intenta regenerar las configuraciones de grub desde startupmanager o grub-customizer (ppa). Modificale el tiempo de arranque 1 segundo mas o 1 segundo menos y guarda la configuracion. Luego fijate si se ha arreglado el update-grub.
Si no funciona pega el contenido de /etc/default/grub.
nestoriano
Level 4
Level 4
 
Posts: 333
Joined: Thu Nov 08, 2012 7:15 pm

Re: Problema con Grub

Postby Adriana on Mon Apr 01, 2013 7:28 pm

Al final, era una tontería, las comillas de quiet splash eran inclinadas y no rectas... las cambié y sirvió, ya pude actualizar; aunque sigo sin ver la opción "Suspender" y el PC no se apaga.
Adriana
Level 1
Level 1
 
Posts: 44
Joined: Sat Nov 10, 2012 10:57 am

Re: Problema con Grub

Postby nestoriano on Mon Apr 01, 2013 10:10 pm

Antes de modificar cosas en /etc es recomendable hacerle una copia de respaldo del archivo porque lo que hay ahi son configuraciones que afectan a todo el sistema. Si algo sale mal puede pasar que no arranque, no apague, la grafica funciona mal, no hay flash, etc, y si hay una copia de respaldo con solo arrancar un livecd, restauras el archivo y problema solucionado.

Para solucionar todos los problemas que han aparecido en tu distro (tipo de problemas que a mi jamas me han ocurrido), creo yo que es hora de salvar las cosas importantes y reinstalar. Con el tiempo eso ocurre con menos frecuencia hasta que un dia, esa "solucion" sea cosa del pasado.
nestoriano
Level 4
Level 4
 
Posts: 333
Joined: Thu Nov 08, 2012 7:15 pm

Re: Problema con Grub

Postby Adriana on Tue Apr 02, 2013 5:29 am

Ya, precisamente por eso, pensando que me había cargado algo, hace 2 días instalé Mint 13 desde cero (nueva tabla de particiones incluida), al arrancar todo iba bien; pero tras actualizar pasó lo mismo que con la antigua instalación: dejaron de funcionar el flash y el apagado.

Lo del apagado ya he conseguido arreglarlo, cuento cómo, por si le sirve a alguien:

- He editado el archivo /etc/default/grub, teniendo mucho cuidado de que las comillas sean verticales y no inclinadas.
- He modificado la línea: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
- La he dejado así: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"
- Después, he reiniciado, tras actualizar el grub.
- Finalmente, he vuelto a dejar la línea GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" como estaba; pero, esta vez, sin actualizar el grub.

En mi caso, el error lo daba al actualizar el grub después de hacer los cambios.

Ahora voy a por el flash... ese cabrón no va a poder conmigo.
Adriana
Level 1
Level 1
 
Posts: 44
Joined: Sat Nov 10, 2012 10:57 am

Re: Problema con Grub

Postby linuxmint14 on Tue Apr 02, 2013 9:29 am

En mi teclado solo hay un tipo de comillas, espero por el bien de la humanidad que sean las buenas...
linuxmint14
Level 1
Level 1
 
Posts: 36
Joined: Sun Feb 10, 2013 7:04 am

Re: Problema con Grub

Postby Adriana on Tue Apr 02, 2013 5:34 pm

En efecto, las comillas rectas son las que hay en los teclados normales, el comando con la comilla "acostada" lo copié de no ssé qué tutorial de internet... aunque, en rigor, con el método "ensayo-error" he comprobado que el problema no es la forma de las comillas, sino que haya una recta y otra que no lo sea.

Son los problemas del copiar y pegar...
Adriana
Level 1
Level 1
 
Posts: 44
Joined: Sat Nov 10, 2012 10:57 am

Re: Problema con Grub

Postby linuxmint14 on Wed Apr 03, 2013 5:08 am

Que me vas a contar, por no hablar de los que te cambian un punto por una coma en medio de toda una secuencia o cosas similares, asins esta uno luego de la cabeza...
mu mala leche es lo que hay, creeme
linuxmint14
Level 1
Level 1
 
Posts: 36
Joined: Sun Feb 10, 2013 7:04 am

Re: Problema con Grub

Postby Adriana on Wed Apr 03, 2013 8:55 am

Esto es como cuando manejas código html, que cualquier tontería inadvertida te amarga la existencia.

Es la parte agria del método "Ensayo - Horror"...

¡Ah! Ya he dado con la tecla: GNASH. Varias personas me habían dicho que me olvidara del Flash Player de Adobe y usara Gnash; pero, claro, yo me iba a Synaptic y ponía, simplemente, eso, "Gnash" y me aparecía un paquete con ese nombre; yo lo instalaba, pero el problema de los vídeos en Youtube u otras páginas con flash no se arreglaba, porque Gnash es un reprductor local, offline.

Hay que instalar el paquete "mozilla-plugin-gnash", que - por cierto - también instala de forma automática el Gnash local.

Este es el espíritu Linux, dame un problema que voy a por él, sin acordarmke de Windows ni culpar a quien me hizo entrar en la maravillosa secta del Pingüino.

Estoy que me salgo.
Adriana
Level 1
Level 1
 
Posts: 44
Joined: Sat Nov 10, 2012 10:57 am

Linux Mint is funded by ads and donations.
 

Return to Español (Spanish)

Who is online

Users browsing this forum: No registered users and 5 guests