Weird bug with the program windows

Forum rules
Before you post please read how to get help

Weird bug with the program windows

Postby leopardpc on Sun Mar 31, 2013 1:10 pm

Hi guys I'm having this weird problem with the linuxmint-14-xfce 32bit distro that started after my sister used the pc. For some reason the close program and minimize window controls are missing from the top of all the program windows. My sis says she didn't do anything so I'm not sure how it could have happened. I've used a lot of different linux distro's and this is the first time i've seen something like this. Pics are below.
Attachments
PICT0030.JPG
PICT0027.JPG
leopardpc
Level 1
Level 1
 
Posts: 2
Joined: Sun Mar 31, 2013 1:01 pm

Linux Mint is funded by ads and donations.
 

Re: Weird bug with the program windows

Postby Orbmiser on Sun Mar 31, 2013 1:42 pm

1. In a terminal, enter

Code: Select all
xfwm4 --sm-client-disable


This should restore the desktop and the workspace switcher in the panel. If it doesn't...??

2. Open the run dialog with Alt+F2, and enter

Code: Select all
xfwm4 --replace


This should restart xfwm4 properly.
3. Make sure everything in your session is set up as you prefer, then log out with 'save session on exit'.
4. Log in again. Everything OK?
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1514
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: Weird bug with the program windows

Postby leopardpc on Mon Apr 01, 2013 3:21 pm

That last command worked thank you very much.
leopardpc
Level 1
Level 1
 
Posts: 2
Joined: Sun Mar 31, 2013 1:01 pm

Re: Weird bug with the program windows

Postby andreas on Mon Apr 01, 2013 6:04 pm

Orbmiser, THANK YOU!! I was having a similar problem (a bit worse, actually), and your well-written instructions saved the day.
andreas
Level 1
Level 1
 
Posts: 6
Joined: Sat Dec 22, 2012 12:56 pm

Re: Weird bug with the program windows

Postby Orbmiser on Mon Apr 01, 2013 11:28 pm

Wasn't me It was My Guru "Google" He let's me ask questions and shares his knowledge. :shock:
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1514
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: Weird bug with the program windows

Postby andreas on Tue Apr 02, 2013 12:30 am

Orbmiser wrote:Wasn't me It was My Guru "Google" He let's me ask questions and shares his knowledge. :shock:
.

Yeah, Google's great. I found your post using Google, which as you say had its origins in Google. The circle is now complete. :P
andreas
Level 1
Level 1
 
Posts: 6
Joined: Sat Dec 22, 2012 12:56 pm

Re: Weird bug with the program windows

Postby xfce13 on Thu May 09, 2013 12:56 pm

Hi there - I had this problem too. The following link mentions the problem and provides a solution:

http://rodmc.com/?p=975

The writer suggest entering "xfwm4 &" into the terminal. It worked for me but not sure what the "&" adds. There's no need for a reboot.

The review is positive about Mint xfce too.

Best wishes. Ed
xfce13
Level 1
Level 1
 
Posts: 3
Joined: Mon May 06, 2013 1:35 pm

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 4 guests