13 Maya LTS, WLAN, Broadcom BCM4311 ?

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help

13 Maya LTS, WLAN, Broadcom BCM4311 ?

Postby ahi on Tue Apr 02, 2013 1:35 pm

lspci ( command lspci run using ubuntu 12.04 LTS, I have not tried mint yet ) lists this as the WLAN device:

30:00.0 Network controller: Broadcom Corporation BCM4311 802.11a/b/g (rev 02)

however, on the net there's this info: "Booting gets stuck in systems with b43 wireless cards".

So, 1) how can I start linux Mint (13 Maya LTS) without it getting stuck ?

and: 2) How can I install support for the integrated wlan chip/card BCM4311 inside my HP Compaq laptop ?

Is there any way to do this so, that the problem would be already solved even if I boot Mint using a bootable CD or a USB memory stick made bootable using a .iso file that could be burn into a CD-R ?

Using Windows XP's (where the WLAN works just fine) device manager, I can see the following information:

Broadcom 802.11 a / b / g
memory: c80fc000 .. c80fffff
irq: 18

Vendor: 14e4
Device: 4312
Subsystem: 1371103c

Driver: BCMWL5.SYS version

using command lspci -vnn | grep 14e4 (under ubuntu 12.04 LTS) I get:

30:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11a/b/g [14e4:4312] (rev 02)

Under ubuntu (running from a usb memory stick) I have been unable to install the needed drivers for the WLAN device.

a note: The hardware switch for WLAN functionality is currently on.

IF it is turned off, then the line:

30:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11a/b/g [14e4:4312] (rev 02)

does NOT appear when command lspci -vnn | grep 14e4 is run.
Level 1
Level 1
Posts: 1
Joined: Tue Apr 02, 2013 11:58 am

Linux Mint is funded by ads and donations.

Re: 13 Maya LTS, WLAN, Broadcom BCM4311 ?

Postby karlchen on Wed Apr 03, 2013 4:27 pm

Hello, Ahi.

The original Ubuntu 12.04 installation ISO images, dated April 2012, were affected by several bugs. One of the bugs was likely to prevent Boradcom 43xx WLAN adapters from functioning.
Mint13 installation ISO images, dated May 2012 and later, are affected by the same bugs as the Ubuntu 12.04 ISO images.

Therefore the old trouble shooting instructions for Ubuntu 12.04 (no service pack) still apply to Mint13:
Boot hangs on systems using b43 wireless cards (Does not apply to the xfce editon only, but to all Mint 13 editions.)

Still using Linux Mint 14, 15, or 16? Upgrade to 17 asap!
Europeans: sudo apt-get purge ttip ceta
User avatar
Level 15
Level 15
Posts: 5929
Joined: Sat Dec 31, 2011 7:21 am

Return to Wireless

Who is online

Users browsing this forum: doylefermi and 3 guests