too much microphone echo on linux. please help.

Questions about applications and software
Forum rules
Before you post please read this

too much microphone echo on linux. please help.

Postby FurqanHanif on Tue Apr 02, 2013 11:41 am

when i use Skype to call my friend then a lot of echo sounds my microphone broadcast or send to my friend and he can't listen me clearly. but on windows there is no such echo in microphone. how can i solve this problem? any software which cancel my microphone echo. i also tried speex codec but no help.
please someone reply me.... :( :( :( i am using Linux mint 14 cinnamon.
(sorry for my English.)
User avatar
FurqanHanif
Level 3
Level 3
 
Posts: 136
Joined: Sun Dec 16, 2012 8:20 am

Linux Mint is funded by ads and donations.
 

Re: too much microphone echo on linux. please help.

Postby bigj231 on Tue Apr 02, 2013 11:52 am

Does skype have a built in echo cancellation? I don't recall seeing one in pulse. Another option (which I always use anyway) is a pair of headphones. No echo, great sound.
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Re: too much microphone echo on linux. please help.

Postby FurqanHanif on Tue Apr 02, 2013 1:51 pm

no, skype 4.0 version not have built in echo cancellation. i don't want to buy an headphone. i have built in microphone in my laptop. but why echo problem is not with window?
User avatar
FurqanHanif
Level 3
Level 3
 
Posts: 136
Joined: Sun Dec 16, 2012 8:20 am

Re: too much microphone echo on linux. please help.

Postby bigj231 on Tue Apr 02, 2013 2:20 pm

Because Windows has echo cancellation. I believe skype turns it on for you.
You might be able to find something with a Google search. Use the search term Ubuntu instead of Linux Mint if you can't find anything
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Re: too much microphone echo on linux. please help.

Postby FurqanHanif on Sun Apr 07, 2013 1:51 am

how can i enable echo cancellation in pulse audio. please reply....
User avatar
FurqanHanif
Level 3
Level 3
 
Posts: 136
Joined: Sun Dec 16, 2012 8:20 am

Re: too much microphone echo on linux. please help.

Postby nerdtron on Mon Apr 08, 2013 5:39 am

FurqanHanif wrote:when i use Skype to call my friend then a lot of echo sounds my microphone broadcast or send to my friend and he can't listen me clearly. but on windows there is no such echo in microphone. how can i solve this problem? any software which cancel my microphone echo. i also tried speex codec but no help.
please someone reply me.... :( :( :( i am using Linux mint 14 cinnamon.
(sorry for my English.)


Not an expert here but you might want to lower down the sensitivity of microphone? Maybe it would make a difference. Type this command in the terminal and adjust the settings.
Code: Select all
alsamixer
"I learned a lot from repeatedly breaking my system and then reinstalling. Oh, and a lot of GOOGLE searches too!"
User avatar
nerdtron
Level 4
Level 4
 
Posts: 281
Joined: Sun Jan 31, 2010 10:46 am

Re: too much microphone echo on linux. please help.

Postby bodwin on Mon Apr 08, 2013 6:43 am

Hi! You can have a look at a similar problem here: https://bbs.archlinux.org/viewtopic.php?id=146495 (reply #8) and http://arunraghavan.net/2011/08/hello-hello-hello/ if you have time to read some extra information. To quote the post from the first link:

That said, PulseAudio has an echo cancellation module that might help. Run:
Code: Select all
pactl load-module module-echo-cancel

and set Skype's audio input and output to the echo cancel source and sink.


My suggestion is, try running the command above, and see if there is anything in the skype settings that would
set Skype's audio input and output to the echo cancel source and sink.
I can't test echo cancelation on my computer now, so I can't really tell you if it will work, but it's worth a try. Good luck!
bodwin
Level 1
Level 1
 
Posts: 2
Joined: Sun Apr 07, 2013 12:24 pm

Re: too much microphone echo on linux. please help.

Postby FurqanHanif on Mon Apr 08, 2013 8:34 am

this command is giving me that error " Machine machine # pactl load-module module-echo-cancel
Connection failure: Connection refused
pa_context_connect() failed: Connection refused"

what i do now? :( :( :( :(
User avatar
FurqanHanif
Level 3
Level 3
 
Posts: 136
Joined: Sun Dec 16, 2012 8:20 am

Re: too much microphone echo on linux. please help.

Postby FurqanHanif on Wed Apr 10, 2013 9:41 am

please someone reply........ :( :( :(
User avatar
FurqanHanif
Level 3
Level 3
 
Posts: 136
Joined: Sun Dec 16, 2012 8:20 am

Re: too much microphone echo on linux. please help.

Postby bigj231 on Wed Apr 10, 2013 10:22 am

I had to build pulse from source to get some plugins in the past.
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: KhalVal and 15 guests