Nvidia drivers are throughing me for a loop.

Questions about applications and software
Forum rules
Before you post please read this

Nvidia drivers are throughing me for a loop.

Postby DartTimeTime on Wed Apr 03, 2013 8:03 pm

I was looking through the forums and couldn't find anything that helped so I just made a new one.

I 've been trying to install Nvidia drivers on my new laptop. It's a HP pavilion dv6t-7000 with an Nvidia 650m.
I'v installed Bumblebee
Code: Select all
 https://wiki.ubuntu.com/Bumblebee
the proper drivers
Code: Select all
 http://www.nvidia.com/Download/index.aspx?lang=en-us
.

What I did:
*Extract drivers.
*move them to /home
*Rename to 1.run
*Sudo service mdm stop
*sudo sh 1.run
* Sudo reboot

*Sudo service mdm stop
*sudo sh 1.run
* Sudo reboot

Resolution is now 640x600
*sudo add-apt-repository ppa:bumblebee/stable
*sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
*sudo apt-get update
*sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic
*sudo reboot

*sudo optirun nvidia-settings -c :8
I change the resolusion to my native resolution( 1366x765)
*sudo reboot

One of two thinks happen.
Either the defult drivers are loaded again.
-or-
The display is now at 640x600 again.
Bumblebee would no longer functional and I couldn't access Nvidia-Settings or Nvidia-Xserver.

I've reinstalled Mint out of frustration so I have a clean system.
I would really appreciate some help. Thanks in advance.
DartTimeTime
Level 1
Level 1
 
Posts: 26
Joined: Tue Apr 02, 2013 11:59 am

Linux Mint is funded by ads and donations.
 

Re: Nvidia drivers are throughing me for a loop.

Postby spcastelli on Thu Apr 04, 2013 12:00 am

Why don't you try the menu selection PREFERENCES / ADDITIONAL DRIVERS?

That is how I installed my Nvidia drivers. It even gives you the option of selecting the version you want.
spcastelli
Level 1
Level 1
 
Posts: 4
Joined: Thu Mar 21, 2013 2:35 pm

Re: Nvidia drivers are throughing me for a loop.

Postby kiwi on Thu Apr 04, 2013 1:02 am

I did it a slightly different way. Mainly because I like Synaptic.

Mint fires up with Nouveau drivers so I used Synaptic :

1. remove X.Org X server -- Nouveau display drive
2. install Nvidia driver of choice -- perhaps current-dev
3. install nvidia settings

Exit Synaptic. Restart your system.

4. open the nvidia x-server settings (main menu)
and set up for your monitors
5. save the config file
6. make edits to xorg.conf and blacklists to avoid suspend issues as explained in this web site.
https://help.ubuntu.com/community/Binar ... wto/Nvidia

I used a more extensive blacklist to cover the intel driver in my system:
blacklist intel_agp
blacklist nouveau
blacklist lbm-nouveau
blacklist i915
User avatar
kiwi
Level 1
Level 1
 
Posts: 24
Joined: Thu Nov 08, 2012 4:48 am
Location: Australia

Re: Nvidia drivers are throughing me for a loop.

Postby DartTimeTime on Thu Apr 04, 2013 2:34 am

Hi kiwi. Thanks for replying.

I'll give it a go tomorow. I'll let you know if that works.
DartTimeTime
Level 1
Level 1
 
Posts: 26
Joined: Tue Apr 02, 2013 11:59 am

Re: Nvidia drivers are throughing me for a loop.

Postby Jamesc359 on Thu Apr 04, 2013 3:50 am

Have you tried nvidia-xconfig?
“Gosh, you've... really got some nice toys here.”
User avatar
Jamesc359
Level 3
Level 3
 
Posts: 117
Joined: Sun May 06, 2012 1:42 pm

Re: Nvidia drivers are throughing me for a loop.

Postby DartTimeTime on Thu Apr 04, 2013 9:28 am

@Jamesc 359 Nvidia-Xconfig has, ultimatly, no results. It changes nothing.
Last edited by DartTimeTime on Thu Apr 04, 2013 11:40 am, edited 1 time in total.
DartTimeTime
Level 1
Level 1
 
Posts: 26
Joined: Tue Apr 02, 2013 11:59 am

Re: Nvidia drivers are throughing me for a loop.

Postby DartTimeTime on Thu Apr 04, 2013 11:36 am

@kiwi, I could use some more help.

Code: Select all
######@####### ~ $ inxi -G
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
Card-2: NVIDIA GK107 [GeForce GT 650M]
X.Org: 1.13.0 drivers: intel (unloaded: nvidia,fbdev,vesa) Resolution: 640x480@59.9hz
GLX Renderer: N/A GLX Version: N/A


something didn't work.

Every single time. I try "sudo nvidia-settings" I get
Code: Select all
You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.


"sudo nvidia-xconfig " seems to write alright, but nothing seems to change.

Also something weird. At login I see a greay box to the right of the screen, It's moving too quickly too read but I did catch 1366 x 768 (my laptops native resolution)
DartTimeTime
Level 1
Level 1
 
Posts: 26
Joined: Tue Apr 02, 2013 11:59 am

Re: Nvidia drivers are throughing me for a loop.

Postby kiwi on Thu Apr 04, 2013 6:09 pm

Three commands I used to figure out what was happening (google and man them for more details).

lspci | grep VGA ... to see the pci controllers making sure you have an nvidia one

cat /var/log/Xorg.0.log |less ... the log so you can ckeck what has been happening (what's loaded)

Code: Select all
[    18.600] (II) LoadModule: "glx"
[    18.622] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[    18.668] (II) Module glx: vendor="NVIDIA Corporation"
[    18.668]    compiled for 4.0.2, module version = 1.0.0
[    18.668]    Module class: X.Org Server Extension
[    18.668] (II) NVIDIA GLX Module  304.43  Sun Aug 19 20:34:01 PDT 2012
[    18.668] Loading extension GLX
[    18.668] (II) LoadModule: "nvidia"
[    18.668] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[    18.683] (II) Module nvidia: vendor="NVIDIA Corporation"
[    18.683]    compiled for 4.0.2, module version = 1.0.0
[    18.683]    Module class: X.Org Video Driver
[    18.686] (II) NVIDIA dlloader X Driver  304.43  Sun Aug 19 20:15:32 PDT 2012
[    18.686] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    18.687] (++) using VT number 7

[    18.695] (II) Loading sub module "fb"
[    18.695] (II) LoadModule: "fb"
[    18.695] (II) Loading /usr/lib/xorg/modules/libfb.so
[    18.696] (II) Module fb: vendor="X.Org Foundation"
[    18.696]    compiled for 1.13.0, module version = 1.0.0
[    18.696]    ABI class: X.Org ANSI C Emulation, version 0.4
[    18.696] (II) Loading sub module "wfb"
[    18.696] (II) LoadModule: "wfb"
[    18.696] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    18.696] (II) Module wfb: vendor="X.Org Foundation"
[    18.696]    compiled for 1.13.0, module version = 1.0.0
[    18.696]    ABI class: X.Org ANSI C Emulation, version 0.4
[    18.696] (II) Loading sub module "ramdac"
[    18.696] (II) LoadModule: "ramdac"
[    18.696] (II) Module "ramdac" already built-in
[    18.699] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    18.699] (==) NVIDIA(0): RGB weight 888
[    18.699] (==) NVIDIA(0): Default visual is TrueColor
[    18.699] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    18.699] (**) NVIDIA(0): Option "Stereo" "0"
[    18.699] (**) NVIDIA(0): Option "nvidiaXineramaInfoOrder" "DFP-0"
[    18.699] (**) NVIDIA(0): Stereo disabled by request
[    18.699] (**) NVIDIA(0): Option "NvAGP" "1"
[    18.699] (**) NVIDIA(0): Option "MetaModes" "DFP-0: 1680x1050 +0+0, DFP-1: 1680x1050 +1680+0"
[    18.699] (**) NVIDIA(0): Enabling 2D acceleration
[    18.699] (**) NVIDIA(0): Use of NVIDIA internal AGP requested
[    20.124] (II) NVIDIA(GPU-0): Display (LG Electronics W2242 (DFP-0)) does not support NVIDIA
[    20.124] (II) NVIDIA(GPU-0):     3D Vision stereo.
[    20.165] (II) NVIDIA(GPU-0): Display (LG Electronics W2242 (DFP-1)) does not support NVIDIA
[    20.165] (II) NVIDIA(GPU-0):     3D Vision stereo.


sudo lshw | less ... the current view of what is loaded and running

Code: Select all
            configuration: driver=pcieport
             resources: irq:40 ioport:e000(size=4096) memory:f4000000-f70fffff ioport:e0000000(size=268435456)
           *-display
                description: VGA compatible controller
                product: G94 [GeForce 9600 GT]
                vendor: NVIDIA Corporation
                physical id: 0
                bus info: pci@0000:01:00.0
                version: a1
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
                configuration: driver=nvidia latency=0
                resources: irq:16 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f4000000-f5ffffff ioport:e000(size=128) memory:f7000000-f707ffff
        *-display UNCLAIMED ####### unclaimed after I blacklisted the i915 driver ##########
             description: Display controller
             product: Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 09
             width: 64 bits
             clock: 33MHz
             capabilities: msi pm bus_master cap_list
             configuration: latency=0
             resources: memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)



I found that the i915 driver was potentially active and blacklisted it.

Look at what's being loaded. Perhaps uninstall the intel drivers. When you know its name, add it to the blacklist.

I can't promise that this will be easy (until you find the right combination). Basically I believe that the trick is:

Have the nvidia stuff loaded.
Have the intel stuff unloaded.
Blacklist the intel drivers.
User avatar
kiwi
Level 1
Level 1
 
Posts: 24
Joined: Thu Nov 08, 2012 4:48 am
Location: Australia

Re: Nvidia drivers are throughing me for a loop.

Postby eMcE on Mon Apr 08, 2013 7:24 am

Miłość i prawda rządzą :] a hipokrytom chooy w tylny exit :]
Image
User avatar
eMcE
Level 3
Level 3
 
Posts: 109
Joined: Tue Oct 30, 2012 9:53 am
Location: Czołg.. Gdzieś na pustyni..

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Preyed and 11 guests