Airplay from Mint to Sony wireless speaker not working

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help

Airplay from Mint to Sony wireless speaker not working

Postby dadnal on Sun Apr 07, 2013 3:34 pm

tl;dr: I've got an airplay speaker and want to use it on Mint 14. Using pulseaudio with raop-plugin, I can choose the speaker as an output device but it doesn't give a sound. Output stalls on banshee and totem (progress bar of current title doesn't move), vlc player doesn't stall but doesn't give sound, too. Output from a Macbook and a Windows pc are fine. Logs suggest that pulseaudio sends a command the speaker does not understand.

----

After a lot of searching and trying I'm somewhat out of ideas. I want to stream music from my laptop (inxi output below) to my new Sony NAS 510 wireless speaker http://www.sony.co.uk/product/wireless-speakers/sa-ns510 by just using it like a local speaker.
The speaker supports airplay and DLNA. My knowledge supports neither, I'm new to this topic, but as far as I understand, I want to use airplay because DLNA would require me to use the speaker as an active client and not as simple as a local speaker. If I'm wrong with that, please point me to a howto, I didn't find one.

Following the airplay howtos I found, I installed the pulseaudio addons like paprefs and pulseaudio-module-raop. In paprefs GUI, I chose the option "Make discoverable Apple AirTunes sound devices available locally". Using volume control, I now can choose my network speaker as an output device. Doing that, the problem described above occurs: no sound from that device, either stalling the play bar or at least leaving me in silence. I tried restarting every service and the system, no effect. I tried a clean system (that's why I'm writing from usb stick system now), no success.
Starting pulseaudio in -vvv mode, I get a lot of output: http://pastebin.com/5NvJZTvR

I think the most relevant part is almost at the end (Rolands-Lautdings is the name of the speaker, although I renamed it between logs to test if the space/hyphen causes the problem)

D: [pulseaudio] module-device-restore.c: Could not set format on sink raop.Rolands-Lautdings.local
D: [pulseaudio] module-suspend-on-idle.c: Sink raop.Rolands-Lautdings.local becomes idle, timeout in 5 seconds.
I: [pulseaudio] module.c: Loaded "module-raop-sink" (index: #20; argument: "server=[192.168.178.38]:1098 sink_name=raop.Rolands-Lautdings.local sink_properties='device.description="Rolands Lautdings"'").
D: [pulseaudio] rtsp_client.c: Established RTSP connection from local ip 192.168.178.27
D: [pulseaudio] raop_client.c: RAOP: CONNECTED
D: [pulseaudio] rtsp_client.c: Sending command: ANNOUNCE
D: [pulseaudio] rtsp_client.c: Full response received. Dispatching
D: [pulseaudio] raop_client.c: RAOP: ANNOUNCED
D: [pulseaudio] rtsp_client.c: Sending command: SETUP
W: [pulseaudio] rtsp_client.c: Unexpected response: RTSP/1.0 500 Internal Server Error
W: [pulseaudio] rtsp_client.c: Unexpected response: Server: AirTunes/103.2
W: [pulseaudio] rtsp_client.c: Unexpected response: CSeq: 2
W: [pulseaudio] rtsp_client.c: Unexpected response:


Output when I change the device in volume control to the network speaker:

D: [alsa-source] alsa-source.c: hwbuf_unused=0
D: [alsa-source] alsa-source.c: setting avail_min=15943
D: [alsa-source] alsa-source.c: Requested volume: 0: 13% 1: 13%
D: [alsa-source] alsa-source.c: in dB: 0: -54.00 dB 1: -54.00 dB
D: [alsa-source] alsa-source.c: Got hardware volume: 0: 13% 1: 13%
D: [alsa-source] alsa-source.c: in dB: 0: -54.00 dB 1: -54.00 dB
D: [alsa-source] alsa-source.c: Calculated software volume: 0: 100% 1: 100% (accurate-enough=yes)
D: [alsa-source] alsa-source.c: in dB: 0: 0.00 dB 1: 0.00 dB
D: [alsa-source] source.c: Volume not changing
D: [pulseaudio] module-suspend-on-idle.c: Source alsa_input.pci-0000_00_1b.0.analog-stereo becomes idle, timeout in 5 seconds.
D: [pulseaudio] module-suspend-on-idle.c: Source alsa_input.pci-0000_00_1b.0.analog-stereo becomes idle, timeout in 5 seconds.
D: [pulseaudio] core.c: Hmm, no streams around, trying to vacuum.
I: [pulseaudio] source-output.c: Freeing output 0 "Peak detect"
I: [pulseaudio] client.c: Freed 9 "MATE Volume Control Dialog"
I: [pulseaudio] protocol-native.c: Connection died.
I: [pulseaudio] module-stream-restore.c: Synced.
I: [pulseaudio] module-suspend-on-idle.c: Source alsa_input.pci-0000_00_1b.0.analog-stereo idle for too long, suspending ...
D: [pulseaudio] source.c: Suspend cause of source alsa_input.pci-0000_00_1b.0.analog-stereo is 0x0004, suspending
I: [alsa-source] alsa-source.c: Device suspended...
D: [pulseaudio] core.c: Hmm, no streams around, trying to vacuum.
D: [pulseaudio] reserve-wrap.c: Device lock status of reserve-monitor-wrapper@Audio0 changed: not busy
D: [pulseaudio] module-udev-detect.c: /dev/snd/controlC0 is accessible: yes


and finally pressing play on vlc player:
http://pastebin.com/U6BVNc37

Well... here I am. I suspect the problem is arising it's because of pulseaudio sending something to the speaker it doesn't understand and doesn't initialize the connection correctly (I updated the speakers firmware, no success). I guess I will try posting this to pulseaudio people and Sony people as well, maybe someone knows more about this.
In the meantime, maybe someone else got an idea what to try to work around (or maybe even solve, if I'm mistaken) this problem?

Thanks for any helpful answer.


inxi output (currently booted from usb stick), only relevant stuff

System: Host: mint Kernel: 3.5.0-17-generic x86_64 (64 bit, gcc: 4.7.2) Desktop: N/A Distro: Linux Mint 14 Nadia
Machine: System: LENOVO product: 1298A8G version: ThinkPad Edge E320
Mobo: LENOVO model: 1298A8G Bios: LENOVO version: 8NET32WW (1.16 ) date: 12/01/2011
Audio: Card: Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture ver: 1.0.25
Network: Card-1: Atheros AR8151 v2.0 Gigabit Ethernet driver: atl1c ver: 1.0.1.0-NAPI port: 2000 bus-ID: 08:00.0
IF: eth0 state: down mac: <filter>
Card-2: Intel Centrino Wireless-N 1000 driver: iwlwifi ver: in-tree: bus-ID: 02:00.0
IF: wlan0 state: up mac: <filter>
Info: Processes: 179 Uptime: 3:41 Memory: 656.9/3868.4MB Runlevel: 2 Gcc sys: 4.7.2 Client: Shell inxi: 1.8.4
dadnal
Level 1
Level 1
 
Posts: 1
Joined: Sun Apr 07, 2013 2:21 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: cakehead and 5 guests