LMDE X-server issues on dell xps m1750

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

LMDE X-server issues on dell xps m1750

Postby dorkvader on Tue Apr 09, 2013 1:15 pm

I try to only ask questions after much research ('cause I learn more that way) and becuase I try to ask questions the smart way

I have a dell xps m1750 that had been running ubuntu (11.04). SInce it's no longer supported, I am reloading it with LMDE, on the theory that a rolling release wil be supported longer.

It works with most of the other Ubuntu/fedora/debian(crunchbang)/slitaz test media I've tried on it, but with all the linux mint flavours I've tried, it fails to load the x server.

I am booting to the USB properly, and the bootloader screen shows up just fine.

With the default boot options, it'll load up a screen that flashes red, green, blue, white, black, repeat.
After reading the following ( viewtopic.php?f=46&t=105955 ) I used the nomodeset cheatcode, which allowed me to get to a command-line (after some errors and much beeping). Now, I'm perfectly happy with this, but my co-workers insist on a GUI (otherwise I'd load a minimal distro to RAM and have done) so I must continue.

The issue seems to be the X server quits after not finding any screens to output to. Further investigation points to some issue loading the nVidia drivers.

So, I need the x-server to work. Is there any way I can load working graphics drivers. I don't care about if it's the nVidia or nouveau, proprietary or free, as long as it works. I see where you can

Additionally, is there any way to install from the command line? I've insalled normal debian this way before, but I can't find the script/command to run.

---
Oh, I was also looking up some other "flashig colours" issues with linux,a nd I saw a post here from quite some time ago
viewtopic.php?f=49&t=25597&start=0
I thoight it might be an issue with having multiple GPU's, as this dell sometimes has. I am reasonably sure our model only has the one, though.

Here's the system spec's
CPU: intel core2 duo T8300 @ 2.4 GHz
GPU: nVidia Corporation G84 [geforce 8700m GT] rev a1
RAM: 2.0 GiB

The currently working Ubuntu 11.04 install says
Kernel driver in use: nVidia
Kernel Modules: nvidia-current, nouveau, nvidiafb

Am I missing something with loading the x server / drivers in mint, or should I just try a different distro?


Thanks in advance.
---
Update 4-9-13 1:37 EST
Will reconfiguring the x-server work? That's pretty easy to do.

update 4-9-13 4:03 EST
I got this loaded by removing the drive and attaching it to a different computer, then swapping it back over and updating the nVidia driver. (and then reconfiguring the x-server, etc.) I am, however, still curious as to how to get it working without the need for another whole computer.
dorkvader
Level 1
Level 1
 
Posts: 1
Joined: Tue Apr 09, 2013 12:17 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: dkent59 and 24 guests