[Solution] Finally Fixed - ATI Catalyst Issues in LM12

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

[Solution] Finally Fixed - ATI Catalyst Issues in LM12

Postby luis84 on Mon Mar 12, 2012 3:13 am

Hello,

I have LM 12. If I boot from Live it works like a charm, looks great, etc. If I install it, I get insane graphical issues.

I narrowed the issue down to my ATI card (well Gnome 3's / ATI bug). Anyway, if I remove the ATI FLGRX drivers, it works a little, but still fails and freezes. If I remove all drivers, I get the old gnome MATE working (not good).

My question is , what drive or system does it use on Live? I want to make my installed version use the same driver or lack of, since it works fine in live, how would I force the installed version to work in that manner?

Thank you
Last edited by luis84 on Mon Mar 12, 2012 3:50 am, edited 1 time in total.
luis84
Level 1
Level 1
 
Posts: 8
Joined: Tue Jan 24, 2012 3:05 am

Linux Mint is funded by ads and donations.
 

Re: Works fine Live - Not when Installed (Display)

Postby luis84 on Mon Mar 12, 2012 3:49 am

Fixed!

Note: Anyone with issues with the ATI Video cards on Gnome 3 / LM 12 - READ THIS! This worked awesome on my Radeon HD 6800

Solution: Use catalyst 12.2 sriver from ATI

Issue: apt-get install fglrx DOES NOT WORK, it's not up to date.

Re: Solution: Manually download and install the driver.

Follow this guide:

(Note, if you are not in GUI, you can WGET the URL: wget http://www2.ati.com/drivers/linux/amd-d ... x86_64.run)
1. Get the Driver, download the .run file here (64 bit): http://support.amd.com/us/gpudownload/l ... ng=English

2. Open Terminal and goto the Download folder or where the file is and chmod it:

Code: Select all
cd /Home/(username)/Downloads
chmod +x amd-driver-installer-12-2-x86.x86_64.run


3. Get needed files, etc.

Code: Select all
sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases linux-headers-generic
sudo apt-get install ia32-libs
sudo ln -svT lib /usr/lib64


4. Make deb package (use this, it says Ubuntu but you know LM is Ubuntu based!)

Code: Select all
sudo sh ./amd-driver-installer-12-2-x86.x86_64.run --buildpkg Ubuntu/oneiric


5. Install the debs, if you get dependency errors, look at the names and do apt-get install (name), you shouldnt if you followed step 3.

Code: Select all
sudo dpkg -i fglrx*.deb


6. Make the xorg config (you just make a default)

Code: Select all
sudo aticonfig --initial -f


7. Reboot

Code: Select all
sudo reboot -n


Once you reboot, you'll be set. If you want to adjust settings, setup dual monitors, etc. Goto the "Menu" on the desktop and find "Catalyst Control Center (Administrative)". It all works.

I have tested a bunch, it seems pretty good. No ugly glitches and supports all resolutions as it should plus my dual monitor (One DVI / One VGA).

Finally.
luis84
Level 1
Level 1
 
Posts: 8
Joined: Tue Jan 24, 2012 3:05 am

Re: [Solution] Finally Fixed - ATI Catalyst Issues in LM12

Postby berkeleybass on Wed Apr 11, 2012 11:28 pm

I just purchased an HP Pavilion p6-2108p (AMD E2-3200 APU with Radeon(tm) HD Graphics × 2) and set it up as a dual boot: factory Windows 7 with LM12 64-bit. I experienced all of the issues described in this and other threads: initially, disastrous graphics with missing letters and panels etc.; then, by clicking on the Restricted Drivers icon, things were a LITTLE better, but not much. I still experienced the bad colors at the top and bottom, slanted letters on the menus, and LOTS of crashes. I then installed Catalyst 12.2, and things became dramatically better, but with many, many Gnome crashes. Luckily, I noticed that AMD has released Catalyst 12.3, which I downloaded and installed (first uninstalling 12.2) according to the instructions in the release notes (http://www2.ati.com/relnotes/Catalyst_11.10_Linux_Installer.pdf). Now things are much better, but certain activities (e.g., opening or closing certain windows, or switching workspaces by clicking on the workspace number in the lower panel) still cause Gnome to crash and reload. (Switching workspaces using Ctrl-Alt-Arrow does not seem to crash Gnome.)

By the way, I did not package the installer as a .deb; just installed it by chmoding and running the executable .run file.

I have a 3-year-old NVIDIA card in my old machine which I could remove and install on this one, but I'm wondering whether it would be worth the bother. (I recall that I purchased the NVIDIA card for the old machine because I was also experiencing lots of graphics issues under Ubuntu.) At this rate, the crashes are only happening about once or twice an hour, and they don't break anything.

Thoughts?
berkeleybass
Level 1
Level 1
 
Posts: 1
Joined: Wed Apr 11, 2012 11:09 pm

Re: [Solution] Finally Fixed - ATI Catalyst Issues in LM12

Postby Jaybarn on Wed Apr 10, 2013 5:55 am

Hi LUIS84

I would like to thank you for the fix. That is really a nice simple tutorial which is simple to understand.

You did great and thanks again. Was looking for a way to do it manually :)

Cheers and keep well
Jaybarn
Level 1
Level 1
 
Posts: 1
Joined: Wed Jan 26, 2011 7:57 am


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 16 guests