Edimax EW-7811Un working - almost!

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Edimax EW-7811Un working - almost!

Postby Iirijkg on Fri Jan 25, 2013 4:34 pm

So I installed Linux Mint 14, cinnamon x64 and quickling noticed an issue: The wifi dongle was picking up my wireless router, but not able to successfully connect. I spent a few days logging back and forth between my dual boot, trying this and that and the other. Due to my newness with linux, I was unable to successfully install the driver I pulled directly from the Edimax website. A bit more digging, however, allowed me to navigate through to the Realtek website where I grabbed the newest driver.

I followed some more instructions, but shifted them up a bit. Eseentially, I saw that the drivers were runnning (but obviously not working) so I closed them, installed the new driver, and everything worked like a charm. Until I rebooted.

Now, in order to get the wireless to work, I have to jump into the terminal and do the following:

iiri@JKGIIRI ~ $ lsmod | grep 8192
rtl8192cu 67616 0
rtl8192c_common 48779 1 rtl8192cu
rtlwifi 74705 1 rtl8192cu
mac80211 539908 3 rtl8192cu,rtl8192c_common,rtlwifi
iiri@JKGIIRI ~ $ sudo modprobe 8192cu
[sudo] password for iiri:
WARNING: /etc/modprobe.d/rt2800usb.conf line 1: ignoring bad line starting with 'sudo'
FATAL: Error inserting 8192cu (/lib/modules/3.5.0-17-generic/kernel/drivers/net/wireless/8192cu.ko): Device or resource busy

(I figured out that I couldn't start the new driver while the two others that I had shut down innitially were running, so I shut them down)

iiri@JKGIIRI ~ $ sudo rmmod -f rtl8192cu
iiri@JKGIIRI ~ $ sudo rmmod -f rtl8192c_common
iiri@JKGIIRI ~ $ lsmod | grep 8192
iiri@JKGIIRI ~ $ sudo modprobe 8192cu

WARNING: /etc/modprobe.d/rt2800usb.conf line 1: ignoring bad line starting with 'sudo'

And again, all is right in the world, and I have internet.

What can I do to either automate this process on startup, or fix the issue?
Level 1
Level 1
Posts: 1
Joined: Fri Jan 25, 2013 4:25 pm

Linux Mint is funded by ads and donations.

Re: Edimax EW-7811Un working - almost!

Postby agm8036 on Mon Feb 04, 2013 4:37 pm

I know that you have an outstanding question in your post. Unfortunately, I cannot help you. Instead I am seeking assistance from you.

After reading your post, if you consider yourself a newbie, I'm still in the womb! I am new to Linux. Up to this point, I've been able to stumble through and resolve most of my issues (which have all been created by me).

Anyway – I have an Edimax EW-7811Un. I've downloaded the Realtek Linux driver, filename... RTL8192xC_USB_linux_v3.4.4_4749.20121105.zip
(Linux Kernel 2.6.18~2.6.38 and Kernel 3.0.8 – v3.4.4_4749 – dated 2012/11/12)

I was hoping it was going to be simple install using GDebi Package Installer; however, no such luck.

The more I google searched and read about installing this device driver, the more confused I got.

I was relieved to see your post listing what I think are post-installation terminal commands.

Can you point me to a resource that will help me do the initial driver installation?? I'm hoping that it would be simple instruction – a Realtek Linux Driver Installation For Dummies, if you will.

And if I ever get to the point of installing the Realtek driver and using the USB dongle, do you think that my internal NIC card will still be seen by the system or will it disappear, never to be seen again?

I am running Mint Maya 32-bit. I'm hoping the instruction for your configuration will work on mine.

Thanks in advance for your time and help.
Level 1
Level 1
Posts: 4
Joined: Wed Jul 20, 2011 6:26 pm

Re: Edimax EW-7811Un working - almost!

Postby Catchpole on Sun Apr 07, 2013 2:55 am

Hi Iirijkg,

I am thinking of using the Edimax usb wifi and have been having a look around.
It appears that there is a driver within the dongle for windows and the operating system sees this first before the wifi.
This post about the Pi seemed to point to the fix by using usb_modeswitch.

I've not tried it yet but perhaps you can figure it out from there.
If you find a fix, please re-post for the benefit of all.
Desktop Computer:
Motherboard = Gigabyte GA-H61M-USB3V
CPU = Intel i3-3240 3.4GHz
Graphics card = nvidia GEFORCE 210
Operating system = Linux Mint 13 LTS (32bit)
Memory = 8GB
User avatar
Level 2
Level 2
Posts: 87
Joined: Sat Dec 24, 2011 4:15 am
Location: Leeds UK

Re: Edimax EW-7811Un working - almost!

Postby Sam234 on Wed Apr 10, 2013 9:33 am

Iirijkg wrote:So I installed Linux Mint 14, cinnamon x64 and quickling noticed an issue: The wifi dongle was picking up my wireless router, but not able to successfully connect....

Have you tried blacklisting the bad drivers by editing blacklist.conf ?

I.e sudo gedit /etc/modprobe.d/blacklist.conf

(replace gedit with your preferred text editor)
At the end of the file add the line:

blacklist rtl8192cu

If the correct driver will still not auto-start, edit etc/modules adding 8192cu on a new line
Level 1
Level 1
Posts: 13
Joined: Sun Feb 10, 2013 12:58 pm

Re: Edimax EW-7811Un working - almost!

Postby elavnave on Sun Aug 31, 2014 1:44 pm

If anyone is still searching for this answer (this particular post shows up first when you search "7811un linux mint"), here it is.

Download the driver in the form of a zip file from the Edimax website. Their download section is current, robust, and contains linux drivers for this device. It unzips as a folder, and you will see a file called 'install.sh' in the root of the recently-unzipped folder. Right-click the install.sh file and choose 'properties'. Go to the permissions tab and check the box for 'allow executing file as program'. Once that box is ticked, close the properties window. Now just double-click install.sh and choose 'Run in Terminal'.

It will make you put in your root password anywhere from 2-5 times depending which version of Mint you are running. It removes the bad driver that OP was talking about and installs a working one over top of it. It just plain works. I like this company. I have gotten this to work very easily on Mint 13 and 17, though it does not work "out of the box."

(Edited to enhance clarity and noob-friendliness.)
Level 1
Level 1
Posts: 22
Joined: Sat Mar 05, 2011 8:52 pm

Return to Hardware Support

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 11 guests